Hue with Lightify Plug

I am using Philips Hue Bridge with a Osram Lightify Plug. I run openHAB 2.0.0-1 (Release Build) with OpenHABian. I use only the Paper UI. When I scan the Hue bridge all things are found (lamps, plugs). I have also a device from Dresden Elektronik (FLS-PP lp) which can integrate without problem.

The Lightify Plug is problem:

  • I can create a thing for it, then when I try to create an item, I get an error. I found this message in the log:
    [WARN ] [] - Received HTTP PUT request at ‘items/Gees_Gast_Nachttischlampe_Dose’ with an invalid item type ‘SwitchItem’.
    When I create a new item there is only “SwitchItem” available as type.

  • The thing I have created for the plug shows “online” after creation. After some time (I haven´t measured the time) it goes to offline for no reason. I can then delete the item and recreate it and it will be online again. I have not found another way to get it online again.

exactly the same Problem here… any solution?

No. I think it is a bug since there is not other option in the dialog. I wonder if this is the right place for bug reports or if I should post it here:

now, it works.

i created a items file in “/etc/openhab2/items” (osramplug.items) which contains the follow String:

Switch Steckdose1 “Lampe Sideboard” [ “Switchable” ] {channel=“hue:0010:0017884875e3:4:switch”}

thats it

Great! That works. :slight_smile:

…but still configuration with the Paper UI still gives an error. :frowning:


Hello Gerd_Sender,

Did you already try it in Habmin?? Because there are also problems with change settings in zwave devices.

@Thetmar: I don´t know what you mean with HabMin. I use the Paper UI. Osram also used ZigBee (here via Philips Hue).

@billygeen: My plugs are mostly shown as “offline”. Because Hue shows them as offline Openhab does not update the status and HomeKit does not control them at all. :pensive:
Do have the same behaviour?

I found my problem: not Hue is loosing contact, HomeKit looses the contact to OpenHab. After a few minutes it is shown as “offline”.

Thanks, it works. Testet a lot of old suggestions regarding the same problem!