HUSBZ-1 Zigbee

So I have a HUSBZ-1 stick that is working fine for Z-Wave. However, when I try to use the Zigbee binding it is unable to find the Zigbee controller. I have noticed that the cp210x kernel driver is not getting loaded and when Id o it manually it does not find any devices. Any ideas what may be going wrong?

I’m running OpenHAB 2.3 on an Odroid C2 running Armbian.

The HUSBZ-1 uses an Ember chipset. Here is how I have mine configured:

  • Add the coordinator as an Ember EM35x Coordinator
  • Correct serial port of course
  • Software Port Control
  • 57600 Baud Rate

That worked for me.

Thanks for the response. Unfortunately a serial port isn’t created for the Ember EM35x Coordinator. I have /dev/ttyACM0 which is created for the z-wave controller. However, the cp210x driver is not creating anything for the Ember controller.

The driver doesn’t create the /dev/ttyACM0. If you plug in the device that “file” will appear no matter what.

However, if you installed some software like a driver that is accessing that device, then the Zigbee controller can’t access it. Only one piece of software can connect to a serial device at a time.

The cp210x driver isn’t going to create anything for Ember. They are from completely different companies and except for the fact that both “talk” zigbee have nothing in common. Nothing written for cp210x is ever going to work for an Ember coordinator.

The CP210x is from Silabs and is the chipset normally used by Ember. The EM35x will normally show up in this way (same with Telegesis as well given they are also using the EM357) - depending on the exact dongle and Ember chip in use.

I’m not really sure what you’re referring to here - the CP210x is a serial chip :confused:

I had my “c” words mixed up. I was thinking he was referring to “CC2531” and didn’t bother to double check. That’s what I get for assuming and not verifying. :flushed:

1 Like

Okay so here is the output of “dmesg | grep tty”

[ 0.000273] console [tty0] enabled
[ 0.576244] c81004c0.serial: ttyAML0 at MMIO 0xc81004c0 (irq = 13, base_baud = 1500000) is a meson_uart
[ 0.576281] console [ttyAML0] enabled
[ 35.228494] systemd[1]: Created slice system-getty.slice.
[ 36.553865] cdc_acm 1-1.2.2:1.0: ttyACM0: USB ACM device

/dev/ttyACM0 is working perfectly with the Z-wave binding. I’m not sure what ttyAML0 is.

Any idea why the Ember chip is not showing up? As mentioned above I can manually load the cp210x driver, but this is all I get:

[13497.812232] usbcore: registered new interface driver usbserial_generic
[13497.812303] usbserial: USB Serial support registered for generic
[13497.818517] usbcore: registered new interface driver cp210x
[13497.818601] usbserial: USB Serial support registered for cp210x

I have also tried manually adding an Ember EM35x Coordinator in PaperUI but it defaults to the /dev/ttyACM0 port and shows as offline. I’ve switched the flow control to software and the baud rate to 57600 to no avail.