HUSBZB Zigbee setup

Tags: #<Tag:0x00007f2fb63aaee8> #<Tag:0x00007f2fb63aad58>
  • Platform information:
    • OS: Windows 10 64bit
    • openHAB version: 2.3.0

Completely new to all this, so I apologize if this is in the wrong place. I searched around before posting, but wasn’t able to find what I needed. I just bought a HUSBZB USB stick to get started with OpenHab. I got the Zwave portion of the stick up and running easy enough, but I can’t get the Zigbee portion running and am at my wits end. When adding the Zigbee as a thing, the log gives me:

22:13:07.432 [DEBUG] [gbee.handler.ZigBeeCoordinatorHandler] - null: Configuration received (Coordinator).
22:13:07.433 [DEBUG] [gbee.handler.ZigBeeCoordinatorHandler] - null: Unhandled configuration parameter zigbee_initialise >> true.
22:13:07.434 [DEBUG] [gbee.handler.ZigBeeCoordinatorHandler] - null: Unhandled configuration parameter zigbee_channel >> -1.
22:13:07.434 [DEBUG] [gbee.handler.ZigBeeCoordinatorHandler] - null: Unhandled configuration parameter zigbee_panid >> 53970.
22:13:07.434 [DEBUG] [gbee.handler.ZigBeeCoordinatorHandler] - null: Unhandled configuration parameter zigbee_extendedpanid >> A4EE5C1D1F30CB07.
22:13:07.435 [DEBUG] [gbee.handler.ZigBeeCoordinatorHandler] - null: Unhandled configuration parameter zigbee_networkkey >> 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00.
22:13:07.437 [INFO ] [smarthome.event.ThingUpdatedEvent ] - Thing ‘zigbee:coordinator_ember:bad9d5b7’ has been updated.
22:13:07.445 [DEBUG] [rnal.ZigBeeNetworkStateSerializerImpl] - Saving ZigBee network state: Start.
22:13:07.448 [DEBUG] [rnal.ZigBeeNetworkStateSerializerImpl] - Saving ZigBee network state: Done.
22:13:07.448 [DEBUG] [gbee.internal.ZigBeeNetworkDiscoverer] - Network discovery task shutdown
22:13:07.456 [DEBUG] [le.ember.internal.ash.AshFrameHandler] - AshFrameHandler exited.
22:13:07.456 [DEBUG] [nding.zigbee.handler.ZigBeeSerialPort] - Serial port ‘COM4’ closed.
22:13:07.457 [DEBUG] [le.ember.internal.ash.AshFrameHandler] - AshFrameHandler close.
22:13:07.457 [DEBUG] [le.ember.internal.ash.AshFrameHandler] - AshFrameHandler close complete.
22:13:07.457 [DEBUG] [gbee.handler.ZigBeeCoordinatorHandler] - ZigBee network [zigbee:coordinator_ember:bad9d5b7] closed.
22:13:07.458 [DEBUG] [ing.zigbee.ember.handler.EmberHandler] - Initializing ZigBee Ember serial bridge handler.
22:13:07.458 [DEBUG] [gbee.handler.ZigBeeCoordinatorHandler] - Initializing ZigBee network [zigbee:coordinator_ember:bad9d5b7].
22:13:07.458 [DEBUG] [gbee.handler.ZigBeeCoordinatorHandler] - Channel -1
22:13:07.458 [DEBUG] [gbee.handler.ZigBeeCoordinatorHandler] - PANID 53970
22:13:07.459 [DEBUG] [gbee.handler.ZigBeeCoordinatorHandler] - EPANID A4EE5C1D1F30CB07
22:13:07.459 [DEBUG] [gbee.handler.ZigBeeCoordinatorHandler] - Key 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
22:13:07.459 [DEBUG] [gbee.handler.ZigBeeCoordinatorHandler] - Initialising network
22:13:07.462 [DEBUG] [gbee.handler.ZigBeeCoordinatorHandler] - Key String 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
22:13:07.463 [INFO ] [smarthome.event.ThingUpdatedEvent ] - Thing ‘zigbee:coordinator_ember:bad9d5b7’ has been updated.
22:13:07.463 [DEBUG] [gbee.handler.ZigBeeCoordinatorHandler] - Key initialised 2EA8C63EF78B5C7104ECAA2DF28AB8EC
22:13:07.464 [DEBUG] [gbee.handler.ZigBeeCoordinatorHandler] - Key final array 2EA8C63EF78B5C7104ECAA2DF28AB8EC
22:13:07.464 [DEBUG] [ing.zigbee.ember.handler.EmberHandler] - ZigBee Ember Coordinator opening Port:‘COM4’ PAN:d2d2, EPAN:A4EE5C1D1F30CB07, Channel:-1
22:13:07.465 [DEBUG] [gbee.handler.ZigBeeCoordinatorHandler] - Scheduling ZigBee start
22:13:08.465 [DEBUG] [gbee.handler.ZigBeeCoordinatorHandler] - ZigBee network starting
22:13:08.466 [DEBUG] [gbee.handler.ZigBeeCoordinatorHandler] - Initialising ZigBee coordinator
22:13:08.466 [DEBUG] [gbee.handler.ZigBeeCoordinatorHandler] - Key initialise 2EA8C63EF78B5C7104ECAA2DF28AB8EC
22:13:08.466 [DEBUG] [.zigbee.dongle.ember.ZigBeeDongleEzsp] - EZSP dongle initialize with protocol ASH2.
22:13:08.467 [DEBUG] [nding.zigbee.handler.ZigBeeSerialPort] - Connecting to serial port [COM4] at 57600 baud, flow control FLOWCONTROL_OUT_RTSCTS.
22:13:08.481 [DEBUG] [nding.zigbee.handler.ZigBeeSerialPort] - Serial port [COM4] is initialized.
22:13:08.481 [DEBUG] [le.ember.internal.ash.AshFrameHandler] - --> TX ASH frame: AshFrameRst []
22:13:08.482 [DEBUG] [le.ember.internal.ash.AshFrameHandler] - AshFrameHandler thread started
22:13:08.484 [DEBUG] [le.ember.internal.ash.AshFrameHandler] - ASH: TX EZSP queue: 1
22:14:56.681 [DEBUG] [gbee.discovery.ZigBeeDiscoveryService] - ZigBee coordinator is offline - aborted scan for zigbee:coordinator_ember:bad9d5b7
22:17:43.197 [DEBUG] [gbee.discovery.ZigBeeDiscoveryService] - ZigBee coordinator is offline - aborted scan for zigbee:coordinator_ember:bad9d5b7

Any suggestions?

Please use code fences. :wink:

It looks like you have the baud rate set properly. It won’t fix the issue, but you could also set the flow control to software. Does the log just stop there? Do you get the same error after an OH restart? Which driver are you using?

I read on another thread about the baud rate, so that’s how it got set properly. This snippet from the log was from trying to add a Zigbee device. Even after a restart I get the same error, so I believe my problem is that Openhab isn’t able to find/communicate with the Zigbee portion of the usb.

I followed this guide (from the Amazon page where i bought it) for the drivers.
Windows 10:

  1. Download Silicon Labs CP210x drivers
  2. Extract drivers to a folder
  3. Open Windows Device Manager (Win+X, M)
  4. Right-click on “Other Devices > HubZ Z-Wave Com Port” and select “Update driver”
  5. Select “Browse my computer for driver software”
  6. Select “Let me pick from a list of available drivers on my computer”
  7. Leave “Show All Devices” selected and click “Next”
  8. Click “Have Disk”
  9. Enter the folder name where you extracted the downloaded drivers
  10. Select “Silicon Labs CP210x USB to UART Bridge” and click “Next”
  11. Windows will prompt that it cannot confirm the device ID, click “Yes” to proceed.
  12. Repeat steps 4-11 for device “HubZ ZigBee Com Port”

This looks good.

I asked because with this version of the binding, I had to restart several times to get Zigbee to work. The coordinator would come online, but none of my devices would. It’s possible you could be running into the same thing, but I could be jumping to conclusions. Recent builds have corrected this. Would you be open to upgrading to an OH snapshot build?

I may have gotten a bit ahead of myself. I should of started with I have not been able to get the coordinator to come online at all yet, so that’s the issue I need help with first I suppose.

So I started fresh this evening and installed the 2.4 snapshot and addons. I got the z-wave controller running with no issues again. However trying to get the zigbee coordinator running still gives a status of “unknown”. Any suggestions?

Serial ports in Windows is pretty straight forward. I’d be looking at permissions (there’s some info in the docs and forum… I’ll look for some later). I don’t know if you would need to set the baud rate and flow control in Windows too, but I don’t see how it would hurt. If you keep striking out, I’ll grab a laptop and my controller and try it out.

I just randomly remembered something about this controller on Windows. Make sure you turn of the power management settings in Device Manager. I remember issues using Zensys Tools with it, and it was because Windows kept powering it down. You should always see a blue led lit up while it is plugged in. Not sure if this is the issue, but it would have been.

Thanks for the suggestions. I set the baud rate and flow control in windows just to be safe, as well as disabled power management, but even after a couple restarts the the status of the Ember coordinator is still “unknown” in openhab.

@rlkoshak do you know if EXTRA_JAVA_OPTS would be needed for a Windows install?

@jered6323, try putting this into your environment variables> system variables, and reboot.

EXTRA_JAVA_OPTS="-Dgnu.io.rxtx.SerialPorts=COM3:COM4"

Created a new entry in system variables and copy/pasted the new line, still no luck, status still says unknown.
Is there a way to find out what the reason it says unknown is? Like in a log somewhere or something?

Absolutely. It looks like you already have zigbee running in debug mode. Look through the openhab.log file from after a restart. The newer binding should have some better logging too.

Which version of Java are you using?

Exactly what do you mean by this? The bridge is added manually, so it can’t be “unknown”…

I do not know. I run in Docker on Linux and didn’t have to add any Java opts there. If that were required I would expect the status to show as offline, not unknown though.

Before Scott helped me set the baud correctly this is how the online status of mine showed up too. The coordinator shows up as expected but instead of showimg online or offline it said unknown. I suspect Jeremy is seeing the same.

1 Like

@chris Here’s a screenshot
Capture

@5iver Java version is 1.8.0_171
Here is a log of a fresh start.

2018-06-27 10:17:43.583 [DEBUG] [org.openhab.binding.zigbee.cc2531   ] - BundleEvent [unknown:512] - org.openhab.binding.zigbee.cc2531
2018-06-27 10:17:43.591 [DEBUG] [org.openhab.binding.zigbee.cc2531   ] - ServiceEvent REGISTERED - {org.eclipse.smarthome.core.thing.binding.ThingHandlerFactory}={service.id=114, service.bundleid=200, service.scope=bundle, component.name=org.openhab.binding.zigbee.cc2531.internal.CC2531HandlerFactory, component.id=9} - org.openhab.binding.zigbee.cc2531
2018-06-27 10:17:43.593 [DEBUG] [org.openhab.binding.zigbee.cc2531   ] - BundleEvent STARTING - org.openhab.binding.zigbee.cc2531
2018-06-27 10:17:43.594 [DEBUG] [org.openhab.binding.zigbee.cc2531   ] - BundleEvent STARTED - org.openhab.binding.zigbee.cc2531
2018-06-27 10:17:43.598 [DEBUG] [org.openhab.binding.zigbee          ] - BundleEvent [unknown:512] - org.openhab.binding.zigbee
2018-06-27 10:17:43.602 [DEBUG] [org.openhab.binding.zigbee          ] - ServiceEvent REGISTERED - {org.eclipse.smarthome.core.thing.binding.ThingHandlerFactory}={service.id=115, service.bundleid=199, service.scope=bundle, component.name=org.openhab.binding.zigbee.internal.ZigBeeHandlerFactory, component.id=10} - org.openhab.binding.zigbee
2018-06-27 10:17:43.603 [DEBUG] [org.openhab.binding.zigbee          ] - BundleEvent STARTING - org.openhab.binding.zigbee
2018-06-27 10:17:43.605 [DEBUG] [org.openhab.binding.zigbee          ] - BundleEvent STARTED - org.openhab.binding.zigbee
2018-06-27 10:17:43.613 [DEBUG] [org.openhab.binding.zigbee.telegesis] - BundleEvent [unknown:512] - org.openhab.binding.zigbee.telegesis
2018-06-27 10:17:43.618 [DEBUG] [org.openhab.binding.zigbee.telegesis] - ServiceEvent REGISTERED - {org.eclipse.smarthome.config.discovery.usbserial.UsbSerialDiscoveryParticipant}={service.id=116, service.bundleid=202, service.scope=bundle, component.name=org.openhab.binding.zigbee.telegesis.internal.discovery.ZigBeeTelegesisUsbSerialDiscoveryParticipant, component.id=11} - org.openhab.binding.zigbee.telegesis
2018-06-27 10:17:43.619 [DEBUG] [org.openhab.binding.zigbee.telegesis] - ServiceEvent REGISTERED - {org.eclipse.smarthome.core.thing.binding.ThingHandlerFactory}={service.id=117, service.bundleid=202, service.scope=bundle, component.name=org.openhab.binding.zigbee.telegesis.internal.TelegesisHandlerFactory, component.id=12} - org.openhab.binding.zigbee.telegesis
2018-06-27 10:17:43.620 [DEBUG] [org.openhab.binding.zigbee.telegesis] - BundleEvent STARTING - org.openhab.binding.zigbee.telegesis
2018-06-27 10:17:43.621 [DEBUG] [org.openhab.binding.zigbee.telegesis] - BundleEvent STARTED - org.openhab.binding.zigbee.telegesis
2018-06-27 10:17:43.624 [DEBUG] [org.openhab.binding.zigbee.xbee     ] - BundleEvent [unknown:512] - org.openhab.binding.zigbee.xbee
2018-06-27 10:17:43.628 [DEBUG] [org.openhab.binding.zigbee.xbee     ] - ServiceEvent REGISTERED - {org.eclipse.smarthome.core.thing.binding.ThingHandlerFactory}={service.id=118, service.bundleid=203, service.scope=bundle, component.name=org.openhab.binding.zigbee.xbee.internal.XBeeHandlerFactory, component.id=13} - org.openhab.binding.zigbee.xbee
2018-06-27 10:17:43.629 [DEBUG] [org.openhab.binding.zigbee.xbee     ] - BundleEvent STARTING - org.openhab.binding.zigbee.xbee
2018-06-27 10:17:43.630 [DEBUG] [org.openhab.binding.zigbee.xbee     ] - BundleEvent STARTED - org.openhab.binding.zigbee.xbee
2018-06-27 10:17:43.943 [INFO ] [er.internal.HomeBuilderDashboardTile] - Started Home Builder at /homebuilder
2018-06-27 10:17:43.955 [INFO ] [panel.internal.HABPanelDashboardTile] - Started HABPanel at /habpanel
2018-06-27 10:17:45.786 [INFO ] [.dashboard.internal.DashboardService] - Started Dashboard at http://192.168.1.130:8080
2018-06-27 10:17:45.787 [INFO ] [.dashboard.internal.DashboardService] - Started Dashboard at https://192.168.1.130:8443
2018-06-27 10:17:49.796 [INFO ] [thome.model.lsp.internal.ModelServer] - Started Language Server Protocol (LSP) service on port 5007
2018-06-27 10:17:50.450 [INFO ] [basic.internal.servlet.WebAppServlet] - Started Basic UI at /basicui/app
2018-06-27 10:17:50.470 [INFO ] [arthome.ui.paper.internal.PaperUIApp] - Started Paper UI at /paperui
2018-06-27 10:17:50.486 [INFO ] [sysfs.internal.SysfsUsbSerialScanner] - Cannot perform scans with this configuration: sysfsTtyDevicesDirectory: /sys/class/tty, devDirectory: /dev
2018-06-27 10:17:50.497 [INFO ] [sysfs.internal.SysfsUsbSerialScanner] - Cannot perform scans with this configuration: sysfsTtyDevicesDirectory: /sys/class/tty, devDirectory: /dev
2018-06-27 10:17:50.509 [INFO ] [sfs.internal.PollingUsbSerialScanner] - Do not start background scanning, as the configured USB-Serial scanner cannot perform scans on this system
2018-06-27 10:17:50.513 [INFO ] [sfs.internal.PollingUsbSerialScanner] - Do not start background scanning, as the configured USB-Serial scanner cannot perform scans on this system
2018-06-27 10:17:50.840 [DEBUG] [com.zsmartsystems.zigbee            ] - BundleEvent STARTING - com.zsmartsystems.zigbee
2018-06-27 10:17:50.843 [DEBUG] [com.zsmartsystems.zigbee            ] - BundleEvent STARTED - com.zsmartsystems.zigbee
2018-06-27 10:17:50.846 [DEBUG] [m.zsmartsystems.zigbee.dongle.cc2531] - BundleEvent STARTING - com.zsmartsystems.zigbee.dongle.cc2531
2018-06-27 10:17:50.847 [DEBUG] [m.zsmartsystems.zigbee.dongle.cc2531] - BundleEvent STARTED - com.zsmartsystems.zigbee.dongle.cc2531
2018-06-27 10:17:50.849 [DEBUG] [om.zsmartsystems.zigbee.dongle.ember] - BundleEvent STARTING - com.zsmartsystems.zigbee.dongle.ember
2018-06-27 10:17:50.851 [DEBUG] [om.zsmartsystems.zigbee.dongle.ember] - BundleEvent STARTED - com.zsmartsystems.zigbee.dongle.ember
2018-06-27 10:17:50.853 [DEBUG] [smartsystems.zigbee.dongle.telegesis] - BundleEvent STARTING - com.zsmartsystems.zigbee.dongle.telegesis
2018-06-27 10:17:50.855 [DEBUG] [smartsystems.zigbee.dongle.telegesis] - BundleEvent STARTED - com.zsmartsystems.zigbee.dongle.telegesis
2018-06-27 10:17:50.856 [DEBUG] [com.zsmartsystems.zigbee.dongle.xbee] - BundleEvent STARTING - com.zsmartsystems.zigbee.dongle.xbee
2018-06-27 10:17:50.889 [DEBUG] [com.zsmartsystems.zigbee.dongle.xbee] - BundleEvent STARTED - com.zsmartsystems.zigbee.dongle.xbee
2018-06-27 10:17:50.890 [DEBUG] [org.openhab.binding.zigbee.ember    ] - BundleEvent STARTING - org.openhab.binding.zigbee.ember
2018-06-27 10:17:50.902 [DEBUG] [org.openhab.binding.zigbee.ember    ] - ServiceEvent REGISTERED - {org.eclipse.smarthome.config.discovery.usbserial.UsbSerialDiscoveryParticipant}={service.id=322, service.bundleid=201, service.scope=bundle, component.name=org.openhab.binding.zigbee.ember.internal.discovery.ZigBeeEmberUsbSerialDiscoveryParticipant, component.id=200} - org.openhab.binding.zigbee.ember
2018-06-27 10:17:50.916 [DEBUG] [org.openhab.binding.zigbee.ember    ] - ServiceEvent REGISTERED - {org.eclipse.smarthome.core.thing.binding.ThingHandlerFactory}={service.id=323, service.bundleid=201, service.scope=bundle, component.name=org.openhab.binding.zigbee.ember.internal.EmberHandlerFactory, component.id=201} - org.openhab.binding.zigbee.ember
2018-06-27 10:17:50.917 [DEBUG] [org.openhab.binding.zigbee.ember    ] - BundleEvent STARTED - org.openhab.binding.zigbee.ember
2018-06-27 10:17:50.962 [DEBUG] [bee.discovery.ZigBeeDiscoveryService] - Creating ZigBee discovery service for zigbee:coordinator_ember:d0f84d4e
2018-06-27 10:17:50.963 [DEBUG] [bee.discovery.ZigBeeDiscoveryService] - Activating ZigBee discovery service for zigbee:coordinator_ember:d0f84d4e
2018-06-27 10:17:50.974 [DEBUG] [org.openhab.binding.zigbee.ember    ] - ServiceEvent REGISTERED - {org.eclipse.smarthome.config.discovery.DiscoveryService}={service.id=329, service.bundleid=201, service.scope=singleton} - org.openhab.binding.zigbee.ember
2018-06-27 10:17:51.122 [DEBUG] [org.openhab.binding.zigbee.ember    ] - ServiceEvent REGISTERED - {org.eclipse.smarthome.core.thing.binding.firmware.FirmwareUpdateHandler}={service.id=330, service.bundleid=201, service.scope=singleton} - org.openhab.binding.zigbee.ember
2018-06-27 10:17:51.261 [INFO ] [ui.habmin.internal.servlet.HABminApp] - Started HABmin servlet at /habmin
2018-06-27 10:17:53.151 [DEBUG] [ng.zigbee.ember.handler.EmberHandler] - Initializing ZigBee Ember serial bridge handler.
2018-06-27 10:17:53.152 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - Initializing ZigBee network [zigbee:coordinator_ember:d0f84d4e].
2018-06-27 10:17:53.152 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - Channel -1
2018-06-27 10:17:53.153 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - PANID 40903
2018-06-27 10:17:53.153 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - EPANID D767A8513BC83A06
2018-06-27 10:17:53.155 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - Key 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
2018-06-27 10:17:53.155 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - Key String 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
2018-06-27 10:17:53.158 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - Key initialised 7E0A9E38F87E173D0AF347B5F385AF6B
2018-06-27 10:17:53.158 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - Key final array 7E0A9E38F87E173D0AF347B5F385AF6B
2018-06-27 10:17:53.247 [DEBUG] [ng.zigbee.ember.handler.EmberHandler] - ZigBee Ember Coordinator opening Port:'COM4' PAN:9fc7, EPAN:D767A8513BC83A06, Channel:-1
2018-06-27 10:17:53.251 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - Scheduling ZigBee start
2018-06-27 10:17:53.637 [INFO ] [ing.zwave.handler.ZWaveSerialHandler] - Connecting to serial port 'COM3'
2018-06-27 10:17:53.655 [INFO ] [ing.zwave.handler.ZWaveSerialHandler] - Serial port is initialized
2018-06-27 10:17:53.661 [INFO ] [mmandclass.ZWaveSecurityCommandClass] - Update networkKey
2018-06-27 10:17:53.667 [INFO ] [ve.internal.protocol.ZWaveController] - Starting ZWave controller
2018-06-27 10:17:53.668 [INFO ] [ve.internal.protocol.ZWaveController] - ZWave timeout is set to 5000ms. Soft reset is false.
2018-06-27 10:17:54.253 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - ZigBee network starting
2018-06-27 10:17:54.254 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - Initialising ZigBee coordinator
2018-06-27 10:17:54.262 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - Key initialise 7E0A9E38F87E173D0AF347B5F385AF6B
2018-06-27 10:17:54.263 [DEBUG] [zigbee.dongle.ember.ZigBeeDongleEzsp] - EZSP dongle initialize with protocol ASH2.
2018-06-27 10:17:54.265 [DEBUG] [ding.zigbee.handler.ZigBeeSerialPort] - Connecting to serial port [COM4] at 57600 baud, flow control FLOWCONTROL_OUT_XONOFF.
2018-06-27 10:17:54.280 [DEBUG] [ding.zigbee.handler.ZigBeeSerialPort] - Serial port [COM4] is initialized.
2018-06-27 10:17:54.292 [DEBUG] [e.ember.internal.ash.AshFrameHandler] - AshFrameHandler thread started
2018-06-27 10:17:54.293 [DEBUG] [e.ember.internal.ash.AshFrameHandler] - --> TX ASH frame: AshFrameRst []
2018-06-27 10:17:54.313 [DEBUG] [e.ember.internal.ash.AshFrameHandler] - ASH: TX EZSP queue: 1
2018-06-27 10:17:56.766 [INFO ] [age.SerialApiGetInitDataMessageClass] - NODE 1: Node found
2018-06-27 10:17:56.767 [INFO ] [age.SerialApiGetInitDataMessageClass] - NODE 2: Node found
2018-06-27 10:17:56.767 [INFO ] [age.SerialApiGetInitDataMessageClass] - ZWave Controller using Controller API
2018-06-27 10:17:56.767 [INFO ] [age.SerialApiGetInitDataMessageClass] - ZWave Controller is Primary Controller
2018-06-27 10:17:56.767 [INFO ] [age.SerialApiGetInitDataMessageClass] - ------------Number of Nodes Found Registered to ZWave Controller------------
2018-06-27 10:17:56.768 [INFO ] [age.SerialApiGetInitDataMessageClass] - # Nodes = 2
2018-06-27 10:17:56.768 [INFO ] [age.SerialApiGetInitDataMessageClass] - ----------------------------------------------------------------------------

Keep going… there must be some more. From what you posted, everything is looking like it’s going well.

Nope, that’s where the log ends. Even after letting it sit for a bit, nothing more has shown up.

Interesting. This is the next bit of log that you are missing…

2018-06-14 05:33:55.589 [DEBUG] [s.zigbee.dongle.ember.internal.ash.AshFrameHandler] - <-- RX ASH frame: AshFrameRstAck [version=2, resetCode=11, Reset: Software]
2018-06-14 05:33:55.589 [DEBUG] [s.zigbee.dongle.ember.internal.ash.AshFrameHandler] - ASH: Connected

My guess is that there is no response from the device, and the initialisation therefore stalls. While we don’t see it here, I think the binding will have sent some low level commands to the dongle, and it never gets a response. You could try enabling trace log level which I think will show this.

Why it’s not responding is another question though - the data rate looks fine so I don’t see too many issues…

Could you please double check that the correct driver is installed for COM4?

I’m remembering someone else from the forum having this problem a while ago under Windows, but can’t remember if it was ever solved. Try setting the channel (25 is furthest from wifi), set Reset Controller to true, and then power off the PC, unplug/replug the stick to make sure it gets a power reset, then start it all up again. But set logging to trace before doing this (always listen to Chris… he knows best!).