HVC Mode for a KNX Thermostat

Hello everybody.

I am trying to control the operating mode of a Siemens RDG160N KNX Thermostat.

So far I had some succes using:
Things:
Type string: HAVCMode “Heating” [ ga=“20.102:3/4/8” ]*
Items
String HAVCMode “Mode” [%s]" { channel=“knx:device:bridge:generic:ClimaProduzione” }

I could not make it work using any other type than String.
However, using String does not seem appropriate and has effects on the feedback received from the thermostat: changing mode on the thermostat, for instance to Comfort Mode, set HVACMode item to “Comfort”.

Thank you for any suggestion.

I mus correct.
Things:
Type string: HAVCMode “Heating” [ ga=“20.102:3/4/8” ]
Items
String HAVCMode “Mode” [%s]" { channel=“knx:device:bridge:generic:HVACMode” }

I use the following:

thing

 Type number        : CV_program                          [ ga= "5.010:5/5/3" ]

Item

Number CV_programma        "program choice"         (Heating)               { channel="knx:device:bridge:generic:CV_program", autoupdate="true"}

sitemap

Selection item=CV_program    label="program"    mappings=[ 1="Comfort", 2="Standby", 3 = "Night", 4 = "frost protection" ]

Thank you Mark.

With your setting:

Things

 Type number:        HVACMode         "Heating"    [ ga="5.001:3/4/8" ]        
    }

Items

Number  HVACMode      "Clima Produzione [%d]"     <heating>       (Produzione)                        { channel="knx:device:bridge:generic:HVACMode", autoupdate="true" }

I get this error from the KNX layer:
[DEBUG] [x.internal.handler.DeviceThingHandler] - None of the configured GAs on channel ‘knx:device:bridge:generic:ClimaProduzione’ could handle the command ‘3’ of type ‘DecimalType’,

No messages to the KNX bus.
I am running OH version 2.4.0.

Did you set the datatype of your groupadress to 5.010 in the knx settings? And your things GA also to 5.010.
5.001 is percentage, 5.010 is a number.

1 Like

It works with DPT 5.010!
Apologies for mistyping it and thank you very much Mark.