I cant install bindings in the paper ui

I just installed openhab and when i open the paper ui and go to addons then bindings i cannot install anything. While i can see all the bindings I’m looking for when I click install the circle just spins and spins. I have tired leaving it and nothing happens. Then i go to Config then bindings in the paper ui the binding i tried to install doesn’t show as installed.

I have tried reinstalling openhabian on my rpi but nothing has changed. Any advice?

What kind of initial-setup have you chosed?


Try Standard or Demo

ok, do i have to reinstall then?

You can try ihis How to change package in Initial Setup page

ok thank you. i will try that

i tried that and there was no change. i reinstalled again too.
any other ideas?

What version and that plattform do you use?
What binding you try to install?
How lang did you wait?

i am using version 1.4.1 of openhabian on a rpi 2
i am trying to install the wifi led binding but no bindings work
i waited for 20 mins

any idea?

I don’t know openHabian versions, but if 1.4.1 contains openHab 2.3.0 then it might be a problem with the binding. Look for the recent posts on upgrading to 2.3.0 broke lots of people setup, just because the wifiled binding has some issues.
Try installing another binding.

I can’t get any bindings at all to work though. Nothing installs, the circle as it is installing just continues and if i refresh then i goes back to the install button. If i check the addons folder there is nothing.

I use 2.3.0 stable, checked to install this binding and get this error. It seems to be a problem…

2018-05-30 19:59:37.845 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-binding-wifiled': Error: Resource mvn:org.openhab.binding/org.openhab.binding.wifiled/2.3.0 does not contain a manifest

A other binding has to been installed.
Edit openhab2-userdata\config\org\openhab\addons.config, remove this binding in the first line and restart openHAB. Check openhab.log.

i cant install any bindings though.

Monitor openhab.log and post relevant info here

ok, will do

2018-05-30 20:53:34.422 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing ‘openhab-binding-hue, openhab-binding-wifiled, openhab-binding-bluetooth, openhab-binding-airquality, openhab-binding-anel1, openhab-binding-ecobee1, openhab-binding-homematic, openhab-binding-freeswitch1, openhab-binding-gpio1’: Error:

Resource mvn:org.openhab.binding/org.openhab.binding.wifiled/2.3.0 does not contain a manifest

that is the error i got when i tried installing a few different bindings