I have problems with connecting Mqtt after installing Openhab 2.5

Hello friends.
After switching from Orangepi zero to Raspberry pi3 for a more powerful configuration.
I installed Openhab 2.5 on the Pi, but I had trouble connecting to accessories via MQTT, although all the parameters and settings were the same as Openhab 2.4 on Orangepi zero.
Here I have a DHT11-esp8266 sensor (Bedroom Temp), and get an error while receiving the data they send in the log file as follows:

Client didn’t provide any credentials and MQTT anonymous mode is disabled. CId = esp8266-5c: cf: 7f: 3c: d: 52-ff

Note that with Openhab 2.4 on my Orangepi Zero it still works fine.
I have researched but not yet overcome, hope to receive your help. Sorry, my english is not good :slight_smile:

It’s recommended to not use the embedded broker as it is no longer supported. Try installing mosquitto using openhabian-config tool and remove the embedded broker.

Thanks for your guidance, I have tried to do so and this is the new problem I encountered, in both devices is the DHT11 sensor and Sonoff with the DHT22 sensor.

2020-01-09 23:08:46.580 [WARN ] [t.generic.ChannelStateTransformation] - Executing the JSONPATH-transformation failed: Invalid path ‘$.DHT11.Temperature’ in ‘29.80’

2020-01-09 23:08:52.396 [WARN ] [ofiles.JSonPathTransformationProfile] - Could not transform state ‘31.4’ with function ‘$.AM2301.Temperature’ and format ‘%s’


Try using JSONPATH:$.SI7021.Temperature for the transformation.

The %s should be %d as it’s a number.

I’m hardheaded and use files for everything so not sure about PaperUI setup but I can give file examples that may help. This is with sonoff basic and temp/humidity senor connected on GPIO.

Thing:

Bridge mqtt:broker:pibroker "pibroker" [ host="10.0.1.19", port=1883, secure=false, username="xxxxxx", password="xxxxxx" ]
{
    // Sonoffs
    Thing topic sonoff11 "Living Room Light" @ "Living Room" {
    Channels:
        Type switch : power       "Power"         [ stateTopic="stat/sonoff11/POWER", commandTopic="cmnd/sonoff11/POWER" ]
        Type number : temperature "Temperature"   [ stateTopic="tele/sonoff11/SENSOR", transformationPattern="JSONPATH:$.SI7021.Temperature" ]
        Type number : humidity    "Humidity"      [ stateTopic="tele/sonoff11/SENSOR", transformationPattern="JSONPATH:$.SI7021.Humidity" ]
    }

    Thing topic sonoff2 "Couch Light" @ "Couch Light" {
    Channels:
        Type switch : power        "Power"         [ stateTopic="stat/sonoff2/POWER", commandTopic="cmnd/sonoff2/POWER" ]
    }
}

Item:

Switch LivingRoom_Light "Living Room Light" <light>  ["Lighting"] { channel="mqtt:topic:pibroker:sonoff11:power" }
Number LivingRoom_Light_Temp "Temperature [%.1f °F]"      <temp>             { channel="mqtt:topic:pibroker:sonoff11:temperature" }
Number LivingRoom_Light_Humidity    "Humidity [%.1f %%]"    <humidity>       { channel="mqtt:topic:pibroker:sonoff11:humidity" }

Switch CouchLight "Couch Light" <light>  ["Lighting"]  { channel="mqtt:topic:pibroker:sonoff2:power" }

It still does not work with me.
I tried it with sonoff basic and temp / humidity senor (DHT22) connected on GPIO.

It still switches on and off and shows the correct status of the switch. And the temperature sensor still shows the same error, even though I deleted all the things, items and used your sample.
I think maybe version 2.5 has a change in JSON transformation, and I can’t understand it yet.

In your things file try using AM2301 rather than SI7021 and see if that changes anything. Also, check the tasmota github page and see if there is info on what should be used if niether of those two work.

Thank you so much.
I have solved my problem with Sonoff + DHT22 by linking to items, I leave the default and don’t choose to be JSONPATH as before.
For DHT11_esp8266, I left Transform Values blank and also left the default when linking items
:smile: