I need help with frustrating on-going z-wave delays

Hi all,

I’ve been playing with openHAB and z-wave for quite a long time now, as my spare time allows. I have had some spare time recently and was hoping to make some progress, but have struck a problem that has repeatedly defeated me.

My z-wave network suffers from delays. I have done a lot of reading around this and as far as I can tell it usually relates to having a bad node in your network, but I’m unable to identify the problem with mine.

I have erased and rebuilt my network a couple of times and each time I experience the same pattern; I add several nodes and the network works very well. Then at some point the network starts to experience delays. I send commands from paperui, or the sitemap, or the console, and either get no response from the device, or a delay of several seconds or more. Typically, I will get long delays when I first start sending commands, then the network becomes responsive again. This pattern is not perfectly consistent though.

I have set up debug logging for the z-wave binding, but I really am not able to interpret what it is showing me. I’ve uploaded the log to https://www.dropbox.com/s/by3nfzvc2w25bv5/openhab-zwave.log?dl=0.
The associated event log is as follows;

2020-01-22 22:46:03.918 [nt.ItemStatePredictedEvent] - DiningRoom_Down_Lights predicted to become 42
2020-01-22 22:46:03.948 [vent.ItemStateChangedEvent] - DiningRoom_Down_Lights changed from 100 to 42
2020-01-22 22:46:26.669 [ome.event.ItemCommandEvent] - Item 'LivingRoom_Floor_Light' received command ON
2020-01-22 22:46:26.710 [nt.ItemStatePredictedEvent] - LivingRoom_Floor_Light predicted to become ON
2020-01-22 22:46:26.730 [vent.ItemStateChangedEvent] - LivingRoom_Floor_Light changed from 0 to 100
2020-01-22 22:47:06.989 [vent.ItemStateChangedEvent] - LivingRoom_Floor_Light changed from 100 to 0
2020-01-22 22:47:40.405 [vent.ItemStateChangedEvent] - LivingRoom_Motion_Sensor changed from OFF to ON
2020-01-22 22:47:56.893 [ome.event.ItemCommandEvent] - Item 'LivingRoom_Floor_Light' received command 100
2020-01-22 22:47:56.930 [nt.ItemStatePredictedEvent] - LivingRoom_Floor_Light predicted to become 100
2020-01-22 22:47:56.951 [vent.ItemStateChangedEvent] - LivingRoom_Floor_Light changed from 0 to 100
2020-01-22 22:48:10.133 [ome.event.ItemCommandEvent] - Item 'DiningRoom_Down_Lights' received command 100
2020-01-22 22:48:10.170 [nt.ItemStatePredictedEvent] - DiningRoom_Down_Lights predicted to become 100
2020-01-22 22:48:10.207 [vent.ItemStateChangedEvent] - DiningRoom_Down_Lights changed from 42 to 100
2020-01-22 22:48:14.767 [ome.event.ItemCommandEvent] - Item 'Kitchen_Down_Lights' received command 0
2020-01-22 22:48:14.805 [nt.ItemStatePredictedEvent] - Kitchen_Down_Lights predicted to become 0
2020-01-22 22:48:14.833 [vent.ItemStateChangedEvent] - Kitchen_Down_Lights changed from 100 to 0

If anyone can look at this and tell me where to start tweaking I would be very grateful. I really want my z-wave network to ‘just work’ so I can get on and do some actual stuff with openHAB rather than just tinker with making it work at all. I’m getting frustrated and close to abandoning z-wave altogether.

If it’s any help, the nodes mentioned in the log correspond to the following devices;

Nodes 2, 5, 6, 7, 8, 11, 14, 17: Fibaro Dimmer 2 (FGD-212)
Node 18: Fibaro Single Switch 2 (FGS-213)
Node 19: Fibaro Double Switch 2 (FGS-223)
Nodes 20, 24: Aeotec Multisensor 6 (on battery power)
Node 29: Aeotec Z-wave LED bulb (ZW098)

These are always tricky problems to resolve. Usually battery devices don’t tend to route data, whereas mains powered devices generally do. Do you have a map of your devices? Range is important as is number of nodes between your device and the controller.

I ended up having to purchase an extender for my network as I was having delays and none responsive nodes.

Do you have any “Zombie” nodes that can be discovered but do not actually exist? That can cause network routing issues.

Follow the instructions for when things do not go as planned and pose debug logs.

You can view a better debug log view here.


1 Like

Thanks for the input so far. Here is my current z-wave device map.

Node 24 in red I suspect is a battery that has just died (a multisensor). The problems were happening before then, but I will address this. Is there anything else in there I should be paying attention to?

The debug log viewer is interesting. I’ve put a few logs in there, but I’m still not sure how to interpret what I’m seeing. I will collect a few more logs and try to note when I’m experiencing delays.

I don’t think I have reception issues as I have a fairly dense network of nodes throughout my house and I was getting good response times to all of them initially.

And no zombie nodes that I know of.

Have you tried to disable nightly heal?

I use most of your devices too and have no such delay. Only on restart of OH for the first 5 min. I can see a delay.

In other posts is written that it is a good idea to disable power monitoring of dimmers and bulbs. I’ve no such channels mapped to items.

I have a different problem. Sometimes the z-wave command send from device is not arrived at OH. It looks like this occurs only on high z-wave trafficcaused by a running roller shutter. At this time my PIR did not send anything to OH.

And sorry, I cannot understand z-wave log. Maybe someone else can help.

I haven’t disabled the nightly heal. Isn’t it important to keep the z-wave network functioning? I don’t really understand it.

I don’t currently have any items or channels devoted to power monitoring. The nodes will send this information across the network anyway unless they are specifically configured not to (is my understanding). Should this be disabled in the dimmers themselves? Is there any real evidence that this helps?

If your network is not changing, the heal is not really needed since the nodes already know routes to the controller.

OK. I still have a few nodes to add though and I do have a habit of tinkering, so I think I should probably leave it running for now. Can it actually do harm? Perhaps it shouldn’t be disabled until my z-wave network is ‘finished’?

How does one disable the heal?

Habmin> Things> select controller> Z-Wave Network Heal> Heal Time> select Disabled.