I want to bind alexa, but the problem is in item

I installed gpio binding, wrote item and sitemap, I added item to paper ui myself (through paper ui the LED does not work, I don’t know if it should work through paper ui or just basic ui), everything works fine in basic ui (the LED is on) . I am going to use alexa voice snap. To do this, I registered with myopenhab, installed openhab skill, combined myopenhab and amazon, but myopenhab in the items section does not detect items, although if I go through myopenhab to the main page (openhab: 8080), the LED is on. I will use wiscore alexa devices as amazon (instead of amazon echo).
Please tell me what to do?

the item must have a TAG like [“Lightning”] or [“Switchable”] or something like that, do you have that? otherwise, the item is not detected by amazon. … byw… do you see the item in the amazon device overview?

I added light> and [“Lightning”], but after that from basic ui, switching does not work
In Paper ui, my item LED disappears after adding <light and [“Lightning”], tried to add again item LED - ERROR comes out: 500 - Internal Server Error!
alexa does not work out
Я живу в России, но в моем аккаунте стоит страна США и язык английский
Switch LED “LED” { gpio=“pin:23” } light> [“Lightning”]

Lighting, not Lightning…

If all you want to do is switch on and off, then you should be able to use the “Switchable” tag.

Also make note of where the tag is in the item structure.

Here’s a sample of a properly tagged item.

Switch Hallway1 "Hallway Lights" [ "Switchable" ]{ tcp=">[ON:10.x.x.6:3040:'MAP(90.map)'],>[OFF:10.x.x.6:3040:'MAP(90.map)']"}

Sorry, I don’t understand why here is tcp in the label, I just wanted to turn on and off a simple LED
Please tell me where to look at the correct tags, because the following tags on openhab.org:
Switch LightSwitch “Light Switch” {alexa = “PowerController.powerState”} or such:
Switch LightSwitch “Light Switch” {alexa = “Switchable”}
on other sites, others …

The TCP is the binding I am using to communicate with that particular switch.

Do you have a properly configured and working item that you can turn on and turn off using a sitemap?

Can you post that item code here?

No tags for alexa
Switch LED “LED” {gpio = “pin: 23”}
sitemap home label = “alexa”
Switch item = LED
Everything works, the LED turns on and off

Which binding are you using to communicate with Alexa?

The Hugh emulation service or the Alexa skill?

I added the openhab skill in amazon and associated it with myopenhab

So if this is your working switch configure like this

Switch LED “LED” [ "Switchable" ] {gpio = “pin: 23”}

Once you have it like this you should be able to ask Alexa to discover new devices.

With Hue Emulation you have to enable pairing mode - I am unfamiliar with the skill so you will need to consult the docs.

Once discovered, you can then ask Alexa to turn on the LED.

Sorry for the brevity…on my phone.

Squid :squid:


Everything works.
Thank you very much! :подмигивать:
I have 1 small question
Do I understand correctly that you need to register with amazon developer if you want to change openhab skill for yourself?

I am unfamiliar with the skill but that would sound about right. You would probably need to have your version of the skill hosted as well. I would start a new thread to ask that question.

If my suggestion fixed your situation, please check the solved box so others can easily see the answer.

Squid :squid:

Perhaps they wanted a shock :rofl: