iAqualink connection issue

If you put the binding in TRACE mode, I’m guessing the binding will print out the raw JSON response from the service, this should show the various pool controllers under your account, you should be able to grab the serialId for the correct one there. Ideally i should have built this in using discovery, but for now this is might be the quickest route.

I had put it already into TRACE level, but this message did not show up. I just checked my other equipment, this is definitivly the only device that has an aqualink connection and also in my app on the mobile no other equipment shows up then the heating pump.
Do you know eventually a http request to get this list of available devices? From what you say I would expect, for whatever reason, expect to pop up two devices.

Ok, yeah, there’s an issue with the logging on the api client, but I just checked and there’s an easier way of doing this. If you go to Zodiac iAquaLink web site and click on “Device Status” you will see the serial number there. My guess is i originally planned on directing users to this if the case of multiple devices came up, but totally forgot.

set the serialId option in the thing configuration to this value and see if this helps?

Thanks for the hint with the website, never been there ,-) Credentials work as for the app and I can also see the heat pump. It has the same serial that is in the URL - and even more funny: Diving into the app I can find the serial also there, it looks however like a version number of the app, nicely hidden.
So the serial in the app and on the website are identical, however both do not match the serial on the plate of the heat pump. Let’s dump on it…
It seems whatver that I’m stuck here: The app shows the pump as “online / green” the website - and API likely! - shows it as “offline”. Se we cannot blame the binding for anything, but the aqualink cloud.

I also put the serial as explicit parameter into the thing definition, but behaviour is still the same.

And finally, when I use https://r-api.iaqualink.net/devices.json with API key etc. I get the device definition, including the crappy serial back and can still not request it.

Dan, thanks a lot, but I will stop it here. The iaqualink cloud seems to be crappy, the binding does quite well so far, but the cloud’s data is crap. I’ll speed up my remote control wiring to the heat pump and attach a wifi switch to it. No cloud, no pain ,-)

No argument there :wink:

FYI i also run this fork of AqualinkD https://github.com/ballle98/AqualinkD , the fork author is/was a openhab user i believe. This basically replaces the need for the cloud binding if you want local only control. It then talks to openHAB via MQTT. While i still use my binding for control, its nice knowing i have a local backup if their cloud becomes unavailable. This runs on an old rasperberry pi 3 with a cheap RS485 serial USB adaptor just for this purpose.