ID Lock 150 Zwave

Tags: #<Tag:0x00007f4335d47360> #<Tag:0x00007f4335d47248>

Thanks, I will try that.

A question, where did you fint the firmware file for the IDLock to use with Silabs zwave pc tool?

You have to register here:

https://idlock.no/z-wave_updater/

And they will mail you the instructions and links for download.

Thanks again for helping me.
I have now downloaded the firmware file, I also registered me for beta version of the lock firmware.
I have a bug that I noticed was fixed in the beta.

Hi,
I have upgraded the lock to latest firmware via the Updater App in the phone (Lock = 1.4.9, Zwave = 1.6), but the Thing configuration still says 1.5. and I guess I have the old binding.

Do I have to exclude the lock, and include it again in order to get the new binding, or is it possible to upgrade to the new binding another way?

Install it manually or use this script:

Just to clarify, the events that misses for me is not commands coming from ZWave, it is regular unlocks from the outside from users with codes and the channel that does not update correct is Alarm (Raw), that is my issue.

I am experiencing the same issue, ie not receiving alarm (raw) messages. Did you ever solve this? Didn’t have this problem before upgrading to latest zwave firmware/lock firmware/1.6 binding.

@chris I’m have firmware for the zwave card @ 1.6 as well.
Having troubles that after I restart openhab, my idlock 150 goes “undef” and a lot of polling is going in in openhab:

2020-01-05 23:18:06.246 [vent.ConfigStatusInfoEvent] - ConfigStatusInfo [configStatusMessages=[]]
2020-01-05 23:18:08.659 [me.event.ThingUpdatedEvent] - Thing 'zwave:device:168ba158009:node42' has been updated.
2020-01-05 23:18:08.660 [vent.ConfigStatusInfoEvent] - ConfigStatusInfo [configStatusMessages=[]]
2020-01-05 23:18:11.038 [me.event.ThingUpdatedEvent] - Thing 'zwave:device:168ba158009:node42' has been updated.
2020-01-05 23:18:11.040 [vent.ConfigStatusInfoEvent] - ConfigStatusInfo [configStatusMessages=[]]
2020-01-05 23:18:13.368 [me.event.ThingUpdatedEvent] - Thing 'zwave:device:168ba158009:node42' has been updated.
2020-01-05 23:18:13.369 [vent.ConfigStatusInfoEvent] - ConfigStatusInfo [configStatusMessages=[]]
2020-01-05 23:18:15.749 [me.event.ThingUpdatedEvent] - Thing 'zwave:device:168ba158009:node42' has been updated.
2020-01-05 23:18:15.750 [vent.ConfigStatusInfoEvent] - ConfigStatusInfo [configStatusMessages=[]]

The funny thing I have to do to resolve it is to pull out one battery for the zwave card wait some, and then reinsert it. Now everything works again and no excessive polling is made.

And as others stated here, in alarm_raw channel, I get information if I unlock with RFID, but not locked/unlocked manually and/or with zwave. Why is the channel marked deprecated?

Hi,

I have some problems with getting the new DB version (minVersion 1.6) to work on my lock.

In my previous house I had an ID Lock 150 and it worked like a charm with the an older version of the lock and Zwave module. I’ve moved a year ago and took the ZWave module with me and just last week I bought a new ID Lock and installed it. I’ve upgraded both the lock and the ZWave module to the latest versions. However, when I include it to OpenHab I think OpenHab fetches the oider version of the DB entry instead of the new one.

As you can see in the print screen below the DB reference is 886 and versionMax says 1.5 so I assume it’s the older version. But what can I do to get the new one? I’ve tried to delete the item and adding it again. I’ve tried including and excluding. In Habmin I don’t have any “Advanced options” so I can’t reinitilize it either.
image

My ZWave binding version is 2.5.8 and I assume that this new DB version for the lock is merged into that Binding version.

251 │ Active │  80 │ 2.5.8 │ openHAB Add-ons :: Bundles :: ZWave Binding

I’m desperate! :sob:

EDIT: Here’s the logs from the latest inclusion attempt. It’s Node 12

Both versions have been in the database since 2.5.0. If you fear you are usinf the old entry, delete the Thing from OH ( do NOT exclude from the network) and then rediscover & add it back.

You showed part of the HABmin attributes but not the firmware version reported by your device.

Until just 5 min ago it has reported 0. But now I see that it reports 1.6 so thats good. Also, i was able to access the configuration (which i haven’t previously) and I got some “advanced options” in habmin. So I tried to reinitialize but now I’m back to not being able to access configuration. However, it reports firmware 1.6 still.

I’ll try deleting and rediscovering it again now that it’s reporting 1.6 instead of 0

Now I got the new version! Let’s see if I also get access to the configuration soon, strange that it’s taking so long.

I wonder what I did differently this time comapre to the other times.

Thanks for your help @Bruce_Osborne!

1 Like

Ok, i still have the same root cause problem that i thought was due to wrong version of ZWave db instance (now sure about the terminology here). I don’t have access to the configuration in either Habmin nor Paper UI. In paper UI i just get an 500- Internal server error message and in Habmin there is no configuration tab.

However, last night I got access to the configuration and that’s when I reinitilized it and got the correct DB version. I have no idea what I did to get it. Is this something anyone has encountered previously or has any suggestions on what I could try?

Your binding is 2.5.8. What version of OpenHAB distro are you running. It UIs usually stated at the bottom of the first web page.

It’s the same, 2.5.8 Release build

So the situation is the same, I don’t see any of the configuration options nor the “association groups” in Habmin for the this device. When I try to “pen” icon in Paper Ui I get an “ERROR: 500 - Internal Server Error”

The lock
image

“Working” device
image

I’ve included the device several time during the last 2 weeks. In the beginning I neither got the configuration options nor the correct version from the Zwave DB (I got the previous one). Then all of a sudden the configurations were availble and I seized the moment and reinitilized the lock which gave me the correct DB version, but the configuration options didn’t appear again. Unfortunately I didn’t have the DEBUG log level when this happened so I can’t dig into those.

So now I’ve tried to just wait, tried to delete and add the device again, but no luck. I’ve done some more digging and I can’t find anything strange in the logs (btw, the zwave log viewer is awesome!).
Here is the log file from the latest inclusion and this one is from one of my delete and add attemps

I don’t dare to exclude and include it again in case I happen to end up in square one again. Perhaps this is the only way out, or do you have any suggestions?

I never seen to learn.

A simple clearing of the cache solved the problem…

Never mind my previous comments :grin:

Was this after an upgrade? Unfortunately, I have found it all too common to need to do that & a couple of restarts too. That is one reason my Production system is still on 2.5.2.

No, i had upgraded before i started to include the lock…

Hi all.
I’m thinking about buying one of these locks, I hope it’s ok if I ask a few questions here:

  1. If I understand things correctly, you can tell not only if the door is locked/unlocked but also if the door is opened/closed through Z-Wave?
  2. When the door is locked/unlocked locally (using pin or tag), are you able to tell in OH which person it was or only that it was locked/unlocked?
  3. My experience with secure inclusion is that the node needs to be very close to the controller, like no more than a few centimetres. How is that done with a node that’s bolted to a door? Do you include it before installing the lock? Or move the controller (and thus the entire server) to the door?