IDE setup for 2.5.x has problems with resolution of org.eclipse.equinox.metatype

I have tried to setup a fresh development environment for version 2.5.x with Eclipse 2019-09 and Java 8 (on Windows 10) but when I try to execute “resolve” for app.bndrun it fails with the following error:

Resolution failed. Capabilities satisfying the following requirements could not be found:
      ⇒ osgi.identity: (osgi.identity=org.eclipse.equinox.metatype)

I have tried different Eclipse versions but the problem remains. Any idea what I am maybe doing wrong?

This error is typical if you have an error in a pom.xml or some other error. Do you have any error showing in the tab with messages?

P.s. I think you mean 2020-09 (although I can see why 2020 isn’t the most attractive year to choose :wink:)

P.s. I think you mean 2020-09 (although I can see why 2020 isn’t the most attractive year to choose :wink:)

:slight_smile: I did not like this year from the beginning on. Everything I see 2020 I see two blanks (x’2020’) …

I have really tried it with 2019-09 because I had a working setup for this Eclipse version with 2.5.9. But 2020-09 did not work either.

The only error messages I could find were those two in the Error Log:

Contains: Problems encountered while deleting files.
Contains: Could not delete: C:\EclipseProjects\openhab-2-5-x\git\openhab-distro\launch\app\target\classes\META-INF\MANIFEST.MF.
!ENTRY org.eclipse.m2e.logback.appender 4 0 2020-10-03 19:50:31.101
!MESSAGE processing instruction can not have PITarget with reserved xml name (position: START_DOCUMENT seen \n        <?xml ... @2:15) 

It is also interesting that the band editor shows an additional combobox that I have never seen before (and I don’t see in the 3.0 development environment):

Had the same problem. I think this happens when switching between OH 3.x and OH 2.5.x development. Removing ~/.m2/repository helped. This will clear your build cache and force the rebuild done on the current Java version. Ensure you have set JAVA_HOME properly for builds via cli (eclipse does this for you when building inside).

1 Like

Thanks, will git it a try