IFTTT not triggering in MyOpenHab

Using openHAB 2.5.0.M1 Milestone Build on Raspbian
Items are exposed to MyOpenHab and showing online. My mode switch item is updating into myopenhab online so connector is working and MyOpenHab is showing online.

Issue is that calls from IFTTT have stopped working. Did work as I had a problem with send On not ON to the switch. Fixed that and recipe worked and MyOpenHab updated online and down to home controller.

This has now stopped working and nothing from IFTTT is getting thru to MyOpenHab. Activity logs show comms from IFTTT when to MyOpenHab and then no logs or trace of call. Tried re-authorising MyOpenHab in IFTTT as well.

Not sure what to do next so opened a help request in case someone else has had same issue

Have bypassed myopenHAB and using Web Hook relay which feeds directly into Node-Red. Only allows 150 calls per month on the free account, with 1500 for about $5 per month. Will see how reliable it is. Very very easy to setup. With that in place not really sure if myopenHAB is worth the hassle now.