Ikea Tradfri Color bulb: cannot set hue instead of colorXY

binding
Tags: #<Tag:0x00007f1e517e9d40>
(Rombout) #1

Hi all,

my setup contains a few lightbulbs of type “IKEA of Sweden TRADFRI bulb E27 CWS opal 600lm”, connected to a CC2531EMK Coordinator.

The Paper UI has discovered the bulbs, with only the Color channel: zigbee:device:stick1:xxxxxxxxxxxxxxx:xxxxxxxxxxxxxxxx_1_color

This means I can control the Color, Brightness and Saturation through this channel. However, the light bulb also has a “white” mode. Cutting/restoring the power to the bulb makes it start in that white mode. That white mode cannot be set using the Color Channel. I expected another channel to access that mode, perhaps the Color Temperature?

I have tried adding the channel manually in the JsonDB, but it gets removed automatically. Adding the channel though a .things file does not work either.

Any hints on what to do? Should I buy the Tradfri Gateway to update the firmware of the bulbs? I have no idea what version they have currently.

  • Platform information:
    • Hardware: Arm Cortex A7, 2Gb Ram
    • OS: Debian Stretch
    • Java Runtime Environment: openJDK 1.8.0_152
    • openHAB version: 2.4
0 Likes

(Elias H.) #2

First of all, hello @scheveningen and welcome to the openHAB community forum :heart:

Now to the “bad” part.

You should read this Topic carefully :slight_smile:


NO! Bad, don’t do that! Please read the Docs.

0 Likes

(Rombout) #3

Above was my uninformed stab at the problem. After reading the Zigbee Light Link docs and sites like:https://github.com/ffleurey/ThingML-Tradfri, I now think the issue with Ikea and the Zigbee binding could be:

If this is correct, it would be great if the binding could support setting the Hue explicitly. Is this worth pursuing?

0 Likes