IKEA Tradfri Gateway remains "Uninitialized"

Dear All,

I’m trying to setup my IKEA Tradfri Gateway via THING File.

Bridge ikeatradfri:gateway:mygateway [ host="", code="SecretCode" ] 
0100 TRADFRI_SPOT_1_THING [ id=65537 ] 
0100 TRADFRI_SPOT_2_THING [ id=65538 ]

Unfortunately it apears under Things in Paper UI but remains “UNINITIALIZED- HANDLER_CONFIGURATION_PENDING”

When adding it via Auto Discovery/Paper UI with same Code it works fine.

Running the latest openHAB 2.2.0~20170926163445-1 (Build #1048)

A hint would be greatly appreciated.

Hey Mike,

any success? Did you look into the documentation: http://docs.openhab.org/addons/bindings/tradfri/readme.html? There exists an additional parameter for the port. I assume the host parameter only expects an IP address or hostname without any port given.

Dear Christoph,
thanks for getting back to me.
I tried

Bridge ikeatradfri:gateway:mygateway [ host="", port="5684", code="SecretCode" ]

unfortunately with the same result.

I now used a two way Approach to make it work:

  1. Autodiscover to add the Gateway and configure it using Paper UI.
  2. Manualy creating the items via Ikea.items file

I may be experiencing a similar problem.

The odd thing is that my Tradfri Gateway works just fine with my “old” OpenHab setup on Ubuntu, but won’t work with my “new” OpenHabian install (everything else works fine so far - I can see my other network devices, I can switch my WeMo plug, it’s all good! - only Tradfri is problematic).

At first it was “uninitialized”; then it initialized, but now it reports status “OFFLINE - COMMUNICATION_ERROR”.

I checked my Ubuntu install again just to be sure, and it still works.

I have verified the security code, too… puzzling.