IKEA Trådfri Gateway

I’m trying to start up with this binding - however i don’t have a remote to the Gateway - will there be any other solution for pairing the bulbs with the gateway other than i need to buy a remote only for the pairing? The binding can’t do something like that?

Sorry byt you need one remote to get the lights into the system.

Check post 70 from this thread, @MortenVinding was able to do pairing only with gateway, without remote

I noticed @OMR mentioning a buzzing noise on the 30x90 FLOALT, and the 30x30 being dead silent. I experience the exact same thing here. And it was so noisy i exchanged it at the Ikea warehouse for a new one, but its the same noise on this one. Experiences? My house is quiet when the kids are outdoors :slight_smile:


Thanks for the group for adding the trådfri binding! It’s a great to see how neatly it works.

One question about the groups, have they been introduced only in 2.2 or should they work also in 2.1?
I have the 2.1 release version of the binding running, if 2.2 is required, is the Jar somewhere available, or do I need to drag myself to my dev system and build one? :slight_smile: Additionally, how can I figure out the group id? Or would a newer version of the binding discover those automatically as well?

Native group support is not yet implemented.
At the moment, you can only use normal “Group” items in OpenHAB to group your bulbs together.
See: IKEA Traadfri Groups - Not always turning all lights off

Thanks for the reply!
I found this example from sourceror

Bridge tradfri:gateway:gwa0cc2b6d6e7b [ host=“yourip", code=“yoursecuritycode" ] {
    0220 tradfri_light_attic [ id=65539 ]
    0220 tradfri_light_bedroom [ id=65537 ]
    group tradfri_group_livingroom [ id=140890 ]
    group tradfri_group_bedroom [ id=132922 ]
    group tradfri_group_attic [ id=147073 ]

Looks to me like the groups work somewhere :slight_smile:

This is from unfinished development.
Reference: https://github.com/eclipse/smarthome/pull/3799

Thanks for the link.
Will checkout, build and give it a try.


Thank you for the binding, it has been working very well.

I have noticed an issue, if I restart OpenHab, the TradFri gateway, and the router at the same time (I’ve been having power outages due to storm). The binding will not correctly connect.

What appears to happen is:

  • The gateway restarts and uses a self-assigned IP address because the router is not yet booted.
  • Openhab starts, the binding discovers the gateway, and stores it’s IP.
  • The router starts, and the gateway receives the correct IP (via DHCP).
  • The binding doesn’t detect the change.

Restarting Openhab corrects the problem, but it would be nice to work correctly from a cold start.

Thank you again for all your hard work.

I just bought a Trådfri Color bulb (there aren’t shown on the IKEA Homepage yet).

May I ask where these are available? Just in Europe/Scandinavia? I see they are not listed on the Canadian IKEA site, either…

I dont’t think they are only available in Europe. On the US IKEA site they are listed: http://www.ikea.com/us/en/catalog/products/20353289/

I bought the bulb in a german IKEA store. At that time they weren’t listed online. So maybe it’s only a matter of time until they are available at the Canadian IKEA site, maybe they are also already available at the local IKEA stores.

1 Like

I have a workaround

  • I set a static IP address for the Gateway
  • I configure this address for the binding.
1 Like

Hello and thanks for the tradfri innovation.

I have a bunsh of lights active thru openhab on my qnap nas.

What I’am missing since the 0.9.0. snapshot is the avalability of the (0820) items(remote controls).
They looked like this:

Tradfri Group

I’am turning always back to the old build due to the fact that I can’t see my remotes anymore.

Can someone please let the (0820) items return into the actual snapshot.


1 Like

Is anyone experiencing stability and delay issues after adding the binding?
I have latest stable openhab and android ikea app (i can check versions if that help), binding is installed via paperUI, and things added via paperUi. Items are added in the files.
I have 4 bulbs in two groups. I had gateway running for few days without the binding, and via the app all works instantaneous. When I install the binding, both the ikea app and commands from the openhab start to have 4-6 (sometimes up to 8) seconds delay. Sometimes would the Ikea app disconnect while trying, saying there is timeout or something.
I do not see anything suspicious in the openhab2/events.log except that the

2017-10-29 20:19:05.622 [ItemCommandEvent ] - Item ‘OfficeLight_Brightness’ received command 86
2017-10-29 20:19:05.623 [ItemStateChangedEvent ] - OfficeLight_Brightness changed from 54 to 86
2017-10-29 20:19:09.113 [ItemCommandEvent ] - Item ‘OfficeLight_Brightness’ received command 38
2017-10-29 20:19:09.115 [ItemStateChangedEvent ] - OfficeLight_Brightness changed from 86 to 38

Entries in the log are instantaneous, but then there is the delay before the lights react. Same goes for ikea app.

First I thought I made some stupid rule, so I removed the binding and reset both the openhab and gateway, and all started working fine via the ikea app. Then I added the binding, all worked fine for a day or two, but then the delay started to show again :frowning:
Any advice on where to start checking?

I got a bit more testing, and it is definitely something with a binding, as soon as I reboot openhab server, binding works fine again both from the openhab and from the ikea native app.
Looks like binding is bombarding the gateway with requests or something, since it also influences native app from working. I will try to determine what is exactly going on and try to get some info out of the logs.

1 Like

Same Problem here … I run Openhab 2.2.0 Build 1069… The Tradfri Gateway stop working after few Minutes :frowning:

191 │ Active │ 80 │ │ TRÅDFRI Binding

After reboot the Tradfri Gateway … it works for few Minutes …

1 Like

try restarting openhab and see if stability is longer, for me it is stable some time, but I guess after a bit fiddling with items or rules it just stops

Yes … and I think only the RGB Bulb is the Problem …

I found this information in a home automation group on Facebook. I am not sure where to post this information to make sure it is received by the right person but I hope someone here can help.