Ikea Tradfri - Lost lights added in Tradfri and IDs changed

Good evening all,

This evening, after an unexpected power outage, all systems rebooted. Everything went well, except for the IKEA Tradfri hub. It did boot just fine, but it turned out that all ‘lights’ and other IKEA items were no longer stored at the gateway.

I just went for the painful exercise of adding all my lights and other smart items that went through the Tradfri binding. I tried to re-use my existing Things, as they are all linked to their respective items and didn’t want to do that again as well. All well so far.

Now, I noticed that the channel names for each thing don’t correspond anymore with the Thing’s IKEA ID, see screenshot below:

I don’t have an immediate problem with them being different, but I did notice that not all lights are responding to rules anymore. A motion sensor notices movement (as per the logs), but there is no entry of a light turning on (and also no errors in the log files). Could this be correlated?

If it is, I would be dying to know whether it would be possible to change the channel name of each thing (that would be quicker than adding everything again through Auto-discovery).

Many thanks in advance for your help!

Best regards,

If using auto discovery I would suggest checking that duplicate items do not exist via the console.

Thanks for your reply! Yes, when forced to go down that road, I would start with everything fresh (delete all Things and possibly items).

Hoping that someone can help me avoid that though!

If you have duplicate items, just remove them.
Did you check via karaf console?

Also, if you use auto discovery, turn it off a.s.a.p. after device has been discovered.

I checked and no duplicates in Items using the Karaf command provided in “Runtime Commands”.


Have you tried stopping OH, cleaning the cache, and rebooting/restarting OH?

Yes, to no avail :(.

See this issue on github: https://github.com/openhab/openhab-addons/issues/6023

Thanks for your help, H102. Much appreciated! I tried to power cycle again as well as removing and putting back in the ethernet cable, both didn’t work. Eventually, I want ahead and removed all Things, again wiped the IKEA Tradfri, and added them again one-by-one, relinking all items.

Glad to say that everything works again.

Thanks again for your help!

Glad you got it working.:+1: Hate you needed to remove and relink everything again.:grimacing:

Please click square box on solution post to mark topic as solved.