Incorrect NTP time


Rpi3b+, latest openhabian install. NTP binding installed. Locale is properly set. My time is displayed 3 hrs ahead of my time. Any clue?

Locale has to do with character set. Timezone, ironically has to do with time. :wink:

Please either give a version or don’t bother with “latest”

Whose locale, java, openHAB? Set to what?

Displayed where? Is this some Item you have made, or log timestamps, or?

It’s probably a timezone issue, but you knew that! There’s lots of posts about suchlike.

Unfortunately sir, not in front of the system to see the version, but was downloaded and installed days ago.

Locale and timezone set properly in Paperui

Displayed on the sitemap, as a date time item.

Weird thing is…same exact items and sitemap declarations setup on multiple pi’s in different places. This is the only one I have issues with.

What about the time zone in the OpenHAB settings? Tell us the settings on one that works and this one for comparison.
We do not have the time to guess at all possibilities just for you to later say you already checked that.

Insert in console

sudo dpkg-reconfigure tzdata

and choose correct time zone.

Cool, I’ll let you know if it worked or not

No, didnt work…

If date & time are wrong from the command line, then this is an OS problem that , according to the openHABian developers, belongs on an OS forum.
The image is basically Raspbian with some modifications but raspi-config where you would normally set the time zone, has been removed.

Should I be able to do a workaround by setting a zone 3 hrs behind?

What displays if you enter the command in the console?


and what shows in the openhab logs for item ntp?

I’m not in front of it at the moment, can be in an hour…well, not for the console…I can only access via myopenhab until Thursday.