Influxdb failed to install through openhabian-config

Tags: #<Tag:0x00007f1751cc3b60> #<Tag:0x00007f1751cc39a8>

*** Platform information:**

  • Hardware: Raspberry Pi 3 Model B Plus Rev 1.3
  • OS: Raspbian GNU/Linux 10 (buster)
  • Java Runtime Environment: openjdk version “11.0.10” 2021-01-19 LTS
  • openHAB version: 3.0.1
    *** Issue of the topic:**
    I installed openhab from an image : openhabian-pi-raspios32-v1.6.3.img.xz
    I am using the “main” branch.
    I used openhabian-config to install Influxdb but it left me with an error.
    Here is the full log : Dropbox - putty - influxdb.log - Simplify your life
    It fails on line 1170. Even though it looks like it is started, but I tried to use it “as is” in openHab, but it cannot connect from my openHab instance.
    Log excerpt:
    (see below because formatting won’t work here!?)

Sorry for the formatting but it always fails on me. I can use the icons from the wysiwyg editor or the keyboard shortcuts, it sometimes work, but today it doesn’t… I edited my main post above multiple times and it’s just getting worse.
I’m trying to format my log again below :

Log excerpt:

Check if InfluxDB is running…
cond_redirect curl --retry 6 --retry-connrefused --user admin:tesT-12345 --insecure http://localhost:8086/query
[[ -n ‘’ ]]
echo -e ‘\n\033[90;01m$ curl --retry 6 --retry-connrefused --user admin:tesT-12345 --insecure http://localhost:8086/query \033[39;49;00m’
$ curl --retry 6 --retry-connrefused --user admin:tesT-12345 --insecure http://localhost:8086/query

curl --retry 6 --retry-connrefused --user admin:tesT-12345 --insecure http://localhost:8086/query
curl: (7) Failed to connect to localhost port 8086: Connection refused
return 7
echo FAILED
FAILED

some days ago i also did a new install of openhabian with oh3. then also installed grafana and influxdb in openhabian-config. worked until reboot, then i had the same entries in the log as you.
i don´t know why and i cannot say if it will work for you but i deinstalled zram in openhabian-config and from next reboot it worked again.
… but next problem for me was that persistence does not work with influxdb - on reboot all items are restored as OFF.

It looks like Influx was installed but not completely.
In ssh, I ran “influx -username admin -password my_password”
Then I ran this script that I adapted from one found here : https://www.smarthomeblog.net/openhab-persistence-grafana-dashboard/

CREATE DATABASE openhab_db
CREATE USER openhab WITH PASSWORD 'Password1'
CREATE USER grafana WITH PASSWORD 'Password2'
GRANT ALL ON openhab_db TO openhab
GRANT READ ON openhab_db TO grafana
exit

Now the error in openhab log are gone… It was showing credential issue and then database not found. Now it looks like it can connect and it finds the database, so I guess it’s saving something, still have to test if it actually works :wink: