InfluxDB+Grafana persistence and graphing

influxdb
graphs
grafana
Tags: #<Tag:0x00007fd31eb04520> #<Tag:0x00007fd31eb041d8> #<Tag:0x00007fd31eaffed0>

(Rich Koshak) #447

I do not have any recommendations but I can say this is not the case. Persistence works with Items completely independently of the bindings those Items may be linked to.


(Cyborg) #448

Good to know @rlkoshak and thanks for the information.

I don’t know where to look then. The influxdb.persist works with every other item, it logs without issues and displays in graphana, but no trace of any attempt or try of the icloud binding to persist the changes.

I am quite new to this world, so could anyone let me know how could I report such issue and where?


(Rich Koshak) #449

I recommend posting a new thread to address this specific issue. Post your relevant Item definitions and .persit file.

Look in your logs for errors.

Look in your events.log to verify that your Items are in fact being updated.


(Cyborg) #450

Yes, that’s all checked. No errors or warnings in the logs (after enabling those via cli). No trace of any error or attempt to persist that item, while everything else does get its way to Influx without issues.


(Carsten) #451

@ThomDietrich any idea where Tiere find this ini?


(Udo Hartmann) #452

I’m not sure, but in recent Grafana there should be the option to deactivate login via UI (not sitting at home now, so I can’t chack)


(Wouter Born) #453

If you haven’t fixed it yet @juelicher, recently some documentation about this issue got added.


(Chris Reid) #454

I’ve just clean installed Openhab 2.2 and used the install tool within openhabian-config to add influxDB and Grafana, but I too cannot find the .ini file to edit to enable anonymous login so the charts work in Basic UI.

I’ve got the data logging and persisting, but just can’t get the graphs to display in Basic UI.

I had this working in 2.1 but just can’t get it to in 2.2


(Udo Hartmann) #455

did you try to find it yet?

sudo find / -name grafana.ini

would do the trick.

If there is none: Did you already start grafana once? Maybe the file is generated while first startup.


(Chris Reid) #456

Got it :slight_smile: I should have known to do that!
Thanks


(Cyborg) #457

Done that now, here: Persistence not working for GPS location formatted XX.XXX75788937955,-X.XXXX170208076405


(Marco Schnubel) #458

thx, now everything is fine


(Dennis Von Der Bey) #459

Sadly this doesn’t work anymore for me. Does anybody know why they would disable this?

Now I have to manually delete all entries by doing a SELECT before and getting the timestamps…


(Juelicher) #460

Thanks for pointing me to that part of the documentation, probably I have overlooked it. Installing nginx and configuring a reverse proxy, as described in the docs, solved the issue for me!


(shane kevin) #461

hey guys, I came across a small issue: In habpanel, when I use the image that created by grafana’s direct link rendered image, the image can not auto refresh unless I hit F5 to refesh the page, I am not sure if this is even can call a bug… but how could u guys deal with this situation? Do we have a rules that can “trigger auto refresh(re-generate) the image” or do I somehow, I don’t know how, make grafana auto generate the image by a period of time say 5min? or should I deal with the “auto F5 refresh” thing to the browser side(chrome in this case)?


(Ralf B.) #462

sorry, grafana works, inluxdb also. i see a my graph in grafana and also with

Direct link rendered image

in my browser
URL:

http://192.168.1.208:3000/render/dashboard-solo/db/gaszaehler?orgId=1&panelId=1&from=1516538410937&to=1516560010937&theme=light&width=1000&height=500&tz=UTC%2B01%3A00

OH:

Image refresh=60000 url="http://192.168.1.208:3000/render/dashboard-solo/db/new-dashboard-copy?orgId=1&panelId=1&from=1516535365910&to=1516556965911&width=1000&height=500&tz=UTC%2B01%3A00"

i had edit the /etc/grafana/grafana.ini file

[users]
# disable user signup / registration
allow_sign_up = false
[auth.anonymous]
# enable anonymous access
enabled = true

but no image in Openhab :frowning:

EDIT
runs now

seems there is a bug in grafana. if i rename my dashboard, the URL seems wrong.
in the url i find my old name.


(Robert K.) #463

Hi,
I’m also fighting a terrible fight against Grafana being used behind a nginx reverse proyx (openHABian image).
My problem is:

This address in the sitemap (Image url=)…

http://<my_local_ip_address>:3000/render/dashboard-solo/db/temperaturen?orgId=1&panelId=3&width=1000&height=500

mutates into this when I check the address of the image in Firefox under BasicUI:

http://<my_remote_dns_url>/proxy?sitemap=home.sitemap&widgetId=030101&t=1517183948343

I have no idea where this transformation happened and what I have to do to make the generated PNG file available for my sitemap. Webview works well, but I also want to have the graphs on my iPhone, so they are no option for me.
I tried it the past four hours and read more or less all tutorials and threads regarding this topic here, but maybe I missed something…

Any hint appreciated - thank you


(Will) #464

Is anyone here successfully running Influx 1.4? I originally installed 1.2, which seemed ok. Someone had mentioned they used 1.4, so I switched to that. About that time, the zwave events stopped being stored, though LocalWeather values still persisted. Yet those also are now no longer persisting. Any thoughts, including a retreat to 1.2?


(Kamil Sroka) #465

Hi
Is any one know how to unistal infux and grafana?
in openHABian Configuration Tool I can see only option to install.
Please


(Jiri Hron) #466

Thank you for great tutorial.

I have created java utility for conversion rrd file to InfluxDB line protocol file. Maybe it will be helpful to someone else too

More info can be found here: