InfluxDB not doing anything

(Tyler W) #1

Running openhabian…

2019-05-10 01:19:09.292 [INFO ] [el.core.internal.ModelRepositoryImpl] - Refreshing model ‘influx.persist’

2019-05-10 01:19:51.784 [thome.event.ExtensionEvent] - Extension ‘persistence-influxdb’ has been installed.

These are the only two log messages I get

services/influxdb.cfg
url=http://192.168.1.50:8086
user=openhab
password=StitchAndLiloAreFriends
db=openhab_db
retentionPolicy=autogen

I can curl the influx url, and login via cli to the database

persistence/influx.persist
Strategies {
everyMinute : “0 * * * * ?”
}

Items {
Outlet1 : strategy = everyMinute
}

Not sure why openhab isn’t logging anything else out…

0 Likes

(Rich Koshak) #2

Does Outlet1 have a state? Is the state changing?

Put the InfluxDB add-on into debug or trace logging to see if it is trying to write out the values. See Log4j2 Sample Config.

Look at the InfluxDB logs to see if it is experiencing any problems on that end.

0 Likes

(Dario) #3

Did you install influxdb and grafana from the openhabian-config utility?

if so, in my experience that utility creates the users openhab and grafana in influxdb but doens’t grant them permissions.

try
image
(from InfluxDB+Grafana persistence and graphing)

0 Likes

(Rich Koshak) #4

It would be helpful to file an issue on the openHABian project if that is the case. See How to file an Issue.

0 Likes

(Udo Hartmann) #5

The file has to be named influxdb.persist

1 Like

(Tyler W) #6

It works now…

… I’m gonna go format all my harddrives now …

:sob:

0 Likes

(Dario) #7

What was the problem causing the issue?

… both useful for anybody else encountering the same situation, and for me to know whether to follow rlkoshak’s advice of filing an issue on github…

0 Likes

(Tyler W) #8

the filename was incorrect, influxdb.persist, not influx.persist

0 Likes