Innogy SmartHome beta1 release

innogy delivers the PushButtonCount for all devices with buttons. With every push the number will be increased, but it stays NaN until the first push. You could then use a rule to react if the count increases.

OK, I thought it should be something like that.
Somehow it was not counting at all, but now it is.

I did a clear-all (I messed up with old + new items etc) and everything works again.
Tip for other users: the controller is discovered quickly, but after entering the API code it takes a while before all the other things are discovered. After a couple of minutes they all popped up.

(Apologies to go offtopic, but I cannot find any option on this community to send a private message.)

Hello Oliver,

I read on your website ( and several forum posts that you created bindings for OpenHab. I assume you have access to a Innogy API?

I would like to add my Innogy Smarthome to my HomeAssistent But I cannot find any info about it or the Innogy API.

Can you tell me how you got it?

Thanks you for your time,

PS. Your email-address on your website is not working?


yes, I have access to the official innogy API. I got the contact via Kai Kreutzer. Now you like to add a kind of binding to HomeAssistent? I could ask the innogy guys, if they would add another developer to their program.

I’ll check my Emailconfiguration - thanks for the hint!

Yes, I would like to add Innogy Smarthome as a component(I guess that is a binding in OpenHab) to HomeAssistent.
I would appreciate it if you can ask them if I can join and/or get access to the official Innogy API. I would be very happy if I can integrate Innogy Smarthome to HomeAssistent.

Hi Oliver, I’m reinstalling my raspberryPi. Is this version still the latest one?
It worked well on my old installation!

Hi Olli,

do you have any summary for updating the binding? I installed an run this version:
and it works fine.

Thanks a lot for helping!


I uploaded the latest version here:

I am still working on the ongoing pull request review and hope to finish it soon. Then the binding will be part of the official OH2 project.


I installed the latest binding and I have some issues.
At first everything works fine. But after some time I see the following in the log and the I cannot control my Innogy system (everything else works fine):

2017-11-22 20:04:56.611 [INFO ] [marthome.handler.InnogyBridgeHandler] - Initializing innogy SmartHome client...
2017-11-22 20:04:56.838 [INFO ] [arthome.internal.client.InnogyClient] - Uninitializing innogy SmartHome Session...
2017-11-22 20:04:56.944 [INFO ] [marthome.handler.InnogyBridgeHandler] - innogy SmartHome bridge handler shut down.
2017-11-22 20:04:56.948 [INFO ] [marthome.handler.InnogyBridgeHandler] - Scheduling reinitialize in 120 seconds.
2017-11-22 20:04:56.950 [ERROR] [marthome.handler.InnogyBridgeHandler] - Error initializing innogy SmartHome client.

Any ideas what is the reason or how to find the problem?

Thanks for the awesome work!


** " Remote access not allowed. Access is allowed only from the SHC device network.". **

I already saw other people having the same error which results in not being able to connect to the bridge anymore.

Unfortunately I did not find any solution … Everthing worked worked fine until this morning. I had to switch off the power of the bridge and after rebooting (IP stayed the same) I got this error.

The Innogy App on my smartphone still works as well as my Amazon Alexa …

Anybody got some hints what to do? I already tried to re-install the binding and auth-code but it didn’t help :slightly_frowning_face:

I’m running OH2 2.1.0 with the lastest beta innogy binding…

Thanx, Stefan

I checked the logs again and I have an assumption. The problem occurs after DSL was automatically reconnected. I tested it by manually reconnecting my Internet connection and I could reproduce the problem. It occurs after there was a timeout of the websocket. This happens a few minutes after the internet connection was shortly interrupted and a new IP address was assigned to the DSL router.

DSL router log:

23.11.17 03:08:22 Internetverbindung wurde erfolgreich hergestellt. IP-Adresse:, DNS-Server: yyy.yyy.yyy.1 und yyy.yyy.yyy.2, Gateway: yyy.yyy.yyy.194, Breitband-PoP: STGJ17
23.11.17 03:08:15 Internetverbindung wurde getrennt.
23.11.17 03:08:12 Die Internetverbindung wird kurz unterbrochen, um der Zwangstrennung durch den Anbieter zuvorzukommen.

Openhab log:

2017-11-23 03:22:39.606 [ERROR] [gysmarthome.internal.InnogyWebSocket] - innogy WebSocket onError() - Timeout on Read
2017-11-23 03:22:39.632 [INFO ] [gysmarthome.internal.InnogyWebSocket] - Connection to innogy WebSocket was closed abnormally (code: 1001). Reason: Idle Timeout
2017-11-23 03:22:39.635 [INFO ] [marthome.handler.InnogyBridgeHandler] - Scheduling reinitialize in 30 seconds.
2017-11-23 03:23:09.644 [INFO ] [marthome.handler.InnogyBridgeHandler] - Initializing innogy SmartHome client...
2017-11-23 03:23:10.116 [INFO ] [arthome.internal.client.InnogyClient] - Uninitializing innogy SmartHome Session...
2017-11-23 03:23:10.763 [INFO ] [marthome.handler.InnogyBridgeHandler] - innogy SmartHome bridge handler shut down.
2017-11-23 03:23:10.766 [INFO ] [marthome.handler.InnogyBridgeHandler] - Scheduling reinitialize in 120 seconds.
2017-11-23 03:23:10.770 [ERROR] [marthome.handler.InnogyBridgeHandler] - Error initializing innogy SmartHome client.


the Websocket reconnect is correct and not the problem. The auth fails, because the innogy backend somehow thinks that you are now in a different network. This seems to have something to do with the remote access feature of innogy and has to be paid.
However it should normally not be a problem, if the innogy bridge and OH are in the same network.

End of next week, we could talk to an innogy developer about it. Please come back to me then.


Can’t create a Authorization code! is there a problem?

What error do you get? Did you choose the right brand?

Try to go to the right URL as described here:

With the link out of the plugin it does not work! With the link from the wiki I got an Token!

But now I get the error message “OFFLINE - COMMUNICATION_ERROR Remote access not allowed. Access is allowed only from the SHC device network.” I am in the same network as the SHC, the SHC has the IP 91 and the open hub server 2

A couple of users have that issue. Seems like the innogy service does not recognize it’s in the same network. If you order the remote access service, the problem maybe gone. I have no solution, but we could ask the innogy engineers to do a deep analysis, if you like to collaborate. If yes, please send me via PM: 1) Your innogy username 2) the openhab log with the error including the timestamp.

Do you have any news from the innogy developers? Actually I have the same problem with the innogy smarthome app. Everytime my router gets a new IP address I have to first log off from the app and log in again before I can access to my smarthome.

I’ll now start a new debugging request with the developers and another user. No news yet, but we’ll see.

1 Like

I have the same problem. Did you reach the innogy customer service about this concern?

Yes, see Innogy SmartHome - "Unexcepted API error: Remote access not allowed".