Install openhab-addons arm ubuntu

Problem since few days now. I tried some solutions found in this forum but nothing worked for me :
I wanted to upgrade openhab2 addons and nothing worked. I even purged it… so I ´d like to install it again!
Here is the error I get :
Err:1 stable/main arm
64 openhab2-addons all 2.5.10-1
Error reading from server - read (5: Input/output error) [IP
: 443]
E: Failed to fetch
ol/main/2.5.10/openhab2-addons_2.5.10-1_all.deb Error reading
from server - read (5: Input/output error) [IP:
E: Unable to fetch some archives, maybe run apt-get update or
try with --fix-missing?

Why do you need to download the addons? I believe they are only needed if you are going to install addons on a server with no Internet access.

I assume you did

sudo apt update


sudo apt upgrade


sudo apt upgrade openhab2 openhab2-addons

and to install

sudo apt install openhab2 openhab2-addons

In case the download with above commands does not work you manually can download the packages with e.g.

wget stable/main arm64 openhab2-addons all 2.5.10-1

and install the package with

sudo apt install ./openhab2-addons_2.5.10-1_all.deb

I thought I’ll do that today… others solutions didn’t work.

I forgot to say hi, sorry I wrote from my mobile. So I’d’ like to Thank you and say hello!

1 Like

It is my need :slight_smile:

Ok. It worked. Dunno what happened though

1 Like

I think bintray has random errors and people have not figured out why.

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.