Installation Debugging



  • Cannot connect to http://ip-address:8080 or https://ip-address:8443.
  • All logs appear to be empty: /var/log/bootstrap.log, /var/log/openhab2/openhab.log and
  • /var/log/openhab2/events.log (I tried cat and tail, nothing zilch).
  • In fact I’m not sure if anything associated with OpenHAB is running as it should.

The installation and Hardware:

  • I’m using a Pi 2. Yes I realise its a little under powered but I just want to experiment with simple home monitoring and switch control.
  • The Host OS is Raspberry Pi OS version 9.11.5-P4-5.1+deb10u1-Raspbian with all updates installed.
  • Java version is: openjdk version “1.8.0_212” (there does not appear to be a zulu 32bit arm version available)
  • I followed the Linux Package Repository Installation process with out an obvious issue.

What Is Working:

  • I can run openhab-cli commands and get to the console.
  • I can run systemctl start|status|stop openhab2.service and I can use top to see a running openhab process.
  • I can start openhab in the console and no errors are reported.

So with out any logs I’m stuck. Sensible or witty suggestions welcome.


First off Philip, welcome to the openhab community!!!
So since this was only posted 2 minute ago, my first question is how long have you allowed it to run? I know my Pi4 w/ 4Gbs takes a few minutes to get running to the point the UI is available. On first start, it takes even longer

Our installation docs include this link for ARM installations:

Leave the OS Selector empty and you can see the Java version you are looking for.

Hi Andrew, yes I recal reading that - thanks.
I’ll restart openhab and have a bite to eat and ry againe.

Thanks Hans (may I be so bold). I would never have thought of that.


Common usage of my name, so no worries :wink:

OK an update - problem resolved.

OpenHAB had at least 12 hours uptime but was in fact down when I checked the status this morning. Still no logs etc.

In short I chose to reinstall everything but in a different order.
1. ran apt-get update and upgrade which did install a new kernel and associated stuff.
2. ran apt-get reinstall openjdk-8- …
3. ran apt-get reinstall openhab2
4. ran apt-get reinstall openhab2-addons
5. ran sudo systemctl start openhab2.service

Not able to access http://ip-address:8080 immediately but retried 41/2hrs later and bingo its working.
Now to play …

Regards all and thanks