Installation fails: Failed to start /etc/rc.local Compatibility

I have been using Openhab2 on a RPi3 for a few years.

Since it started making problems lately, I decided to reinstall it and then load a backup file.

When I try installing, I get the following error:

Failed to start /etc/rc.local Compatibility

After reading this, I tried editing /etc/resolv.conf and change the IP address to, but after rebooting, I get the same error (and the content of /etc/resolv.conf is back to the previous IP address 192.168.x.y).

Any ideas what can resolve this?

The minimum required to answer any such question would be a comprehensve description of WHAT (version ?) you want to install WHERE (hardware, OS ?) and WHICH are the instructions you are following.

How to ask a good question / Help Us Help You - Tutorials & Examples - openHAB Community

You are correct, sorry.

Trying to install openhabian / openHAB 2.5.12

On a RPI3.

Used etcher to flash it on an external SSD drive.

Installing to and booting from SSD is not supported in openHABian.
Please read the docs before you try installing, and mind the prerequisites.
Btw you’re referring to an outdated docs site.

1 Like

I had such an installation working for several years.

Is it something that was changed?

Maybe I am not explaining myself properly?

So what? That does not mean it was supported back then. Either way, it isn’t today.
Of course there have been many changes over the years.

It’s rather expectations of yours, you are expecting stuff that today’s openHABian is not built to provide. So if you want to stick with openHABian please move to supported hardware. Or figure things out on your own.

How is the error I receive relate to any HW issue?

And on a side note:
So after moving from Vera hubs several years ago, and using OH since then, because of an issue I had, and in order to continue using OH, following this recommendation, I practically have no way of continue using OH.

That’s a great community and support - thanks!

I wish others would join this discussion, and show me the rest of the community is different.

That error is sign of something to fundamentally go wrong with the install process and is because you flashed to an SSD instead of the standard internal SD card. It does not happen when you stick to the standard.
You can install latest openHABian to SD card. As you apparently want OH2 take care of this then you can import your old config.

I bought a new SD card, flashed it with OpenHabian 2.5, placed it in my RPi, and during the installation received the same error.

Seems like the cause of the error is not the SSD I used,

Any ideas what I should do now?

There is no such thing. It’s either openHAB 2.5 or openHABian 1.7.2 or if you used some old image that would be an explanation for your problems, too.

We don’t support OH2 any longer in openHABian, sorry.
So if you insist on 2.5, I’m afraid you’ll have to debug that yourself.
Read the debug guide (set debugmode=maximum BEFORE installing by accessing the boot partition from some other computer). Start by looking into /boot/first-boot.log.

You could also go with a standard installation of OH3 and downgrade after, there’s a menu option or you can do it manually by exchanging the Linux packages.

Thanks for your tries to assist.

I was using the openHABian installation that Iused to install OH2.5 on my system a few years ago.
This is the filename: openhabian-pi-raspbian-201908050414-gitca0976f-crc6a66b5a1.img.xz

The most important thing for me, is to try and have as less editing / work as possible with my old configuration (ZWave items, add-ons) and rules. They were working perfectly for me, and I just want to keep them.

If I install a clean OH3 installation (openHABian 1.7.2, downloaded from here, filename: openhabian-pi-raspios32-202201271414-git08bc4ff-crcdd86375a.img.xz), will I be able to restore my configuration from OH2.5, or will I have to start setting up from scratch?

I told you to install latest openHABian, see above.
So try that. I also pointed you at the docs how to install OH2 from the start.

You cannot restore an OH2 config to OH3. That’s why I advised to install the standard then downgrade.

So to make sure I understand the steps:

  1. Install latest openHABian
  2. Use menu option 42 to downgrade from OH3 to OH2.5
  3. Use menu option 51 to restore my OH2.5 backup

Is that correct?
Will I have to do anything else?

In the past, I was not using the menu items to back/restore, I was doing it using the following commands:

sudo openhab-cli backup
sudo openhab-cli restore /var/lib/openhab2/backups/

Is it identical to restoring using menu item 51?

Yes but that’s plan B only. As I’m now saying for the third time, preferred is to install latest openHABian with the modification to install OH2 rather than the default OH3.


Apparently I don’t understand what it means to install “with modification”. How should I do that?

I already wrote that so you should have read that. The link in post #8.