Installation fails on macOS

Hi. Brand new to OH. Long-time home automator for 15+ years, considering a move from Indigo to OH but I’ve fallen at the very first hurdle, so not looking promising so far. I get errors (see below) when I try to run ./ Never used Java before so am completely stumped by this error and can find no mention of it anywhere on forums or online. Install of Zulu JDK all seemed to go fine. Tried rebooting Mac to see if that helped but no change. Tried re-installing both Zulu JDK and OH. Tried re-downloading OH. Nothing helped.

Cannot even get started and have no clues as to where to go from here so any help gratefully received. Thank you!

  • Platform information:
    • Hardware: MacBook Pro 2014
    • OS: macOS Big Sur
    • Java Runtime Environment: latest Zulu builds JDK 11
    • openHAB version: latest stable
  • Issue of the topic: installation fails:
Launching the openHAB runtime...

Error: Could not find or load main class

Caused by: java.lang.ClassNotFoundException:

Had a sudden thought - maybe this being in my iCloud Drive docs folder was somehow the problem. Copied the whole openhab-3 folder to Downloads in my local User folder and then it works. No idea why that would make a difference but maybe this will save another newbie some frustration in future! Perhaps might be worth adding a note on this to the macOS installation instructions page as I imagine this might be a fairly common problem.

1 Like