Installation of add-ons started failing (but worked before)

  • Platform information:

    • Hardware: RPi
    • OS: OpenHABian
    • openHAB version: 2.5.3
  • Issue of the topic:
    I have been running OpenHAB for about 6 months without issues. I have installed add-ons before successfully.
    Suddenly it is not possible to install add-ons anymore. It started when I tried to add the MAP Transformation add-on. Then I tried to install also the Chromecast binding which also failed. Also trying to remove already installed bindings fails.

  • This is the related error message in the log:

2020-09-28 12:01:26.860 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-binding-chromecast, openhab-transformation-map': Unable to resolve root: missing requirement [root] osgi.identity; osgi.identity=openhab-binding-modbus; type=karaf.feature; version="[2.5.3,2.5.3]"; filter:="(&(osgi.identity=openhab-binding-modbus)(type=karaf.feature)(version>=2.5.3)(version<=2.5.3))" [caused by: Unable to resolve openhab-binding-modbus/2.5.3: missing requirement [openhab-binding-modbus/2.5.3] osgi.identity; osgi.identity=openhab-transport-modbus; type=karaf.feature [caused by: Unable to resolve openhab-transport-modbus/2.5.3: missing requirement [openhab-transport-modbus/2.5.3] osgi.identity;; type=osgi.bundle; version="[2.5.9,2.5.9]"; resolution:=mandatory [caused by: Unable to resolve missing requirement [] osgi.wiring.package; filter:="(&(osgi.wiring.package=org.apache.commons.pool2)(version>=2.8.0)(!(version>=3.0.0)))"]]]

Any idea how to fix this?

Thanks, Ondrej

Never mind. I resolved the issue. Looking more carefully at the error message I noticed that refefecne to the Modbus binding. So I removed it and now the other add-ons are installing fine.