Installation of openHABian on Pi 2 not working


my first post in this community unfortunately as result of an unsuccesfull installation.
I followed your installation guide (openHABian 1.4.1) but after waiting for two hours after

  • Wait approximately 15-45 minutes for openHABian to do its magic

the attached TV-screen is black and I can’t connect to http://openhabianpi:8080 either.
My Pi2 is attached via LAN-cable.

Many thanks for your help.

Kindest regards


Attach a keyboard, login and check /boot/first-boot.log to see where your install stops/starts hanging.
Common problems at this stage are

  1. Internet isn’t accessible (openHABian needs it to update packages)
  2. DHCP or DNS resolving does not work because of your router setup

We really need some more information.
What happens if you reboot - is the screen still black?
Does the screen show anything at all during boot up?
Is the tv connected by hdmi? and is it selected in HDMI mode?


and thanks in advance for your help.

I see a boot screen on my TV attached via HDMI. Several lines of code before the screen turns to black there is something like “daily apt”. Thats it. How can I log in with a black screen even with a keyboard attached?
Unfortunately I’m no LINUX-wiz. That’s exactly why i used habian.

Kind regards


Pinging “openhabpi” from a windows clients results in:

Antwort von 2001:a62:1572:ec01:4409:cb15:fc25:9247: Zeit=1ms

I have a fritzbox (router).

I started my pi again and now I see the line “Initial setup exiting with an error!”

Kind regards


After logging in with the attached keyboard I automatically see (cat) the first-boot.log and the error ist in the line

Updating resositories and upragind installed packeges … FAILED

I never had a problem with fresh installed LINUX on PI’s connecting to the internet and upgrading packages.

Kind regards


Do you have another monitor (or borrow) you could try? You could also use an analog video lead to an analog input on a tv or monitor as another option to try instead of the hdmi connection.
Another question - have you booted up a raspberry pi before and been able to see the screen correctly with your setup?


sounds like the boot did not complete. It might be worth erasing the SD card and trying again in case something has corrupted. Have you checked your download checksum is good?

Hello Rob,

seems you missed my last post becuase you wrote yours at the same time.

Kind regards


That sounds like the connection to the internet has failed.

Just put the SD into a Pi 3 with exactly the same result.
Why is this the only system (I have 3 PI’s running on the same LAN ) having problems with the internet connection?

Kind regards


In would re-install to the SD card and test again. Sounds like a burn fail to me.

I’m giving it another try now with WiFi.
The internet connection must at least work regarding the system time because in both cases the time displayed was correct and is not possible without any internet connection.
At the moment “Daily apt upgrade and clean activities” are running.

Kind regards

I once had a problem with openhabian and the installation when apt tried to use IPv6 instead of IPv4.
I had to force APT to use IPv4 then it worked.


WiFi did the job on the Pi 3. Now I can connect via Web-Interface.

I’ll give it another try with a Pi 2, cabled LAN and a 32GB SD.

Thanks a lot for your help.

And voila, with a different SD now working on my Pi 2 either.

Thanks for your support.