Installation problem of openHABian

Hello Friends, i have a problem installing openHABian on RPI. the log file in question speaks of openhab download error caused by the repository address. Below the file:
Err:2 https://dl.bintray.com/openhab/apt-repo2 stable InRelease
Something wicked happened resolving ‘dl.bintray.com:https’ (-5 - No address associated with hostname)

I ask for your help to solve the problem, thanks.

This indicates a dns issue in your operating system. You may try to set your dns server to 8.8.8.8, one of Google;s public dns resolving servers.
Are you using the latest openHABian image or a version of Raspbian?

thanks for the reply, however I use the latest version of openHABiabian, 1.5

I think that image expects to get its dns server configuration from your dhcp server.

It’s about your network setup. Your DHCP and/or DNS server does not work properly. See this.

1 Like

unfortunately I don’t have a DHCP / DNS server, and my router doesn’t give me the ability to change the DNS.
Any suggestions?

How does your openHABian get an ip address then? DHCP normally provides that. Most home routers have that capability. The DHCP server also tells the client what DNS servers to use. Many times the DNS server belongs to your ISP.

Try editing /etc/dhcpcd.conf .
Something like:
interface wlan0
static ip_address=192.168.178.211/24
static routers=192.168.178.1
static domain_name_servers=192.168.178.1

@Bruce_Osborne: Can the DNS be set to 8.8.8.8 here?

Not sure if this is the correct spot so google if not.

static domain_name_servers=8.8.8.8 would likely work. Your router may not be set up as a dns forwarding server.

True, but worth a try if no other router options can be changed.

1 Like

thanks for the tip, but it doesn’t work.