Installing binding manually, nothing happens

Using Openhab 2.3 stable, running apt.get hasslefree on a Rpi 3B.

I´m trying to install a binding manually (copyíng the .jar file to /usr/share/openhab2/addons).
This binding: [velux] New OpenHAB2 binding - feedback welcome!

Problem is - Nothing happens, not even an error message or something. So I need to track this problem in some way. But how to do this, if/when nothing happens.
I know the binding work for others, so I fear this might be a general problem on my setup and therefore really could need some help to track this problem.

I have check with karaf console, and there is no velux binding.

openhab> bundle:list | grep velux

I have tried downloading a fresh copy of the jar file. Still no go.
I have check the openhab.log file as well. Nothing about velux.

I have no idea what to do next.

Can you add the binding name to the addons.cfg? This should have openhab install it.

something is wrong with your jar
try the following:

from the rPi3 ssh shell:

sudo su
systemctl stop openhab2
cd /tmp/
wget ""
chown openhab:openhab org.openhab.binding.velux-master/org.openhab.binding.velux-2.3.0-SNAPSHOT.jar
cp org.openhab.binding.velux-master/org.openhab.binding.velux-2.3.0-SNAPSHOT.jar /usr/share/openhab2/addons/
systemctl start openhab2

This works only for bindings which are a part of the distributed addons (the ones that appear also in PaperUI)
For manually deployed addons, you shouldn’t add anything in the addons.cfg (only place the jar in the addons folder)

1 Like


1 Like

He fixed it:


Correct, something was wrong with the jar file, both times I downloaded the jar file. I ususal just right click on the file a choose ‘save as’. It was saved as an jar file, but for some reason OpenHab wouldn´t load it. The third time I chose direct link insted. Then it all worked.

1 Like