Installing Java 8 on Windows and z-wave questions

Tags: #<Tag:0x00007f616e35deb0> #<Tag:0x00007f616e35dde8>

Yes
I in Environment Variables:
entered new system variable, name: JAVA _HOME; browse directory to this PC>OS©>.PROGRAM FILES> ZULU>ZULU-8 . Copied the path and pasted it to the name window.
Hit enter and closed environmental variables.
Just to check, went again to the environmental variables and the path was present.

Just FYI
I have: Windows10 Home, ver 1903

Thanks for responding.

Did you install Java as Administrator?

Thanks for the recommendation.

I checked and found that I was a admin.

FYI

Called Geek Squad and was escalated to the second level tech support.
They have some first had experience with this issue. He obtained the upgraded version and executed the same procedure. These are the results:

C:\Users\James>java -version
java version “1.8.0_221”
Java™ SE Runtime Environment (build 1.8.0_221-b11)
Java HotSpot™ 64-Bit Server VM (build 25.221-b11, mixed mode)

Thanks for your help and I will proceed with the installation with looking for this issue with software in the future.

Thanks
Stay safe
Jim.

HELP again

I am stuck on step 5 of of “Starting openHAB as a Service”

!. I have successfully deleted the openHAB2-wrapper.conf, and have copied the text in step 4 to notepad, and saved it with the title openHAB2-wrapper and renamed the extension from txt to conf.

  1. I don’t follow “adapt the first entry (openhab-home) to match your installation directory”.
    Can’t find exactly the name “installation directory” and noticed that there was “set.default OPENHAB_HOME=c:\openHAB2”. My directory is openhab2.

ANY COMMENTS?

  1. I then was successful in following directions to the Administrator Command Prompt - that is what it says in the window, and tried to cd c:\openhab2\userdata\bin
    This was the result:

Microsoft Windows [Version 10.0.18362.836]
© 2019 Microsoft Corporation. All rights reserved.

C:\WINDOWS\system32> cd c:\

c:>cd c:\openhab2\userdata\bin
The system cannot find the path specified.

c:>

Like before, i can see the bin directory but windows doesn’t. Is this that administrator thing again. It is possible I got java installed because I had geek squad as an administrator install it .

ANY SUGGESTIONS???

Be Safe
Jim

Careful with Windows editors to save files in UTF-8 form.
Can’t say if that matters here, but it will certainly get important later.

Thanks all for your help.

Most of my problems were misspelling and a different filename from the utube video (openhab2) instead of openHPB2 from the documentation.

I have successfully installed openHAB2 installed the standard version and now going through the tutorial on Paper UI.

Yesterday I tried to exclude and include all of my devices, to see if anyone would connect directly to the controller, but none of them did.

I am trying to connect my Aeotec heavy duty switch Gen 5 to my Zooz S2 Stick ZST10.
I added the ZWave binder and am really lost in the terms:
Z-Wave Device, Z-Way Virtual Device, Z-Way Server
???
I followed the documentation and found my ZWave port name/number: usb serial device (Com5). Documentation says that I need to dd the serial adapter:

“Before the binding can be used, a serial adapter must be added. This needs to be done manually. Select Serial ZStick , and enter the serial port.”

Where is the serial adapter and how do I get to the window to install it? What precisely should i choose for my stick?

My instruction say to i should create a file"//.//comXXX where XXX is the comp port. In my case it is port 5 so I need to create a file//.//com005 correct. what kind of file and where does it go. I am really lost.

Should I open another another topic or can you help me here?

Please advise.

Stay Safe
Jim

@JimHome

You first should set a system variable EXTRA _JAVA_OPTS

See here.

In your case it should be:

-Dgnu.io.rxtx.SerialPorts=COM5

Then go to PaperUI --> Configuration --> Things and set your z-wave controller port to COM5

Like this: you should select COM5

image

Thanks Alex

I entered the system variable using control panel>system>advanced system settings>environmental variables, then under system variable sel>new and “EXTRA_JAVA_OPTS” , and your string., hit ok.

Then went to PaperUI >configuration> Things>Add Things>
took me to inbox>choose Z-Way binding>then it stayed in inbox and said “thing not listed” so I sel ADD MANUALLY>ZWAVE DEVICE>then it gave me this config window:

I followed your procedure multiple times and could not get your config device window. This is the closest I got. I selected create bridge and it displayed configuration parameters for the Thing.

I hope this helps you to find my error.

Thanks
Stay Safe
Jim

Do you really want to use a Z-Way? Or do you mean Z-Wave?

Thanks Alex

Z-Wave looks more like what I expected from your response. Next on to the discovery of Aeotec SW.

I configured with com5 (checked it) and it is now “On Line” in the config>Things window.
pressed + > choose z-wave binding > and it initiated a search (same thing a a discovery right?)
While progress wheel was still turning, pushed the search button on my Aeotec smart switch.

It was blinking (not paired), and stared blinking faster as expected. Then momentarily full on then back to a slow blink.

There was nothing in my inbox.

It is not discovered.

Did I miss something?

Please advise.

Thanks
Jim

Yes, it is. (better call it “inclusion mode”)

But first of all you should check if your z-wave device is supported.

Is it a “Heavy Duty Smart Switch, Gen5” = DSC10

or

is it a Smart Switch 6 = ZW096

or

is it a Smart Switch 7 = ZW175?

All three models are supported, please check there also your firmware version. Is it supported, too?

If so, please read there how to include your device into z-wave network. Read the “Inclusion Information” section.

For all further devices to include please search this database:

https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devices

Cheers.

Thanks

The switch I have is an Aeotec ZW078 made by by Aeon Labs.

It is not listed as AEON Labs ZW078.

I searched the OpenHab web site and found precise details when you enter ZW078 Heavy Duty Switch under Add-ons.

The inclusion info requires using a “Acrion Button” for inclusion and my stick has none.

From Z wave Bindings - Supported things:
Heavy Duty Switch

Overview

Wall mounted switch for high current appliances, up to 40A. Power reporting.


Inclusion Information

If you’re using a Z-Stick:

  1. Decide on where you want your Heavy Duty Smart Switch to be placed and set it up as per the Quick Start guide steps 1 to 5. Its Status LED will begin to blink.
  2. If your Z-Stick is plugged into a gateway or a computer, unplug it.
  3. Take your Z-Stick to your Heavy Duty Smart Switch.
  4. Press the Action Button on your Z-Stick.
  5. Press the Action Button on your Heavy Duty Smart Switch.
  6. If your switch has been successfully linked to your Z-Wave network, its Status LED will no longer blink. If the linking was unsuccessful, the Status LED continues to blink. Repeat the above steps.
  7. Press the Action Button on your Z-Stick to take it out of installation mode

Exclusion Information

  1. Unplug the Z-Stick from your gateway or computer.
  2. Take your Z-Stick to your Heavy Duty Smart Switch.
  3. Press the Action Button on your Z-Stick.
  4. Press the Action Button on your Heavy Duty Smart Switch.
  5. If your Heavy Duty Smart Switch has been successfully removed from your network, its Status LED will blink. If the removal was unsuccessful, its Status LED will not blink.
  6. Press the Action Button on your Z-Stick to take it out of removal mode.

What do I do now?

Stay Safe
Thanks
Jim

Please link to those instructions, They are incorrect for openHAB.

It is not usually recommended to use the button on a controller. I do not have buttons on either of my two controllers.

EDIT: I found it in our database. I need to discus this with others.

EDIT2: I have asked the developers for advice.

It’s in database here.

@JimHome Have you added any other Z-Wave devices through openHAB? If you have already added devices I can simplify my instructions.

I agree those instructions were confusing. They will be updated in the next release.

Thanks Bruce

There are no other devices, this is the first z-wave thing I have tired to connect.

Can you refer to the existing documentation and augment the instructions so I can proceed?

I am a newbe. Can you tell me when the update is available?

.
Need help on my second transducer:
I am trying to find a low profile room temperature / relative humidity sensor to compute the moles / cu meter in the return air duct to control my air/air heat exchanger. I would like something small so as to to not impede the air flow. I then plan to cut a square in the duct, and mount the sensor on a plastic plate so it is facing to the inside of the duct.

I need the indoor dry bulb temperature and %humidity to calculate the number of moles of water inside the home. I will use the national weather service measurements for outside temp/% hum. I will then calculate the water density inside and outside and determine if I need to humidify or dehumidify with outside air. This calculation requires an exponential equation and have no idea how to do this in openHAB.

Any suggestions?

Jim

The developer usually exports the database about once a week, many times on weekends.
We then need to wait for the next snapshot build of the binding.
That binding can then be manually installed, after uninstalling the existing binding.
You then need to delete the Thing from openHAB (NOT exclude from the network) and then rediscover and add it back to get the new database settings, but all I changed was the instructions.

Continuing the discussion from Installing Java 8 on Windows and z-wave questions:

Thanks Bruce

Please confirm my understanding of the following:

  1. when you refer to the database, you mean the binding software. Correct? I uninstalled my old binding and installed v2.5.6 snapshot. I think this was the previous version.

  2. I did not see the Z stick under Thing, so I re-configured my binding to com 5. I did not change any default configuration parameters.

  3. searched for things under the serial controller (on line) and I pushed the discovery button on my Aotec thing (smart switch) and failed to see it in my inbox and failed at the smart switch.

  4. Do i need to wait for a new binding also? Are the existing instructions correct?

Actually it is contained in the binding. As I stated I did not make any functional changes, just the documentation.

Hello again Bruce
Had a knee replacement and no time to continue with my Zwave connecting.

I have successfully added the Z-Wave Node 005: ZW078 Heavy Duty Switch to my inbox. The problems was that I held the pair button too long.

I have two other things I don’t understand.

  1. My Z-Wave Serial Controller zooz zst10 is off line. The z wave controller is on line.
    2 I followed the new openhab instructions and changed the JAVA_HOME from c:\program files\Zulu\zulu-8 to c:\program files\java\jfk1.8.0_251
    Everything seems to work.

Thanks for your help.
Jim

1 Like