Installing OH 1.8.3 on Windows: OH not starting

I wanted to start from scratch and installed OH on Windows; you would it hsould be easy… well, i was wrong.

I followed the Wiki
OH sits in D:\Prog\openhabr
Since there can’t be a space in the path name, I copied C:\Programs (86)\Java to D:\Prog\Java

I modified start.bat to contain set ECLIPSEHOME=D:\Prog\Java\v8

And ran start.bat and? Got an error: Error: Unable to access jarfile

Removing echo off to see what is happening shows:
for /F "delims= tokens=1" %c in ('dir /B /S /OD D:\Prog\Java\v8\plugins\org.eclipse.equinox.launcher_*.jar') do set EQUINOXJAR=%c The system cannot find the file specified.

Where do I get the eclipse stuff from?
Why is it not in the Wiki article?
Why does it have to be so difficult?

I can’t speak for OH 1.8.3 but I do have OH 2 running on Windows 7 (64 Bit) and I am not aware of any reason why it would be different.

I simply extract the zip file into c:\openhab and then run start.bat. I have never had to modify any files to find Java or make OH 2 work, i.e. all the files are at default settings and I have had no issues with spaces in the directory name.

My Java files are located as per the following:

Hope this helps.

p.s. same directory structure on my development system and all works OK.

1 Like

You can get the 1.8.3 designer from the following link:

The sentence

Note that there can’t be a space in the path, so it can’t be in program files in windows.

belongs only to openHAB itself, therefore you only have to ensure that the path to runtime\start.bat has no spaces. In fact, this restriction isn’t true at all, but you would have to add many quotation marks in the start.bat (and it’s not easy-peasy to get this right…) :wink: so please delete D:\Prog\Java, delete openHAB completely and unzip it again.

1 Like

How silly does one have to be…
Thank you for your replies.
I have no idea what went wrong initially :cry:
So, deleting the lot and re-installing did it.

However, there is one thing that is different… which could have been the culprit:
I am running openHAB on the R Pi, and have a designer on Windows, which I installed into D:\Prog\openhab; I named the openhab directory openhabr (the r for runtime).
Before I re-installed it I renamed openahb to openhab_designer and openhabr to openhab.

In any case it works like a charm now :slight_smile: Thanks!

Good to see you have the issue sorted.

openHAB is a bit of a big learning curve for most us, but I for one am sure it will be worth it in the end!

Hi Mike; I believe you, while I am still hanging in there :slight_smile:

1 Like