Installing OpenHabian 1.4.1

I have successfully flashed my 16GB memory card with Etcher software on windows 10 (under VMWare). I then plugged in the card into my Rasberry PI 3 B+, and my ethernet cable - and left it for about 1 hour. But when I returned to my computer, I tried going to the new ip address but found none. Even after I rebooted the PI.
The doco says “The device will be available under its IP or via the local DNS name openhabianpi”, but cant see anything in my ipconfig, and I get an error when I type http://openhabianpi:8080 in my browser.

Your help is appreciated!!


1 Like

So because I can’t see my PI’s ip address, I can’t login with putty…

Tony, you’ll need to arm yourself with more patience than 1 hour :wink: - by restarting OH, you likely stopped the installation and left the Pi in a corrupted state. Go back to Etcher, reload the image, put the flash card in, restart it, and…leave the house for the day…when you come back, take a look at your router and see if a new client popped up (assuming you’re connected to your router via copper)…It took my Pi ~3 hours to load up with openhabian, for reference.

1 Like

As a suggestion, though not necessary, it’s really nice for installation to use hdmi and a usb keyboard at Raspberry Pi. You will see what openHABian has done (at least I would expect some output), you are able to login without the need of a working LAN, when logged in, you can get every Pi IP :wink: by using

ip a

1 Like

as @Udo_Hartmann said either hook up a monitor so see the output, or the little less stressful option in my eyes is to directly connect to the pi during installation using ssh. in the next image there will be also the option to trace the installation status using http

this means that you also should be able to find the pi within a few minutes of installation in your network. if this is not the case i would assume that you have some kind of network problems in the first place

Thanks everyone - very insightful!

Opened up the file first-boot.log and found this WIFI error: (I assure you that my username/pass are correct)

2018-03-14_02:17:47_UTC [openHABian] Starting the openHABian initial setup.
2018-03-14_02:17:47_UTC [openHABian] Storing configuration… OK
2018-03-14_02:17:47_UTC [openHABian] Changing default username and password… SKIPPED
2018-03-14_02:17:47_UTC [openHABian] Setting up Wi-Fi connection… OK, rebooting…
2018-03-14_02:18:24_UTC [openHABian] Starting the openHABian initial setup.
2018-03-14_02:18:24_UTC [openHABian] Storing configuration… OK
2018-03-14_02:18:25_UTC [openHABian] Changing default username and password… SKIPPED
2018-03-14_02:18:25_UTC [openHABian] Setting up Wi-Fi connection… OK
2018-03-14_02:18:25_UTC [openHABian] Ensuring network connectivity… FAILED

I was not able to connect to the configured Wi-Fi.
Please try again with your correct SSID and password.
Also check your signal quality. Available Wi-Fi networks:
wlan0 Interface doesn’t support scanning : Network is down

2018-03-14_02:20:09_UTC [openHABian] Initial setup exiting with an error!

Curious: Has anyone tried to install OpenHabian 1.4.1 on a PI 3 b+ ?

Try to install it using the ethernet port and then switch to WiFi

Thanks for your suggestion! Yeah I’ve tried plugging in my Ethernet cable and I still find connectivity errors in the first-boot.log file.

Any other ideas? I will try it with the Ethernet cable again, and paste the error here.

1 Like

I am having similar issues while installing openhab. Cannot get past the “ensuring network connectivity…failed”

1 Like

thanks @Dim

I plugged in my CAT5 cable, after reimaging my PI, and got this error messages:

2018-03-13_22:53:47_UTC [openHABian] Starting the openHABian initial setup.
2018-03-13_22:53:47_UTC [openHABian] Storing configuration… OK
2018-03-13_22:53:47_UTC [openHABian] Changing default username and password… OK
2018-03-13_22:54:00_UTC [openHABian] Setting up Ethernet connection… OK
2018-03-13_22:54:00_UTC [openHABian] Ensuring network connectivity… FAILED
2018-03-13_23:34:16_UTC [openHABian] The public internet is not reachable. Please check your network.
2018-03-13_23:34:16_UTC [openHABian] Initial setup exiting with an error!

make sure that your DHCP server is up and running. Usually, DHCP is provided by your internet gateway (router)

Thanks @Dim

Well here is my modem settings for DHCP:

I don’t know what exactly is the root-cause… it seems to be something related to the IP connectivity from your rPi to the internet…

You should check if the rPi gets an IP and if it can reach the internet.

post the output of the following commands in the Linux shell of your rPi:

sudo su
ip a
route -ne
systemctl status dhcp*
ping -c 4

How do I get in to the Linux shell of my rPI?

Im running MAC OS(High Sierra), and Windows 10 inside a VMWare. Having said that, I have tried installing OpenHabian 1.4.1 on MAC and on Windows 10, and getting the same errors with the Ethernet cable. Hope this rPI is not faulty?

I came to realize that this issue was related to my internet connectivity. I guess my cable was broken so even though I was able to access the internet wirelessly and believed there was connectivity, it took a change in cable to fix this.

1 Like

Hi @mammes_s

I have used my CAT6a cable, and swapped it over to my CAT5 cable and ran the install to no avail. These cables run my apple TV and seem to work…


A beginners mistake…:

I had my PI plugged into my laptop Ethernet port INSTEAD of my modem!! So OpenHab happily installed as expected this time, and I plugged my PI into my TV via the HDMI cable to see the install progress…

Now ready for some serious automation!!

1 Like

Glad you figured it out…

Niiiiiiiiiiiice… Do share what you are doing for automation…