Insteon 1 button Mini Remote problem

When I tried to put an Insteon switch in my bedroom I had to abort. My house is over 100 years old and the box in the wall is only a half deep box, so there was no way a switch was going to go in there. So, I put a Hue bulb in my lamp so I can control it with Openhab. I still wanted local control over the lamp with a switch so I bought an Insteon mini remote which I figured could control the lamp through Openhab rules. I added the switch to my Insteon Hub and configured an Item. When I trigger the switch I can see entries in the Openhab log, but I don’t see any events in the event log.

Here’s my Item:

Switch BedroomLS “Bedroom Light Switch” (House,Bedroom,Light) [ “Lighting” ] {insteonplm=“44.9C.DF:F00.00.10#switch”}

Here’s what I see in the openhab.log:

2018-03-17 16:19:22.147 [INFO ] [onplm.internal.device.MessageHandler] - LightOnSwitchHandler: device 44.9C.DF was switched on REGULAR.
2018-03-17 16:19:23.223 [INFO ] [onplm.internal.device.MessageHandler] - LightOffSwitchHandler: device 44.9C.DF was switched off REGULAR.

Here are some test rules I’m using for debugging:

rule “Bedroom Light Switch ON”
when
Item BedroomLS changed
then
logInfo(“BedroomLightSwitch”, “Set to” + BedroomLightSwitch.state)
if (BedroomLS.state==ON)
{
sendCommand(CouchEnd,ON)
}
end

CouchEnd is a light in my TV Room that’s standing in for my bedroom hue light, I’m too lazy to go sit in my bedroom to debug this.

Can anyone tell me what I’m missing?

Thanks
-Bob

  • Platform information: Openhabian
    • Hardware: CPUArchitecture/RAM/storage Raspberry Pi
    • OS: what OS is used and which version Openhabian
    • Java Runtime Environment: which java platform is used and what version
    • openHAB version:
  • Issue of the topic: please be detailed explaining your issue
  • Please post configurations (if applicable):
    • Items configuration related to the issue
    • Sitemap configuration related to the issue
    • Rules code related to the issue
    • Services configuration related to the issue
  • If logs where generated please post these here using code fences:
logInfo(“BedroomLightSwitch”, “Set to ” + BedroomLS.state.toString)

take the correct item-name and extend with .toString

Ok, I did that, but we’re not getting that far, I’m not getting that log entry in the log file, if the condition is being triggered I should have seen at least the text of the log entry in the log file and I’m not.

So, thanks for that, but it’s a bit of a red herring, for whatever reason the rule isn’t being triggered.

Thanks
-Bob

You should see log lines in events.log like

2018-03-17 16:19:22.147 [INFO ] [....] - BedroomLS received command ON

or at least

2018-03-17 16:19:22.147 [INFO ] [....] - BedroomLS changed to ON

When these lines do not occur, the item definition is wrong, or maybe the items file isn’t loaded at all.

You might want to verify your rules file is being loaded and that some typo error isn’t keeping it form loading. Restart OH and look for something this in your log:

2018-03-17 17:27:47.231 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model ‘openhab.rules’

Turns out Udo was right. I went back into the log files to respond to his post when I noticed that there were warning files that ‘switch’ wasn’t supported for F00.00.10 but buttonA, buttonB, buttonC and lastHeardFrom were. I changed it to ‘buttonA’ and now it works.

When I looked at the PLM page for Insteon it doesn’t say much about the 1 button mini remote, but goes into the 8 button remote a little bit. It wasn’t clear to me that there would be so much in common between F00.00.10 and F00.00.20.

Thanks
-Bob

1 Like