Insteon 8 button keypad no longer responds to OH after setting up clean OH3 install

HI again everyone, I just built a new system with an raspberry pi4 (booting from usb-ssd), Openhabian 1.6.5, Openhab 3.1.0
I have the older Insteon hub (2242-222) and a handful of different devices. Everything is working except my 8 button keypadlink-Dimmer (2334-232).

I can receive commands from all the buttons on the keypad into Openhab, but I can’t change the state of any of the buttons by sending a command from Openhab into the keypad, however I can Control the Dimmer from Openhab.

I’ve tried adding the device by textual definition via the things file, and I’ve also tried using the gui to add it, both have come to the same result as described above

here is my thing definition:

Thing device Foyer_Keypad [address="2b.98.42", productKey="F00.00.16"] {
      Type keypadButtonA  : keypadButtonA  [ group=1 ]
      Type keypadButtonB  : keypadButtonB  [ group=2 ]
      Type keypadButtonC  : keypadButtonC  [ group=3 ]
      Type keypadButtonD  : keypadButtonD  [ group=4 ]
      Type keypadButtonE  : keypadButtonE  [ group=5 ]
      Type keypadButtonF  : keypadButtonF  [ group=6 ]
      Type keypadButtonG  : keypadButtonG  [ group=7 ]
      Type keypadButtonH  : keypadButtonH  [ group=8 ]

and here are the related Items:

Dimmer DrivewayLights  "Driveway Lights [%.0f]" (ExteriorDimmers) { channel="insteon:device:home:Foyer_Keypad:loadDimmer" }
Switch keypadSwitchB "Foyer"  { channel="insteon:device:home:Foyer_Keypad:keypadButtonB" }
Switch keypadSwitchC "All Outside" { channel="insteon:device:home:Foyer_Keypad:keypadButtonC" }
Switch keypadSwitchD "Living Room" { channel="insteon:device:home:Foyer_Keypad:keypadButtonD" }
Switch keypadSwitchE "Dining Room" { channel="insteon:device:home:Foyer_Keypad:keypadButtonE" }
Switch keypadSwitchF "Kitchen" { channel="insteon:device:home:Foyer_Keypad:keypadButtonF" }
Switch keypadSwitchG "Basement Stairwell" { channel="insteon:device:home:Foyer_Keypad:keypadButtonG" }
Switch keypadSwitchH "All Off" { channel="insteon:device:home:Foyer_Keypad:keypadButtonH" }
Number keypadSwitchHManual "All Off" { channel="insteon:device:home:Foyer_Keypad:manualChangeButtonH" }

This is how I had it configured and working in OH2 for reference:

Dimmer DrivewayLights  "Driveway Lights [%.0f]" (ExteriorDimmers,Persistant) {insteonplm="2b.98.42:F00.00.16#loaddimmer"}
Switch keypadSwitchB "Foyer" (Persistant){insteonplm="2b.98.42:F00.00.16#keypadbuttonB,group=0xf2,related=2b.da.30"}
Switch keypadSwitchC "All Outside" (Persistant){insteonplm="2b.98.42:F00.00.16#keypadbuttonC,group=0xf3"}
Switch keypadSwitchD "Living Room" (Persistant){insteonplm="2b.98.42:F00.00.16#keypadbuttonD,group=0xf4"}
Switch keypadSwitchE "Dining Room" (Persistant){insteonplm="2b.98.42:F00.00.16#keypadbuttonE,group=0xf5,related=30.b2.0a"}
Switch keypadSwitchF "Kitchen" (Persistant){insteonplm="2b.98.42:F00.00.16#keypadbuttonF,group=0xf6,related=30.9c.50"}
Switch keypadSwitchG "Basement Stairwell" (Persistant){insteonplm="2b.98.42:F00.00.16#keypadbuttonG,group=0xf7"}
Switch keypadSwitchH "All Off" (Persistant){insteonplm="2b.98.42:F00.00.16#keypadbuttonH,group=0xf8"}

As always any help is appreciated

You have the group configured as 0xf1, 0xf2, … in OH2 but using 1, 2, 3, … with your new setup.

What does insteon display_local_database return from the console command for the device?

2B.98.42: hub controls groups (242,243,244,245,246,247,248) and responds to grou ps (1,2,3,4,5,6,7,8)

Based on how you have your groups set up, it’s working as expected. You have different groups configured for responder and controller.

Well, I’ve tried Air-gapping the device to reboot it (no luck), then I opened up houslink and resysced the network databases (No Luck), then I opened up houslink again, deleted the device, factory reset the device, added it back to houslink, resynced databases again (for good measure) and still no luck. I’m about ready to throw it away but I can’t find another lighted 8-button keypad at anywhere near that price point.

If I shutdown my OH3 box and boot up my OH2 box I can still get full control of the keypad, as far as I can tell all configs are good.

any advice or if anyone knows about another similar keypad I’d appreciate it, doesn’t have to be insteon (I’ve been trying to get away from their products for years).

Try using Insteon Terminal instead.