Insteon binding not working


I am trying to add my first two devices (Insteon 2457D2 LampLinc Dimmer) to my new OpenHab server running on a raspberry pi 3. I’m not 100% sure what I am doing so I figured I would ask you guys!

I have installed the Insteon PML and changed the following part of the insteonplm.cfg file to have my email and password to my insteon account and saved it:

I also added the following to my items file:
Dimmer Lamp “Lamp” {insteonplm=“xx.xx.xx:F00.00.19#dimmer”}

and replaced the Xs with the devices Insteon ID.

I have the following in my sitemap:
Slider item=Lamp

It is not controlling my lamp. Does anyone know what I am doing wrong?
I have also tried broadcasting the group 2 on command to the hub and it still isn’t turning on the lights.

Thanks so much!!

I personally switched to using the PLM module but I did use the hub for a while with OpenHAB 1.8. If I remember correctly the user name and password you need to enter are not the email and password of your account. If you look at the bottom of the Insteon Hub there’s a user name and password listed on it. Use those instead. That should resolve the issues.

Are you using OpenHAB 1.8 or 2.x? Either way you should look at the logs and see what it has to say about the Insteon binding as it loads up. If using the RPi 3 you can do a:

tail -f 

on the log file and it will stream the log on your screen. Or if using OpenHAB 2.x you can SSH into the Karaf console and use


to watch the logs.

Look here for more info:


Thank you for responding! I changed my username and password to match what is at the bottom of the hub’s setting in the app but it still doesn’t seem to be working. I am using OpenHAB 2.

I currently have this in my insteonpml.cfg

insteonpml:port_0=/hub2/name:pass@Ip Address:25105,poll_time=1000

any help is extremely appreciated!

There was an issue using the newest hub with OpenHAB2 but as far as I know they resolved that. I would also double check the IP address. My router changed mine on me a couple of times so if it’s not set to static IP it can be re-assigned and if that happens the binding won’t work anymore.

Check the IP and let me know what you find.

I got it working!! Thanks so much for your help! It turns out I had the same insteon ID typed in for the hub and dimmer… not sure why I did that. Thanks again!