Insteon hub confusion

So I have a shiny new Insteon hub 2245-222 and I want to use openHAB
with it.

I found this page:
https://github.com/openhab/openhab/wiki/Insteon-Hub-Binding
but I can’t find the 1.8 openHAB software. Everything on this page:
http://www.openhab.org/getting-started/downloads.html
refers to v1.7.1.

Both the 1.8 insteon PLM binding documentation here:


and the 1.7 version say

“This binding provides access to the Insteon network by means …
or the new 2245-222 (“2014”) Insteon Hub.”
but then I don’t see any examples of of to configure it.

So can the 1.7.1 software be used with my 2245-222 or do I need the 1.8
software and where is the 1.8 software?

Thanks,
Steve

Steve,

You can find the latest OpenHab 1.8 here:

https://openhab.ci.cloudbees.com/job/openHAB/

You can actually get away with using OH 1.7, and just installing the insteonplm jar into your addons directory. That may be an easier upgrade path.

As far as configuration is concerned: you need to edit openhab.cfg. Copy the relevant lines from openhab_default.cfg from there into your openhab.cfg:

Good luck!

Bernd

Bernt,

I downloaded and installed the 1.8 core and the insteonPLM and insteonhub bindings.
I was able to connect using the hub binding after I added these lines to the openhab.cfg file

insteonhub.host=192.168.2.53
insteonhub.port=25105

The first line I got from the documentation, the second was an educated guess. I suggest that it is added to the docs.
$ ./start.sh
Launching the openHAB runtime…
osgi> 2016-01-01 12:19:46.969 [INFO ] [.o.core.internal.CoreActivator] - openHAB runtime has been started (v1.8.0).
2016-01-01 12:19:47.648 [INFO ] [o.o.i.s.i.DiscoveryServiceImpl] - mDNS service has been started
2016-01-01 12:19:47.671 [INFO ] [o.o.i.s.i.DiscoveryServiceImpl] - Service Discovery initialization completed.
2016-01-01 12:19:49.286 [INFO ] [penhab.io.rest.RESTApplication] - Started REST API at /rest
2016-01-01 12:19:57.938 [INFO ] [.o.u.w.i.servlet.WebAppServlet] - Started Classic UI at /openhab.app
2016-01-01 12:20:01.688 [INFO ] [.service.AbstractActiveService] - InsteonHub Refresh Service has been started
2016-01-01 12:20:01.688 [INFO ] [insteonplm.InsteonPLMActivator] - Insteon PLM binding has been started.
2016-01-01 12:21:04.691 [ERROR] [.i.h.a.s.InsteonHubSerialProxy] - Communication error with Insteon Hub @192.168.2.53:25015

However I was not able to get it to work with the PLM binding. When I replaced my 2 config lines with:
insteonplm:port_0=/hub2/<my_user_id>:<my_password>@192.168.2.53:25105,poll_time=1000
I get a timeout.
(Note that I did not literally type <my_user_id> etc)
$ ./start.sh
Launching the openHAB runtime…
osgi> 2016-01-01 12:33:38.439 [INFO ] [.o.core.internal.CoreActivator] - openHAB runtime has been started (v1.8.0).
2016-01-01 12:33:39.105 [INFO ] [o.o.i.s.i.DiscoveryServiceImpl] - mDNS service has been started
2016-01-01 12:33:39.131 [INFO ] [o.o.i.s.i.DiscoveryServiceImpl] - Service Discovery initialization completed.
2016-01-01 12:33:40.960 [INFO ] [penhab.io.rest.RESTApplication] - Started REST API at /rest
2016-01-01 12:33:49.471 [INFO ] [.o.u.w.i.servlet.WebAppServlet] - Started Classic UI at /openhab.app
2016-01-01 12:33:53.101 [INFO ] [insteonplm.InsteonPLMActivator] - Insteon PLM binding has been started.
2016-01-01 12:33:53.120 [INFO ] [.o.b.i.InsteonPLMActiveBinding] - dead device timeout set to 3000s
2016-01-01 12:33:53.120 [INFO ] [.o.b.i.InsteonPLMActiveBinding] - config: service.pid -> org.openhab.insteonplm
2016-01-01 12:33:53.120 [INFO ] [.o.b.i.InsteonPLMActiveBinding] - config: port_0 -> /hub2/Elizabet:Hllze9WB@192.168.2.53:25105,poll_time=1000
2016-01-01 12:33:53.123 [INFO ] [.service.AbstractActiveService] - InsteonPLM has been started
2016-01-01 12:33:53.125 [INFO ] [.o.b.i.InsteonPLMActiveBinding] - devices: 0 configured, 0 polling, msgs received: 0
2016-01-01 12:35:08.664 [INFO ] [.o.b.i.InsteonPLMActiveBinding] - modem database has 1 entries!
2016-01-01 12:36:03.413 [ERROR] [o.b.i.i.driver.hub.HubIOStream] - got exception while polling: org.apache.http.conn.ConnectTimeoutException: Connect to 192.168.2.53:25105 timed out
2016-01-01 12:36:09.418 [ERROR] [o.b.i.i.driver.hub.HubIOStream] - got exception while polling: org.apache.http.conn.ConnectTimeoutException: Connect to 192.168.2.53:25105 timed out

I’m guessing that I have misconfigured somehow.

Got to go out now but at least I made some progress.
Thanks,
Steve

I don’t have an Insteon hub but maybe @sipvoip or @jtmoderate876 could help since both of them use the hub.

I’m using that hub with the 1.8 version of insteonplm binding and these settings:
port_0=/hub2/@192.168.1.120:25105,poll_time=500
modem_db_retry_timeout=300000

I had to add that timeout line to account for the long poll time of all my devices.

I’m using it in openhab2 but it is probably the same in openhab 1.8.

Not sure if it will help but here is my working startup log:

2016-01-03 05:34:45.547 [INFO ] [.service.AbstractActiveService] - NetworkHealth Refresh Service has been started
2016-01-03 05:34:45.553 [INFO ] [.o.b.i.InsteonPLMActiveBinding] - setting modem db retry timeout to 300s
2016-01-03 05:34:45.562 [INFO ] [.o.b.i.InsteonPLMActiveBinding] - dead device timeout set to 3000s
2016-01-03 05:34:45.587 [INFO ] [.o.b.i.InsteonPLMActiveBinding] - config: modem_db_retry_timeout -> 300000
2016-01-03 05:34:45.589 [INFO ] [.o.b.i.InsteonPLMActiveBinding] - config: port_0 -> /hub2/user:pwd@192.168.21.120:25105,poll_time=500
2016-01-03 05:34:45.595 [INFO ] [.service.AbstractActiveService] - InsteonPLM has been started
2016-01-03 05:34:45.716 [INFO ] [.o.b.i.InsteonPLMActiveBinding] - devices:   0 configured,   0 polling, msgs received:     0
2016-01-03 05:34:46.131 [INFO ] [.o.b.i.InsteonPLMActiveBinding] - config: service.pid -> org.openhab.insteonplm

You can leave your ,poll_time=1000 and do not need to set it to 500 - that was left over from me messing with performance.

I did find this absolutely required on my system with 60+ insteon devices:
modem_db_retry_timeout=300000

Prior to making the above adjustment (recommended by @Bernd_Pfrommer ) my system timed out and never worked.

First, check your network setup. What do you get if you:

telnet 192.168.2.53 25105

Is it connecting? If not, that’s the problem right there. Is the port open? Use a port scanner (like nmap) to see what ports the hub is listening on.

Next, make sure your password is right. I think you left it in the log, may want to edit that out. May sure you have “1” vs “l” vs “I” etc right in your password. My username also has a number in there, your’s doesn’t. Remember its the username/password that is on the bottom of the hub, not your web login.

From the openhab_default.cfg:

insteonplm:port_0=/hub2/my_user_name:my_password@myinsteonhub.mydomain:25105,poll_time=1000