Insteon Hub slow? Your thoughts

Hello to all the insteon users. My setup seems to be rock solid. I have two lamp Linc devices and the Insteon Hub latest version.

What I have found is when I command my two devices using a group switch one lamp comes on almost 1-2 seconds after the first.

When using Alexa through openhab I see the command in the open hab log then one lamp lags again. My group switches on other devices don’t have this issue. Curious is this normal for insteon? Or is there a switch I need to flip.

Second, I tried to link the two devices together and it works great using the switch on the side of the lamp linc. So switching one turns on the other. The issue is when I toggle in software this feature does not work?

//Dim insteon plug individually
Dimmer Ins_Plug1 "TV Lamp" (gBlackLamp) [ "Lighting" ]  {insteonplm="35.4E.C4:F00.00.19#dimmer"}
Dimmer Ins_Plug2 "Back Door Lamp" (gBlackLamp) [ "Lighting" ] {insteonplm="35.3F.5F:F00.00.19#dimmer"}

Group:Dimmer gBlackLamp "Black Lamp"  [ "Lighting" ] 

your code goes here

@Thedannymullen Is it always the same lamp that is lagging? Was it working fine before and the behavior you are describing just started? What happen if you turn on each switch separately from OH? Do you experience the same behavior when using the Insteon App?

A few things to note, there will always be a bigger lag when turning on a group switch in OH compared to having a linked scene at the Insteon level for the two switches. With the former, two distinct commands are sent compared to one with the linked scene. If you created the linked scene between the two devices, you could always use it in OH instead of the group one. You would have to just create an item pointing to the scene, assuming you created it through the Insteon App and not manually using the physical buttons.

When checking the logs, you should see two statements; one about the group item receiving the command in the event logs and another one from the Insteon binding in the openhab logs showing the command received by the relevant items. You should check if you see any time discrepancy between the two.


2018-08-05 23:53:16.785 [ome.event.ItemCommandEvent] - Item 'gTestLamp' received command OFF


2018-08-05 23:53:16.805 [INFO ] [g.insteonplm.InsteonPLMActiveBinding] - Item: TestLamp1 got command OFF
2018-08-05 23:53:16.997 [INFO ] [g.insteonplm.InsteonPLMActiveBinding] - Item: TestLamp2 got command OFF

@jeshab yes the lag alternates between lamps.

Curious can I control a scene on and off directly using openHAB? I did not see that asan option in the binding docs?

Yes, the concept of triggering a scene is called “group broadcasts” in the Insteon binding. The group number is the scene id that can be retrieved from the Insteon App.

However, you have to keep in mind that a scene is just an on/off switch so you wouldn’t be able to dim your lights through that item.

Thanks! I will read up more on that.

I have only had my insteon device hooked up for a week. So I am still learning them.

@jeshab Awesome response time using a group. Thanks! I realized I won’t be able to dim this way, but thats ok. Most of the time I don’t dim anyway.

Sad I didn’t try the group earlier, I thought it was for keypads only. My keypad comes in next week, I am hoping I can get it configured the way I want and enjoy having it. I want to use it as a scene controller in openhab.

I may be posting again in a couple days once that device shows up! Until then!

Just a hint on the dimming - I use groups for dimming all the time.

You can set up the group to send specific brightness levels to each item - I know it’s not as good as a slider but if you want to say go to 10% at sunset on both lamps then just set a scene with brightness=25 in the insteon system.

1 Like

@crxporter thanks for the tip! I like it! I am going to give it a try.

What are you using to create the scenes? The Insteon Hub app? Or something else?

I have the USB plm - so I use insteon terminal (command line) to set scenes. It’s not the easiest to set up but it works great once it’s programmed.

Yes I use insteon terminal also as some things programmed in the app don’t function in openhab.

I will have to look up how to program a scene. After programming the keypad with insteon terminal, I became a more savvy user.

I saved all of my programming in a text file. I’m on a plane right now but I can put a few samples on here once I land if you like - let me know.

That would be great. I am sure with an example, I can figure it out. Just need something to get me in the correct direction.

I really like the insteon devices.

I assume you already have insteon terminal set up, but here are a couple of lines from to define devices so I have shortcuts for programming:

# device definitions
modem        =  Modem2413U("test_modem", "44.85.d6")
 # dimmers
Office       =  Dimmer2477D("Office", "")
bedCeiling       =  Dimmer2477D("bedCeiling","46.a2.4f")
# micro dimmers
stairs   =  Dimmer("stairs","")
# switches
backPorch    =  Switch2477S("backPorch","34.0A.EC")

And an example of adding two items to scene 12:

Office.addResponder("44.85.d6",12, [0, 28, 1])
bedCeiling.addResponder("44.85.d6",12, [35, 28, 1])

So in this example, the scene sets Office to 0 brightness, ramp rate 28, button 1 (everything but keypadlinc is button 1 I believe). It sets bedCeiling to 35 brightness, 28 ramp rate, button 1. Then you have to tell the modem that those two devices are in the group - which is the 2 lines for adding to the modem. Brightness and ramp rate are on a scale from 0-255.

One final note is if you make a mistake you’ll have to remove the devices individually from the scene then add them back in. Like this:

bedCeiling.removeResponder("44.85.d6",11, [255, 28, 1])

From what I read it’s recommended to start at group 11 because 1-10 are used for other things in the insteon system. You can use up to group 255 - which would be impressive. I’m at like 40 dimmers/switches in my house and have only used through group 32 I think. Good luck!

@crxporter thanks for the information, this helps quite a bit! Sorry for my delayed response, I have been travelling the last few days. I will give these commands a try in the next day.