Insteon Leak Sensor wet condition is not detected

I’m using the Insteon 2852 Leak Sensor with an Insteon 2413U PLM and the OpenHAB 1.7.1 insteonplm binding. When a wet condition is detected, the sensor sends a 0x11 command on group 2 with a secondary command 0x02.

The insteonplm binding device feature specification is…

<feature name="LeakSensorContact">
	<message-handler cmd="0x03" group="1">NoOpMsgHandler</message-handler>
	<message-handler cmd="0x11" group="1">OpenedOrClosedContactHandler</message-handler>
	<command-handler command="OnOffType">NoOpCommandHandler</command-handler>

Note that the 0x11 message-handler specifies group=“1”. This works for the dry condition which sends an 0x11 on group 1 but not for the wet condition on group 2. I’m not sure how to fix this. The message handlers are indexed by command so I can’t add a second 0x11 entry for group=“2”. If I remove the group=“2” attribute, the group defaults to -1 which doesn’t match either dry or wet and the handler is never called.

Any suggestions?


Thank you for your feedback.

I think the group=1 parameter is a bug that I introduced with commit


on 4/24/2014.

Simply removing the group=“1” should fix it.

Your post says you are running the 1.7.1 binding. While I am aggressively supporting the latest binding I’m lazy on back supporting the older releases (it’s hard enough to get one dev environment working). Would you mind using the very latest version of the binding? I’ve seen people claim you can just drop the 1.8 insteonplm jar file into a 1.7 base installation, and it’ll work.

I have tacked the bug fix onto my pending pull request, and built a jar file for you. Please check the .jar file referenced with my PR #3205

Try dropping that into the addons folder and see if your leaksensor starts working.


I think if no group is specified, the handler will not filter the incoming messages by group, so that should work.

Yes, it works with the jar attached to your PR. Thanks!