Insteon Setup for a complete beginner

Hi all,
I’m a complete NOOB looking for some assistance with setting up my Insteon with OH2. I have the PI set up with OH2 as a fresh install and can’t seem to understand this binding.

I have hub version 2245-222 so it looks to me like I can use this config:

  • 2245-222 hub (2014-): use /hub2/my_user_name:my_password@myinsteonhub.mydomain:25105,poll_time=1000

I see the Insteon binding as an add-on in PaperUI, but it says PLM. Do I need the USB PLM to make this work or can I skip that? It would be nice to skip if I can so I don’t have to pair every one of my devices with the PLM. I have many switches and sensors to add so it would be a long process. I’ve found many docs online talking about the setup, but none actually explain the process understandably. Looks to me like I need to put that hub info in an insteon.cfg file somewhere and then fill in all of my info about items on the insteon network or does that populate automagically after my hub is detected?

You do not need the USB PLM, the hub binding was merged into the PLM binding a while ago. Just use the PLM binding.

You will need to link the devices to the hub using either the phone app or Insteon Terminal ( before adding it in OpenHAB. If you link the device later the binding will need restarted.

The bindings page ( has good examples of adding devices in your items file.

You are correct, you will need a config file. The binding installation should install a generic one in your services folder that you can edit. The 2014 version configuration will look like:

/# to connect to an Insteon Hub2 (the 2014 version) on port 25105, with
/# a poll interval of 1000ms = 1sec:


You will need to use the user name and password printed on the bottom of the hub, not the one set up in the cell phone app.

1 Like

One general tip.

Make sure you only have one insteon app open at any given time. So if terminal is running then shutdown openhab for example.

Also, when rrstaring openhab the logs will dhow what devices are setup in the modem.

All of my devices were previously linked to the hub via my phone app so I’m good there. I have entered my info in the insteonplm.cfg file and restarted the pi. I do not see an items file so I’m guessing I need to create one manually? I created insteonplm.items

I did see in the log:
[g.insteonplm.InsteonPLMActiveBinding] - devices: 0 configured, 0 polling, msgs received: 0
Found errors in the log stating wrong UN/PW. Realized I typed my creds wrong so fixed that…

Now I am seeing some movement in the log, but not there yet. Here are some of the major issues I see in there…

[nplm.internal.driver.hub.HubIOStream] - failed to write to hub: org.apache.http.conn.ConnectTimeoutException: Connect to timed out
2018-08-27 12:36:56.964 [WARN ] [ding.insteonplm.internal.driver.Port] - bad data received: got unknown command code 0x43
2018-08-27 12:47:27.139 [WARN ] [g.insteonplm.InsteonPLMActiveBinding] - device 3C.39.56 not found in the modem database. Did you forget to link?
2018-08-27 12:50:40.675 [INFO ] [g.insteonplm.InsteonPLMActiveBinding] - devices: 1 configured, 0 polling, msgs received: 0
2018-08-27 12:51:16.484 [INFO ] [el.core.internal.ModelRepositoryImpl] - Refreshing model ‘Insteonplm.items’

Ok yes you have some progress.

Can you shutdown openhab. Then open the insteon app on the phone. Need to see what version of firmware you have.

Sorry not at phone to tell you correct one but check it then post version please. Since you are talking with openhab it is probably ok, but i would like to double check. After this disconnect the app, reboot the hub and reboot open hanb. Lets get a clean start and look at the logs.

Lastly, an fyi i had some quirks linking in the app. In the end i seem to have got it all figures ouy, but initially had sime quirks. Dont worry once workimg in your setup, you will think gee ghat was simple!!

Insteon App shows:
BIN version Hub2-V04-20140904
PLM Version A3
Hub Version 1017

Getting this continual error now after closing out of the app on all devices and rebooting Hub and OH

[ERROR] [nplm.internal.driver.hub.HubIOStream] - got exception while polling: org.apache.http.conn.HttpHostConnectException: Connection to http://192:25105 refused

Rebooted everything and started to get lots of login errors

2018-08-28 06:57:01.487 [ERROR] [nplm.internal.driver.hub.HubIOStream] - bad username or password. See bottom label of hub for correct login
2018-08-28 06:57:01.490 [ERROR] [nplm.internal.driver.hub.HubIOStream] - failed to write to hub: login credentials incorrect

Checked password again and also reset in app based on PW from bottom of hub. Closed OH and App, rebooted everything again. Appears as though the UN/PW issue is resolved, but I’m still getting the same issues as before.

2018-08-28 07:02:05.446 [INFO ] [nding.insteonplm.InsteonPLMActivator] - Insteon PLM binding has been started.
2018-08-28 07:02:05.525 [INFO ] [g.insteonplm.InsteonPLMActiveBinding] - poll interval set to 300000 per config file
2018-08-28 07:02:05.528 [INFO ] [g.insteonplm.InsteonPLMActiveBinding] - setting modem db retry timeout to 240s
2018-08-28 07:02:05.530 [INFO ] [g.insteonplm.InsteonPLMActiveBinding] - dead device timeout set to 3000s
2018-08-28 07:02:05.539 [INFO ] [g.insteonplm.InsteonPLMActiveBinding] - config: poll_interval -> 300000
2018-08-28 07:02:05.539 [INFO ] [b.core.service.AbstractActiveService] - InsteonPLM has been started
2018-08-28 07:02:05.542 [INFO ] [g.insteonplm.InsteonPLMActiveBinding] - config: modem_db_retry_timeout -> 240000
2018-08-28 07:02:05.545 [INFO ] [g.insteonplm.InsteonPLMActiveBinding] - config: port_0 -> /hub2/,poll_time=6000000
2018-08-28 07:02:05.550 [INFO ] [g.insteonplm.InsteonPLMActiveBinding] - devices: 0 configured, 0 polling, msgs received: 0
2018-08-28 07:02:05.612 [INFO ] [g.insteonplm.InsteonPLMActiveBinding] - config: -> org.openhab.insteonplm

2018-08-28 07:06:05.870 [WARN ] [onplm.internal.device.ModemDBBuilder] - modem database download unsuccessful, restarting!
2018-08-28 07:06:05.889 [WARN ] [steonplm.internal.message.MsgFactory] - incoming message does not start with 0x02
2018-08-28 07:06:05.896 [WARN ] [ding.insteonplm.internal.driver.Port] - bad data received: incoming message does not start with 0x02
2018-08-28 07:06:05.918 [WARN ] [ding.insteonplm.internal.driver.Port] - got bad data back, must assume message was acked.

Holy Santa Claus S***!
I have some positive results although they aren’t really that positive LOL. It is finally reading something from the Hub.

2018-08-28 07:27:41.825 [INFO ] [g.insteonplm.InsteonPLMActiveBinding] - modem database has 34 entries!

This one I manually put into my items file already:
2018-08-28 07:27:41.833 [INFO ] [g.insteonplm.InsteonPLMActiveBinding] - device xx.xx.xx found in the modem database and the modem controls groups [0x00,0x1C,0x1D,0x21] and responds to groups [0x01].

The other switches and such have not been entered into the items file yet so guessing that is why I’m getting part of these errors…

2018-08-28 07:27:41.855 [INFO ] [g.insteonplm.InsteonPLMActiveBinding] - device yy.yy.yy found in the modem database, but is not configured as an item and the modem controls groups [0x00] and responds to groups [0x01].

Yes if you have mismatches the logs will let you know. Hey forward progress!!

Once everything is entered as an item or you remove from modem. The errors will go away about mismatching things.

1 Like

I was wondering if someone could lend a hand, I too have a RasB Pi-3 and I’m trying to connect to a 2245-222, and having some issues?

I have added the following to my cfg:

and I’m getting the following error?
[ERROR] [onplm.internal.driver.SerialIOStream] - got no such port for hub2/,poll_time=1000

Any help would be appreciated.

Nevermind, looks like I have some movement now after a reboot:

12:10:12.795 [INFO ] [g.insteonplm.InsteonPLMActiveBinding] - modem database has 25 entries!

I take that back , I’m getting the following error now after adding items to my items config.

[WARN ] [g.insteonplm.InsteonPLMActiveBinding] - no device found with insteon address 28.30.EB

That is just a warning saying the device showing in your modem is not online. This is not an error. It’s working, just need to setup all the items now.

I set up three devices and I get the same warn for all of them? And I get no lights to come on?
How do I get the modem online?

This is telling you that you have not linked your device with the hub. If you’ve done it correctly you should see something like:

2018-10-14 09:20:44.799 [INFO ] [g.insteonplm.InsteonPLMActiveBinding] - modem database has 62 entries!
2018-10-14 09:20:44.818 [INFO ] [g.insteonplm.InsteonPLMActiveBinding] - device 23.9F.C9 found in the modem database and the modem controls groups [0xFE] and responds to groups [0x01].

I don’t understand?
All of my devices are setup in my hub?
As my hub does work with the Insteon Android app just fine?

Here is the log entry after a reboot?

2018-10-17 15:29:18.461 [INFO ] [g.insteonplm.InsteonPLMActiveBinding] - device 28.30.EB found in the modem database, but is not configured as an item and the modem controls groups [0x00,0x0B,0x0C,0x0E,0x19] and responds to groups [0x01].

This is the same issue that I ran into. Do you have your devices defined in your items file? You can take the list from the boot log and gather a list to create the items list or utilize the Insteon tool to poll everything. Each Insteon device needs to be listed in the items file before that error will go away in the log

Yes, the 3 I’m working with now are in there?
Switch Tourch1 “Tourch 1” {insteonplm=“28.30.EB:F00.00.19.02#switch”}
Switch Tourch2 “Tourch 2” {insteonplm=“2C.F5.F7:F00.00.19.02#switch”}
Switch Tourch3 “Tourch 3” {insteonplm=“27.4F.C5:F00.00.19.02#switch”}

I am out of town tonite but can assist tomorrow unless you get it figured out before then. The Insteon bindings document shows the exact context that the item needs to list. Once they’re in there you can see then in paperUI and map in HABpanel.

1 Like