Insteon Update

Happy to be a beta tester and thank you for the prompt reply. Many of us have many $$$'s invested in our home automation systems, and myself have mostly Insteon devices. Glad to see such a swift reply on this issue.

Thank you!

1 Like

I have the same problem. Is there anyway to flash an the 1015 firmware onto the hub?

I should have googled further before posting.

This worked:

Rolled firmware back to 1012 which is now working fine except messages are kind of sluggish. Perhaps after sitting for a while it will speed up.

I added a firewall rule to my router to block the modem from the internet. Should solve the update problem. To add devices I’ll need to toggle the rules off to use the app I imagine.

Were you able to restore to a specified firmware version or did Insteon choose for you?

I assume it was the version which was previously flashed on the modem.

+1 I got the update Tuesday night and on Wednesday openhab can no longer control my Insteon devices. It think it can, but nothing happens.


Just received a reply to my support email:


I am very sorry to hear you are experiencing issues with the most recent update.

We are aware of an issue where our latest hub firmware update (1016) caused integrations using local http commands to stop functioning. While this is not an officially supported API, we understand that having local command and control is preferred among a select group of users as well as some 3rd party software developers. Therefore we will be looking to make the necessary updates to restore this functionality. If you are using the local API, we would like to invite you to join our beta group to assist us in testing our next update. Your participation will also ensure that any future updates do not impact your integration. To submit your request to join the beta program, fill out the form here. Be sure to select OpenHAB or HomeSeer as the software you are using so that we can arrange a special firmware build that will restore local API control. Please be patient as we will need time to get you setup as a beta tester and to configure your account.

_Thank you for choosing Insteon for your home automation network and we appreciate your patience while we work to resolve this issue.

If you do not wish to join the beta program, but still require we push out the modified firmware, please reply back to this email with your Hub ID number, and associated email address, and we will have our software team push out the necessary update.

Please forward this request along to other effected users you are aware of who may not have already contacted us regarding the issue. They can send their emails to with the subject line “1016 Firmware Direct Command Issue” and we will take care of them ASAP.

Kind regards,
Daniel P - Customer Solution Lead


This is what I got.
Not OK
You can access this hub remotely without any problem.

If you are looking for any other information, feel free to contact us. We will be happy to help you.

Ryan Wilson

Insteon just pushed a rollback firmware to my hub. After re-enabling the Insteon PLM binding, I am able to interact again with my Insteon device through openHAB. The hub firmware version shows as 1015. So I will assume that Insteon just downgraded the users that notified them using the instructions listed above.

I just received the 1015 “Rollback” too. It’s dated June 20 2018, 15:40. My email request for it was submitted about four hours ago, so I’d say their response time is very good.

After the rollback my system was in a zombie state. Openhab was correctly responding to commands (as seen in the logs and on my habpanels), but the insteon devices ignored them. However the Insteon App was still working Ok at this point.

After rebooting openhab and the hub I have a working system again. Time to celebrate!

  • Thomas

Same here, hub is on the rollback version, and openhab is currently jacked up. Going to reboot before I troubleshoot anything, but Im betting she’ll be good to go when it comes back up.

ETA: Reboot of Openhab fixed it and we’re good to go. Really happy with Insteon’s response to this

@insteon, thanks for helping out with this situation. It would be awesome if your team could provide assistance on ways we could improve the binding.

So, the question i have is… Is the binding under active development as can we get an update that will work with the new firmware. Aka an update that doesn’t use http, but some other protocol?

Kudos to @Insteon for the rapid response and the prompt firmware rollback.

@Thedannymullen - There hasn’t been any development on the Insteon binding in a long time. If I remember correctly, the developer that created this binding (@Bernd_Pfrommer) had no intention of updating the binding for OpenHAB 2, since he had no plans to upgrade his OH installation. I’m not sure if anyone else here has the same intimate knowledge of the Insteon protocol.

1 Like

I never got my rollback. I tried the instructions in Insteon article but never got the hub to rapidly beep after pressing he button 5 times. How did everyone get their rollbacks? I’m still crippled here :disappointed_relieved:

@mark_alan_williamson I sent my hub info to Insteon, and they pushed it. I checked the app to see if an update was available, but it had already put the v15 code on and rebooted on its own

Thanks, looks like they restored my hub back to 1015 last night. I’m very happy with their customer service.

1 Like

What did you do to rollback the last update?
What do they say at Insteon, when would be a planned update to fix the issue?

thank you

Read post #25:


A new firmware is being released today for our Insteon Hub (2245-222) that reverts back to allowing local http commands. You can read more about the update here:

Future updates will be vetted by some of the kind folks here that are now on our beta program. This will ensure any future updates do not disrupt integrations such as those used by OpenHAB.

Thank you for your patience and support.

Kind regards,
The Insteon Team