Insteon Update

Hey folks, hoping this is the correct place to put this posting. I’ve been using the Insteon binding to work with an Insteon hub for about a year and a half or so now, have always had good luck with it. My insteon hub received an update this morning, and now connectivity between openhab and the hub is broken. Tailing the log shows a bunch of 403 errors, with the hub replying “SSL Required” to openhab. I’m assuming the Insteon update no longer works with http, and will only answer on https. Will their change make it so the binding needs to be updated as well, or can you configure ssl inside the config file and I’m just missing it? Thanks for the help.

My current config reads like this: port_0=/hub2/UserName:Password@,poll_time=1200

+1. Mine is broken too.

Insteon pushed their latest hub update onto my 2245-222 controller a couple hours ago. It broke the openhab insteon binding.

Web access using their official smartphone app is still working fine. But I’m getting the SSL error and all insteon devices are no longer accessible from openhabian.

Also, local web browser connection to the hub using the IP:port URL no longer works either. It too gives a “403 Forbidden: SSL Required - use HTTPS” error.

Here’s the announcement they published a few days ago.


Broken on 1.8 openhab here.

@Bernd_Pfrommer any suggestions? I’m guessing the current binding implementation doesn’t support ssl.

I noticed the same thing this morning. Even if the binding supported SSL I don’t think it will work. I have a feeling that Insteon botched their implementation of SSL as I can’t connect to the hub using a standard browser using https on port 443 or the original port 25105. They either changed the port or screwed up http(s) connection to the PLM which is bad for us.

I own a hub, but it broke some time last year, just stopped working. I can’t even reproduce the problem.
Can somebody do a port scan (nmap) to see what ports are still open?

Users on the Homeseer forum are complaining of the same issue. It seems a plugin developer over there is also trying to assist. Perhaps following this thread on the Homeseer forum may provide some insight?

If you still have the broken hub and a soldering iron, you should be able to bring it back to life in 15 minutes. Replace cap C7 (47uF/50V). I’ve repaired two dead units by changing this cap.

25105 and 443

I also fixed my dead hub that way, worked great.

I get the same ports, I don’t think insteon implemented ssl properly and might be why we cannot connect.

Thank for the link @peteraquino. Lots of good info going on at the HS forums. I hope to contribute more when I’m back on my feet. Throwing your back out sucks

This might be good news

Insteon is going to push out ver 1015 code (labeled as 1016) to roll everyone back.

I guess all the calls worked

Hello all,

I am writing on behalf of Insteon and wanted to share an update with you all:

We are aware of an issue where our latest hub firmware update (1016) caused integrations using local http commands to stop functioning. While this is not an officially supported API, we understand that having local command and control is preferred among a select group of users as well as some 3rd party software developers. Therefore we will be looking to make the necessary updates to restore this functionality. If you are using the local API, we would like to invite you to join our beta group to assist us in testing our next update. Your participation will also ensure that any future updates do not impact your integration. To submit your request to join the beta program, fill out the form here. Be sure to select OpenHAB as the software you are using so that we can arrange a special firmware build that will restore local API control. Please be patient as we will need time to get you setup as a beta tester and to configure your account.

We appreciate your patience while we work to resolve this issue and thank you for choosing Insteon for your home automation projects.

Kind regards,
The Insteon Team


Thank you for responding to our concerns. Local control is definitely preferred as it gives us more control into how insteon works and does not rely on an internet connection. Local connections also allow us to control our own security and encryption. It’s too bad that local connection is not supported and also confusing. The sticker on the back of my hub has the http port for local connection so I’m sure at one point this WAS officially supported. I believe it should continue to be supported. This is why I love Insteon so much.

I hope for a speedy fix to this problem. Thanks again for the info.

The question is how many days will my house not work?

@Insteon, thank you for the status update. I don’t want to be a beta tester, but would like a rollback to 1015. Will that occur automatically or do I need to contact support and request a rollback?

  • Thomas

Thanks very much guys for reaching out about this issue, I really appreciate the response from the Insteon team. I’d be happy to participate in the beta program, will fill out the form this evening.

Happy to be a beta tester and thank you for the prompt reply. Many of us have many $$$'s invested in our home automation systems, and myself have mostly Insteon devices. Glad to see such a swift reply on this issue.

Thank you!

1 Like

I have the same problem. Is there anyway to flash an the 1015 firmware onto the hub?

I should have googled further before posting.

This worked:

Rolled firmware back to 1012 which is now working fine except messages are kind of sluggish. Perhaps after sitting for a while it will speed up.

I added a firewall rule to my router to block the modem from the internet. Should solve the update problem. To add devices I’ll need to toggle the rules off to use the app I imagine.