Internet Radio - I need your help!

I have Hama radio, which works fine with this binding. But I can’t figure out, how to control playback (play/pause, next track), when using USB stick as a source?

Maybe this will be useful for someone:

  • in you can define your own radio station (=openhab box) and push it to your radio. This station could be assigned to preset, which could be controlled from OH2 later.
  • and then use streaming server (i.e. mpd) on openhab box to stream audio
  • probably you could route OH2 sink to mpd and have FS radio as OH2 audio sink (to be tested. any ideas how to route audio internally?)

Good evening folks,
I am trying to connect to my Sangean WFR-28D with the FS Internet Radio Binding without success. I need your help since I don’t know why it is not working.

I connected my Hama IR320 which is in the same network as the Sangean radio without any issues. So I know my setup looks good so far.

From the outside look it is similar to the Sangean WFR-28C so I thought let’s give it a try. Also the displayed texts are similar to the Hama IR320 ones.

The manual mentions following paragraph:

Network Pin setup (Pin number)

Your radio has the option of being controlled by an application installed on an Apple iPhone, iPod

touch or iPod. The Pin number facility allows you to ensure that your radio can only be controlled by

your own Apple device rather than someone else’s.

Details of how this feature can be used with your iPhone or iPod touch are explained in the separate

section in this manual called ‘Using iSangean app for controlling your WFR-28 internet radio’.

But when i try to connect with I also tried 1234, but i set it to 0000 in the radio menu. This also makes me think I am on the right way. I don’t recieve anything. I tried that with the browser and also with the curl command. No reply.

My radio.things looks like this:

fsinternetradio:radio:radioInLivingroom [ ip="", pin="0000" ]
fsinternetradio:radio:radioInKitchen [ ip="" ]

Please help me! Thanks in advance :slight_smile:

Maybe your radio uses a different port (see post from March 14)? You could try:
Or use a port scanner to check which port is open at your device.

Hey Patrick,

Thank you so much for your help! The port 2244 was the key. Now everything works as expected! Now I can confirm that Sangean WFR-28D will work with 2244 as a default port!
I cannot wait to program my new alarm clock :wink:
Thank you so much again.

I really appreciate this community. Never saw such a helpful one.


I have an old Roberts Revival iStream (v1) which looks like a basic FS based internet radio.

Output of as I don’t have UPnPTester on my Mac…

<root xmlns="urn:schemas-upnp-org:device-1-0" xmlns:pnpx="" xmlns:microsoft="urn:schemas-microsoft-com:WMPNSS-1-0" xmlns:df="">
<pnpx:X_hardwareId>VEN_2A2D&amp;DEV_0003&amp;SUBSYS_0004&amp;REV_01 VEN_0033&amp;DEV_0005&amp;REV_01</pnpx:X_hardwareId>
<dlna:X_DLNADOC xmlns:dlna="urn:schemas-dlna-org:device-1-0">DMR-1.50</dlna:X_DLNADOC>
<friendlyName>Revival iStream 002261a4e9f0</friendlyName>
<manufacturer>Roberts Radio Limited</manufacturer>
<modelName>Revival iStream</modelName>
<modelNumber> </modelNumber>

Roberts Revival iStream API is on TCP port 2244:


I have a Roberts Stream 107 and it works fine with this binding. Thank you!

Works as the instructions say.

FS_OK 1862805258



The binding works fine with Block SR-50 internet radio.

It seems either the device can be controlled by openhab or by UNDOK app. Each logs off the other one. Is there a workaround for this behaviour? I like to use both (for scene automation with openhab and as the app is quite user-friendly as regular remote when I only want to control the radio device).


I have a Roberts multi-room setup that I’d love to see work with this binding. I have an R100 radio and 2 RS-1 adapters.

Here is the R100:

Description: ir-mmi-FS2026-0500-0267-R100_V2.11.12c.EX67897-V1.13
DeviceType: urn:schemas-upnp-org:device:MediaRenderer:1
FriendlyName: Bedside Radio
Manufacturer: Roberts Radio Limited
ManufacturerUrl: http:// www. robertsradio. com/
ModelName: R100
ModelNumber: R100
ModelURL: http:// www. robertsradio. com/
PresentationUrl: http://
SerialNumber: 0f07050b393b1f270101bf05ffffb0ff
UDN: uuid:3DCC7100-F76C-11DD-87AF-0022612BC9C0

Here is the RS-1 adapter:

Description: ir-mmi-FS2026-0500-0364-RS1_V2.11.12.EX68122-V1.05
DeviceType: urn:schemas-upnp-org:device:MediaRenderer:1
FriendlyName: Kitchen Audio
Manufacturer: Roberts Radio Limited
ManufacturerUrl: http : // www. robertsradio. com/
ModelName: RS1
ModelNumber: RS1
ModelURL: http : // www. robertsradio. com/
PresentationUrl: http : //
SerialNumber: 0f0c1809371a1f2701016605ffffc4ff
UDN: uuid:3DCC7100-F76C-11DD-87AF-0022613A1B74

I’ve had to add spaces to all the URLs as I’m a new user and this stupid software won’t allow me to post more than 2 links!


I have a HAMA DIT 2100MSBT Tuner, which works well with this binding after manually creating the thing.
It would support much more functionality than this binding provides.
Maybe it is possible to add more features?

UDN uuid:3DCC7100-F76C-11DD-87AF-00226181FFFF
Type urn:schemas-upnp-org:device:MediaRenderer:1
Base URL
Friendly Name [Radio]WoZi DIT2100MSBT
Manufacturer HAMA GmbH
Manufacturer URL
Model Description 
Model Name DIT2100MSBT
Model Number DIT2100MSBT
Model URL
Serial Number 12071b0713351f2701016800ffffffff
Presentation URL

UDN uuid:3DCC7100-F76C-11DD-87AF-00226181FFFF
Type urn:schemas-upnp-org:service:RenderingControl:1
Base URL
Service ID urn:upnp-org:serviceId:RenderingControl
Service URL
Control URL
Event Subscription URL

UDN uuid:3DCC7100-F76C-11DD-87AF-00226181FFFF
Type urn:schemas-upnp-org:service:ConnectionManager:1
Base URL
Service ID urn:upnp-org:serviceId:ConnectionManager
Service URL
Control URL
Event Subscription URL

UDN uuid:3DCC7100-F76C-11DD-87AF-00226181FFFF
Type urn:schemas-upnp-org:service:AVTransport:1
Base URL
Service ID urn:upnp-org:serviceId:AVTransport
Service URL
Control URL
Event Subscription URL

Hello everybody,
I come back to write again something in this thread because I recently noticed a little problem using this binding with my radio Auna Connect 150: the volume-percent channel doesn’t work as expected because in my radio model the absolute volume works in the range 1-20 (not 1-32 as described in the binding documentation) and so the volume-percent channel doesn’t show the right percentage of the actual volume.
I try to give you an example of the situation: if my volume-absolute channel is set to 5 (that is the 25% of the maximum reachable volume) the volume-percent channel show something like 15%. I guess the binding makes this calculation: 5/32 because it assumes that all the FS radios have this 32 points volume range.
I always used this binding without problem just with the volume-absolute channel, but recently I tried to add to my system some voice controls through Google Home and I found out that for this purpose it is useful to have a dimmer item with the volume expressed as a percentage. So, it would be great for me to have the possibility to use this channel too even if I have a model with a 20 points absolute volume range instead a common 32 one.
Could anybody help with this? Bye.


is it possible to add Play/Pause/Next/prev channels to the binding so you can control for example spotify.
I have a Roberts S1 and an Hama DIT2000. all the available options working fine.
just missing a few things

Hi Marcel,
This is probably possible. Unfortunately, I don’t actively use / develop this binding at the moment, so I cannot help you. If you know some Java, you could add that Feature yourself and open a pull request for it…
Happy easter :slight_smile:

Here’s my MEDION P85111 / MD88295:
Medion P85111 MD88295

Works when adding manually, but is not detected when scanning.

1 Like

I’m trying the bindig with an auna connect 150 SE an I always get


Hey marmoh,
did you get it to work at openhab?

I bought an auna connect 150 SE und put it into OH3 with fs internetradio binding. Sometime it works, sometime it does’t work and I get the error: COMMUNICATION_ERROR This is shown at the openhab.log: “18:32:14.837 [ERROR] [radio.FrontierSiliconRadioConnection] - Fatal transport error: java.util.concurrent.TimeoutException: Total timeout 5000 ms elapsed” OH3 shows me: COMMUNICATION_ERROR “java.util.concurrent.TimeoutException: Total timeout 5000 ms elapsed” Any idea how to fix this?

Hi all! Just wanted to mention that the Marshall Woburn Multiroom speaker is also working with that binding! Pin is 1234 as well! :slight_smile:

I’ve only discovered two bugs:

  1. Auto-discovery is not working. you need to add the speaker manually
  2. Preset is not updated (UNDEF).

I hope this information can help for people with same or similar speakers! :slight_smile:

1 Like

A small update of this device (Block receiver CVR100) after roundish 4 years:

  1. Volume settings never worked
  2. When using AUX the smart radio does not appear to be smart and useful settings like mute and power are disabled
  3. Some Internet Radio stations (like Radio 10 in the Netherlands) get additional content (read advertisements) pushed during streaming; will this be the future of smart devices?

Solution: A PiCorePlayer on AUX and solving:

  • no additional content pushed in Internet Radio broadcasts (so far)
  • able to use Spotify
  • access to my music library in much friendly and quicker way (using HIFI-cast as APP with DNLA plugin)
  • synchronize two receivers (struggling with the Spotify part, but hopefully not without a good end)

A bit off topic but it was raining.