Investigating my Amazon to Openhab not functioning issue

Its been three days since my Amazon echo devices got a response for openhab exposed items.
My best guess at the moment is that the issue is in the cloud and it is either Amazon or MyOpenhab, its never really easy to figure out which. I can say that I am able to control all other devices other than Openhab from Alexa. Unfortunately I have around 250 ittems on Alexa that are not currently available to the house as they are are in part or wholly dependant on Openhab being reachable.

So firstly, I did a few searches to see if I could see any others discussing any issues as it could still be something at my side (I have rebooted my OH system) but I could not find such a topic, although there was mention of new items could not be exposed, my items have been exposed for a long time so parking that as the issue for now.

I am a little bit stuck, normally the issue simple resolves itself by magic over night I have not seen an issue carry on for three days that often and certainly without me being able to locate a relevant thread that explains what is going on.

I am starting to look at how to bypass the OH cloud for the must have working (critical) stuff.




It seems that the Alexa Openhab skill was updated to v3 around the timeframe of my issue with non responding devices see here

It is getting a little late for me to concentrate so I will read through the thread in the morning but this could be the root cause of my recent issue.


Hello Paul,

I had the same issue this week, a reboot of my OH Pi did not fix the connection with Alexa, My Openhab was connected, so it should have worked!
I fixed it bij restarting the Cloud Connector in KARAF, Bundle:restart ID (where ID is the number of the CC)
Maybe this works for you also,

A reboot had not worked, my cloud connector was established correctly after the restart.

I have clear the issue after finding the thread about the new version of alexa skill by simply asking her to discover devices. This apparently starts the migration to the v3 skill and then everything just worked.