IP address for openhab runtime changes after router reboot

Hey everyone, new user here, just set up habpanel after configuring a time of things in the paper UI.

I am encountering an issue though:

Each night, my router turns off (my wife has a condition where wifi affects her sleep) and turns on again in the morning.

Each day this happens, the address for the openhab panel changes. It’s fine on the iMac where it’s installed, but on my tablet upstairs using the actual address ( changes each day and so can’t find the right page. I have to go into the setting on paper UI, find the new IP, and reload the page on the tablet.

Is there a way to set a fixed up to run openhab? Or what solution would you recommend?

Thanks in advance :pray:

You should be able to reserve the mac address of your server (RaspberryPi) in the dhcp settings on your router. Failing that, in your server you can set a static option address.
Google has more options.

Alternatively, can you just use your server name?

1 Like

As Crispen indicates, you need to look to your router first.

See if you can reserve an IP for your server in the router’s DHCP settings so it always assigns the same ip to your openHAB server.

If your router doesn’t provide this option, you can see if using the hostname works. Most computers advertise their hostname and the routers recognize this so you can access machines by their hostname.

If that doesn’t work, it is possible to configure your OH server with a static IP on the server itself (see Crispen’s link above). Just be sure to choose an IP address at the high end of the range so one of your other devices doesn’t grab the same address when the router starts back up in the morning.

Personally, I would buy another wifi router if your current one doesn’t support assigning a static IP address to your machines and just use your existing supplied by the isp gateway as the Wan to your new more capable wifi router. Then set the static IP addresses in the new router.

Thanks so much I will take a look


Just to throw in a curve ball.

I have an AVM FritzBox router, which has an option to turn off the WiFi to a schedule, or with a short code dialed into an attached phone, or simply reduce transmission power when not being actively used.

I ended up changing my IP on the iMac to manual, and giving it a fixed IP. This fixed the issue :slight_smile:

1 Like