IP Camera Binding not working after move to OH3

Hi there,

unfortunately, I cannot get the ip camera binding working with my 2 Edimax cameras after setting up OH new recently with v3. It was working well few months back on v2.5.

Platform: openhabian release 3.0.1 on RPI3

I’m using the ip camera binding and a generic ipcamera Thing type. I’m configuring the snapshot and mjpeg url with information like “http://192.168.178.xx:yyyyyy/snapshot.cgi” (camera’s IP and http port) which provides me the image stream in a web browser. Now, the strange thing is that as soon as I enable the Thing, I cannot access the image stream at its original adress (see above) anymore. Hence, it’s clear to me that I also cannot access the stream via the binding’s image url and mjpeg url channels. These channels/items though do give me a proper target url (e.g. “http://192.168.178.zz:aaaa/ipcamera.mjpeg” being the openhab server and server port). Just no image visible there.

Any ideas or hints? Anywhere to check further? I did already restart/reboot, also reinstalled the binding, etc. (obviously checked forum…)

Thanks for any ideas! Highly appreciated!

Perhaps you can try it with release 3.1.0-SNAPSHOT :wink:

And then have a look here: OH3 Widget: Building a camera widget

Why guess or blindly try things when you can turn on TRACE logs and get more information. See the bindings documentation and at the top is a section called how to get help.

Hi colleagues - thanks!

Yes, I did trace logs and search the forum for similar issues. Couldn’t figure out any solutions :frowning:

Logs only gives me

2021-03-02 21:43:10.378 [TRACE] [era.internal.handler.IpCameraHandler] - Sending camera: GET: http://192.168.178.xx:yyyyy/snapshot.cgi
2021-03-02 21:43:18.380 [TRACE] [era.internal.handler.IpCameraHandler] - Sending camera: GET: http://192.168.178.xx:yyyyy/snapshot.cgi

repeatedly. (Replace x and y with the camera’s IP and port).

Again, the very akward thing - which I was hoping to give an indication of the issue - is that I cannot access the IP camera’s image anymore even at its original IP/port as soon as I activate the openhab Thing. I can again as soon as I disable the Thing.

Any idea how to further investigate? Thx!

What happens in the logs when you try to open snapshots.mjpeg in any web browser? See docs for info on this feature.

Some cameras only allow a single connection at a time so that may be normal for your camera?

Some cameras only allow a single connection at a time so that may be normal for your camera?

Fair point - but no, doesn’t seem to be the case. Having the Thing/Binding deactivated, I can access the video stream from the IP cam via web browser simultaneously from different devices.

What happens in the logs when you try to open snapshots.mjpeg in any web browser?

I don’t get much info in the log when accessing any url (server url, etc.). The only I get is

2021-03-03 22:34:42.442 [TRACE] [era.internal.handler.IpCameraHandler] - Sending camera: GET: http://192.168.178.xx:yyyyy/snapshot.cgi
2021-03-03 22:34:48.849 [DEBUG] [era.internal.handler.IpCameraHandler] - File server for camera at 192.168.178.xx has started on port aaaa for all NIC's.
2021-03-03 22:34:52.857 [WARN ] [era.internal.handler.IpCameraHandler] - Binding has not been supplied with a FFmpeg Input URL, so some features will not work.
2021-03-03 22:34:52.885 [TRACE] [era.internal.handler.IpCameraHandler] - Sending camera: GET: http://192.168.178.xx:yyyyy/snapshot.cgi

By intention I’m not using FFmpeg.

Thx.

You dont need ffmpeg for that feature to work and you should at least see the binding report that it knows you are asking for the stream.

I have no ideas then why it stops the camera working until you disable the binding, it may be possible to cause an internal error in the camera if something was going wrong that the camera did not like. Do you know how to use wireshark? it would be interesting to see if the camera is responding at all and with what data. If you compared what happens when the binding ask VS when you ask with a browser it may provide a clue.

If you post a 2 way data trace, make sure you change the password to something you dont care about, or just edit some of the data to make it non valid.