Ipad ios openhab panel cannot connect to openhab 2.4.0

  • Platform information:
    • Hardware: raspberry pi 2
    • OS: raspbian
    • Java Runtime Environment: 1.8
    • openHAB version: 2.4.0
  • Issue of the topic: After upgrade to 2.4.0 the ios app cannot connect to the openhab server. The ios app says “discovering openHAB”, then “connecting to discovered URL” and finally (in red background): “Error: could not connect to the server”.
    I power-cycled the iPad but that didn’t help.
    My Android phone has no problem connecting to the server.

Did you try to connect manually?

Did you upgrade the iOS App yet? (afaik I’ve updated the app at my wife’s iPad around the 4. of January)

Yes, I upgraded the app. Maybe that is the problem! I am going to wait, maybe other people have the same problem. I tried to change the syntax of the url, now it is the same as my Android app (with double slashes before the IP address and an ending slash after the port number). Same result (i.e. empty screen).

Still same problem. Android app works, IOS app does not work. IOS app version is Reinstalled openhab, restarted ios app. No solution.

my problem is similar though not the very same. i wonder if these are related.

when iphone is on the same local net as OH server (through wifi), mobile app goes blank after discovering URL. when I turn off wifi and the phone tries to connect over the air it works.

i am using OH 2.4.0-1 and iOS app 2.0.3

any hints how to debug the issue?