IR blaster


(Ramy Rutu) #1

How to make wired IR work with OpenHab2 installed on RPI3? I am using Lirc and I have installed Lirc Binding and filled my Item, rules, sitemaps and things files and nothing seems to work!! I would like to send signals throw on HabPanel let’s say to turn on my Tv
By the way I have followed this tutorial and used the code


(Vincent Regaud) #2

Which PIR sensor?
How does it communicate it’s state? RF? WiFi? Wired? Which protocol?

It has nothing to do with LIRC which is a binding to SEND/RECEIVE ir commands to devices like TVs, AC units and the likes


(Ramy Rutu) #3

My bad I have fixed the topic… I have an IR led weird connected to my RPi3 and I am trying send command to turn on and off RGB led light throw openhab into habpanel. My bad for the confusion!!


(Vincent Regaud) #4

OK

Show you items, things and rules and LIRC configuration
How is your LED connected to the pi? What pin? What circuit?

Please use the code fences.


(Ramy Rutu) #5

I am new to codes and python and all that so please understand me if you see my code is messed up… I have copy and paste and modified everything here . I followed this
https://github.com/mtraver/rpi-ir-remote and followed this Problems with implementing lirc to control IR-devices
my LED/IR blaster is connected by wire to gpio 5 and that’s my /boot/config.txt file

Uncomment this to enable the lirc-rpi module

dtoverlay=lirc-rpi,gpio_out_pin=5,debug=1

and that’s my lirc service status:
sudo systemctl status lircd.service
● lircd.service - Flexible IR remote input/output application support
Loaded: loaded (/lib/systemd/system/lircd.service; enabled; vendor preset: enabled)
Active: active (running) since Mon 2018-09-24 19:23:40 EDT; 2s ago
Docs: man:lircd(8)
http://lirc.org/html/configure.html
Main PID: 2840 (lircd)
CGroup: /system.slice/lircd.service
└─2840 /usr/sbin/lircd --nodaemon --driver=default --device=/dev/lirc0 --listen=192.168.2.97:8766

Sep 24 19:23:40 raspberrypi lircd[2840]: lircd-0.9.4c[2840]: Notice: lircd(default) ready, using /var/run/lirc/lircd
Sep 24 19:23:40 raspberrypi lircd[2840]: lircd-0.9.4c[2840]: Notice: Connected to 192.168.2.97
Sep 24 19:23:40 raspberrypi lircd[2840]: lircd-0.9.4c[2840]: Notice: accepted new client from 192.168.2.97
Sep 24 19:23:40 raspberrypi lircd[2840]: lircd-0.9.4c[2840]: Info: Cannot configure the rc device for /dev/lirc0
Sep 24 19:23:40 raspberrypi lircd-0.9.4c[2840]: Warning: Running as root
Sep 24 19:23:40 raspberrypi lircd-0.9.4c[2840]: Info: Using remote: RGB.
Sep 24 19:23:40 raspberrypi lircd-0.9.4c[2840]: Notice: lircd(default) ready, using /var/run/lirc/lircd
Sep 24 19:23:40 raspberrypi lircd-0.9.4c[2840]: Notice: Connected to 192.168.2.97
Sep 24 19:23:40 raspberrypi lircd-0.9.4c[2840]: Notice: accepted new client from 192.168.2.97
Sep 24 19:23:40 raspberrypi lircd-0.9.4c[2840]: Info: Cannot configure the rc device for /dev/lirc0

here is my /etc/lirc/lirc_options.conf file

These are the default options to lircd, if installed as

/etc/lirc/lirc_options.conf. See the lircd(8) and lircmd(8)

manpages for info on the different options.

Some tools including mode2 and irw uses values such as

driver, device, plugindir and loglevel as fallback values

in not defined elsewhere.

[lircd]
nodaemon = False
driver = default
device = /dev/lirc0
output = /var/run/lirc/lircd
pidfile = /var/run/lirc/lircd.pid
plugindir = /usr/lib/arm-linux-gnueabihf/lirc/plugins
permission = 666
allow-simulate = No
repeat-max = 600
#effective-user =
listen = 192.168.2.97:8766
connect = 192.168.2.97:8766
#loglevel = 6
#uinput = …
#release = …
#logfile = …

[lircmd]
uinput = False
nodaemon = False

[modinit]

code = /usr/sbin/modprobe lirc_serial

code1 = /usr/bin/setfacl -m g:lirc:rw /dev/uinput

code2 = …

[lircd-uinput]

and my /lib/systemd/system/lircd.service file
[Unit]
Documentation=man:lircd(8)
Documentation=http://lirc.org/html/configure.html
Description=Flexible IR remote input/output application support
Wants=lircd-setup.service
After=network.target lircd-setup.service

[Service]
Type=simple
ExecStart=/usr/sbin/lircd --nodaemon --driver=default --device=/dev/lirc0 --listen=192.168.2.97:8766
; User=lirc
; Group=lirc

; Hardening opts, see systemd.exec(5). Doesn’t add much unless
; not running as root.
;
; # Required for dropping privileges in --effective-user.
; CapabilityBoundingSet=CAP_SETEUID
; MemoryDenyWriteExecute=true
; NoNewPrivileges=true
; PrivateTmp=true
; ProtectHome=true
; ProtectSystem=full

[Install]
WantedBy=multi-user.target

my items:


```Number          GF_Living_Remote                        ""                                                                              <none>                        $
String IR_command "IR_command [%s]" { channel="lirc:remote:local:RGB:event" }
String Remote_RGB { channel="lirc:remote:local:RGB:transmit" }
Switch Remote_RGB { channel="lirc:remote:local:RGB:transmit" }

my rules:rule "Remote RGB"
  when
    Item Reciever received command
  then
     if(receivedCommand == KEY_B)
     {   lirc.apply("RGB", "KEY_B", logName)

     }
     else
     {
     if(receivedCommand == KEY_R)
     }   lirc.apply("RGB", "KEY_R", logName)

end


my things:

 
Bridge lircd:bridge:local [ host="192.168.2.97", port="8766" ] {
    Thing remote RGB [ remote="RGB" ]
}

I want to control my RGB led light from HABPANEL, when I press the switch button nothing happens,, my PAPERUI has already discovered my RGBremote 

THANKS FOR ANY HELP IN ADVANCED