IRtrans binding - Parsing is skipped

Hi,

I have set up the IRtrans binding successfully a few days ago. What I have noticed yesterday and today is that after a while (I don’t know the exact trigger), the openhab.log starts to fill with the INFO/WARN messages below. The OpenHAB process also consumes 95% of the CPU (a Synology DS415+ with a quadcore 2.4Ghz CPU). I can only stop it by stopping and re-starting OpenHAB.

An extract from the error log:

2017-05-15 13:10:27.412 [INFO ] [ing.tcp.AbstractSocketChannelBinding] - The channel for /192.168.3.14:21000 is now connected
2017-05-15 13:10:27.692 [INFO ] [ing.tcp.AbstractSocketChannelBinding] - The channel for /192.168.3.14:21000 is now connected
2017-05-15 13:10:27.946 [INFO ] [ing.tcp.AbstractSocketChannelBinding] - The channel for /192.168.3.14:21000 is now connected
2017-05-15 13:10:28.201 [INFO ] [ing.tcp.AbstractSocketChannelBinding] - The channel for /192.168.3.14:21000 is now connected
2017-05-15 13:10:28.441 [WARN ] [ding.irtrans.internal.IRtransBinding] - Did not receive an answer from the IRtrans device - Parsing is skipped
2017-05-15 13:10:28.455 [INFO ] [ing.tcp.AbstractSocketChannelBinding] - The channel for /192.168.3.14:21000 is now connected
2017-05-15 13:10:28.695 [WARN ] [ding.irtrans.internal.IRtransBinding] - Did not receive an answer from the IRtrans device - Parsing is skipped
2017-05-15 13:10:28.708 [INFO ] [ing.tcp.AbstractSocketChannelBinding] - The channel for /192.168.3.14:21000 is now connected
2017-05-15 13:10:28.962 [INFO ] [ing.tcp.AbstractSocketChannelBinding] - The channel for /192.168.3.14:21000 is now connected
2017-05-15 13:10:29.215 [INFO ] [ing.tcp.AbstractSocketChannelBinding] - The channel for /192.168.3.14:21000 is now connected
2017-05-15 13:10:29.443 [WARN ] [ding.irtrans.internal.IRtransBinding] - Did not receive an answer from the IRtrans device - Parsing is skipped

I only use IRtrans to send IR commands, not to receive them. These are my items:

Switch IRtrans_EV_Ontspanningsruimte_Projector					"Epson Projector - Aan/Uit"					<projector_benq>				(gEV_Ontspanningsruimte, gIRtrans) 	{ irtrans="[ON:192.168.3.14:21000:*:Epson:Power], [OFF:192.168.3.14:21000:*:Epson:Power]" }
Switch IRtrans_EV_Ontspanningsruimte_Projector_PlayPause		"Epson Projector - Afspelen"				<projector_benq>				(gEV_Ontspanningsruimte, gIRtrans) 	{ irtrans="[ON:192.168.3.14:21000:*:Epson:Play], [OFF:192.168.3.14:21000:*:Epson:Pause]" }
Switch IRtrans_EV_Ontspanningsruimte_Projector_Stop				"Epson Projector - Stop"					<projector_benq>				(gEV_Ontspanningsruimte, gIRtrans) 	{ irtrans="[ON:192.168.3.14:21000:*:Epson:Stop], [OFF:192.168.3.14:21000:*:Epson:Stop]" }
Switch IRtrans_EV_Ontspanningsruimte_Projector_Mute				"Epson Projector - Mute"					<soundvolume_mute>				(gEV_Ontspanningsruimte, gIRtrans) 	{ irtrans="[ON:192.168.3.14:21000:*:Epson:Mute], [OFF:192.168.3.14:21000:*:Epson:Mute]" }
Switch IRtrans_EV_Ontspanningsruimte_Projector_HDMI1			"Epson Projector - HMDI1"					<video>							(gEV_Ontspanningsruimte, gIRtrans) 	{ irtrans="[ON:192.168.3.14:21000:*:Epson:HDMI1], [OFF:192.168.3.14:21000:*:Epson:HDMI1]" }
Switch IRtrans_EV_Ontspanningsruimte_Projector_Volume			"Epson Projector - Volume"					<soundvolume>					(gEV_Ontspanningsruimte, gIRtrans) 	{ irtrans="[ON:192.168.3.14:21000:*:Epson:VolumeUp], [OFF:192.168.3.14:21000:*:Epson:VolumeDown]" }

I have one rule that sends out an IR command. However, that rule was not even triggered today.

OpenHAB remains functioning, but is extremely slow.

So for now, it seems that these messages start at random.

Does anyone know the cause of this problem?

Hi,
After trying out many different configuration options, I gave up.

I removed the IRTrans binding, and installed the HTTP binding. I now send the IR commands using HTTP:

Switch IRtrans_EV_Ontspanningsruimte_Projector					"Epson Projector - Aan/Uit"					<projector_benq>				(gEV_Ontspanningsruimte, gIRtrans) 	{ http=">[ON:GET:http://192.168.3.14/send.htm?remote=Epson&command=PowerOn] >[OFF:GET:http://192.168.3.14/send.htm?remote=Epson&command=PowerOff]" }
Switch IRtrans_EV_Ontspanningsruimte_Projector_PlayPause		"Epson Projector - Afspelen"				<projector_benq>				(gEV_Ontspanningsruimte, gIRtrans) 	{ http=">[ON:GET:http://192.168.3.14/send.htm?remote=Epson&command=Play] >[OFF:GET:http://192.168.3.14/send.htm?remote=Epson&command=Pause]" }
Switch IRtrans_EV_Ontspanningsruimte_Projector_Stop				"Epson Projector - Stop"					<projector_benq>				(gEV_Ontspanningsruimte, gIRtrans) 	{ http=">[ON:GET:http://192.168.3.14/send.htm?remote=Epson&command=Stop] >[OFF:GET:http://192.168.3.14/send.htm?remote=Epson&command=Stop]" }
Switch IRtrans_EV_Ontspanningsruimte_Projector_Mute				"Epson Projector - Mute"					<soundvolume_mute>				(gEV_Ontspanningsruimte, gIRtrans) 	{ http=">[ON:GET:http://192.168.3.14/send.htm?remote=Epson&command=Mute] >[OFF:GET:http://192.168.3.14/send.htm?remote=Epson&command=Mute]" }
Switch IRtrans_EV_Ontspanningsruimte_Projector_HDMI1			"Epson Projector - HMDI1"					<video>							(gEV_Ontspanningsruimte, gIRtrans) 	{ http=">[ON:GET:http://192.168.3.14/send.htm?remote=Epson&command=HDMI1] >[OFF:GET:http://192.168.3.14/send.htm?remote=Epson&command=HDMI1]" }
Switch IRtrans_EV_Ontspanningsruimte_Projector_Volume			"Epson Projector - Volume"					<soundvolume>					(gEV_Ontspanningsruimte, gIRtrans) 	{ http=">[ON:GET:http://192.168.3.14/send.htm?remote=Epson&command=VolumeUp] >[OFF:GET:http://192.168.3.14/send.htm?remote=Epson&command=VolumeDown]" }

The only disadvantage of not using the IRTrans binding (I think) is that I cannot receive IR commands (and let OpenHAB react on it), but since I only use it in the other direction (OpenHAB sending IR commands), that is acceptable for me.

1 Like