Is the MiOS binding auto-install working in OpenHAB2?


First, I haven’t posted much since the forums are so great, and OH so stable, when you finally have clearad the first little hill. Now I am a little bit stuck in moving from 1.9 to 2.0 but I am sure I will get some help soon :slight_smile:

Now, I have a problem getting the MiOS binding to auto-install in OpenHAB2 as it should according to the documentation here:
"When you save this file openHAB will begin the download (if using the Online version) and installing the add-ons."

Here is my addons.cfg file:

# The installation package of this openHAB instance
# Note: This is only regarded at the VERY FIRST START of openHAB
# Note: If you want to specify your add-ons yourself through entries below, set the package to "minimal"
# as otherwise your definition might be in conflict with what the installation package defines.
# Optional. If not set, the dashboard (https://<yourserver>:8080/) will ask you to choose a package.
# Valid options:
#   - minimal  : Installation only with dashboard, but no UIs or other add-ons. Use this for custom setups.
#   - simple   : Setup for using openHAB purely through UIs - you need to expect MANY constraints in functionality!
#   - standard : Default setup for normal users, best for textual setup
#   - expert   : Setup for expert users, especially for people migrating from openHAB 1.x
#   - demo     : A demo setup which includes UIs, a few bindings, config files etc.
# See for a detailed explanation of these packages.
package = expert

# Access Remote Add-on Repository
# Defines whether the remote openHAB add-on repository should be used for browsing and installing add-ons.
# This not only makes latest snapshots of add-ons available, it is also required for the installation of
# any legacy 1.x add-on. (default is true)
remote = true

# Include legacy 1.x bindings. If set to true, it also allows the installation of 1.x bindings for which there is 
# already a 2.x version available (requires remote repo access, see above). (default is false)
legacy = true

# A comma-separated list of bindings to install (e.g. "sonos,knx,zwave")
binding = mios

# A comma-separated list of UIs to install (e.g. "basic,paper")
ui = habmin,habpanel

# A comma-separated list of persistence services to install (e.g. "rrd4j,jpa")
#persistence = 

# A comma-separated list of actions to install (e.g. "mail,pushover")
#action = 

# A comma-separated list of transformation services to install (e.g. "map,jsonpath")
transformation = xslt,exec,regex,jsonpath,map

# A comma-separated list of voice services to install (e.g. "marytts,freetts")
#voice = 

# A comma-separated list of miscellaneous services to install (e.g. "myopenhab")
#misc = 

  • I have installed the mios map transformations to the best of my abilities.
  • I added the “zwave” binding to the addons.cfg file and it downloaded correctly according to the logs. (removed it again in the file above to make troubleshooting easier)
  • I have tried the spelling of “mios” and “MiOS” in the config file.
  • I do not get any errors in the logs from what I can see

All this, but no “mios.cfg” file pops up in the services directory as it should according to the docs… what am I doing wrong? Appreciate any help!

  • I guess the next thing to try is to create a mios.cfg file myself and see if things start moving from there…

Thanks for reading all the way to the end… /Daniel

I have the binding running with OH2.

I followed these directions (using the mios.cfg instead of openhab.cfg)::

1 Like

It’s a 1.x binding, so the name has to have a suffixed 1:

binding = mios1

See also: Initial package selection and changed add-on ids

1 Like

Ok, thanks alot! Missed that post from Kai. Will try the fix tonight and put this as solved if it does.

Regarding the documentation that I linked to, can I edit it myself?


Yes, you can find the information how to edit here:

As an alternative you may open an issue on the issue tracker:

But I would not recommended to edit each and every 1.x binding wiki to add that information.
It should be in an overview in the bindings section, although I can’t find it at the moment, it was in there some time before :sunglasses:

1 Like

I did my install via the PaperUI, where you can select that you want the MiOS Binding to be installed (v1)

It installs correctly from there, although it doesn’t show in the dashboard, and the mios.cfg file is exposed for manual editing at the command line.

1 Like

Well, I tried sihui’s soluition by adding the “1” at the end of the “mios” name, so the line in “addons.cfg” becomes:

“binding = mios1”.

The config file “mios.cfg” popped up as expected in the services folder. Great stuff. I will now try to edit the page I referenced in my first post if possible.

Hats of to all the answers. Thanks a lot yall. /Daniel

As I already said: that does not make any sense. Do you also want to edit all the other 100 1.x bindings with that information?
It needs to be in a centralized section:

For the record, the only page I have referred to is the migration tutorial mentioned in my first post (not the MiOS binding page). That´s the one I would like to edit, but lost my nerve when I read the Git instructions… :slight_smile:


Hello, I am new to openHAB so forgive me If my question is stupid. I have hue working with no problem. I can’t seem to get veraedge working. I am sure this is because I don’t fully understand the process of getting it setup. I am using paper ui and I have the mios binding installed. mios.cfg was created and I configured it. Under transform there are some mios .map files that was auto created. I am not sure what I need to do next. Please point me in the right direction.

Thanks in advance