Is the OH Cloud down and problematic today?


(Matt) #1

I’ve been losing connectivity with the OH Cloud all day. Both from home and from my mobile devices while out and about. Is something wrong?


MyOpenHab cloud - ERROR Request failed: internal server error (500)
(Maurits) #2

See for yourself


(Michael Portz) #3

Hi, i had the same issue today. After restarting OH it works again. In my log are several posts:

2019-01-26 02:08:14.146 [INFO ] [io.openhabcloud.internal.CloudClient] - Disconnected from the openHAB Cloud service (UUID = 7b9c3f74-c8e8-4903-a535-4d43c1dcb671, base URL = http://localhost:8080)
2019-01-26 02:08:47.138 [ERROR] [io.openhabcloud.internal.CloudClient] - Socket.IO error: {}
io.socket.engineio.client.EngineIOException: xhr poll error
at io.socket.engineio.client.Transport.onError(Transport.java:71) [230:org.openhab.io.openhabcloud:2.4.0]
at io.socket.engineio.client.transports.PollingXHR.access$100(PollingXHR.java:19) [230:org.openhab.io.openhabcloud:2.4.0]
at io.socket.engineio.client.transports.PollingXHR$6$1.run(PollingXHR.java:124) [230:org.openhab.io.openhabcloud:2.4.0]
at io.socket.thread.EventThread$2.run(EventThread.java:80) [230:org.openhab.io.openhabcloud:2.4.0]
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:?]
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:?]
at java.lang.Thread.run(Thread.java:748) [?:?]
Caused by: java.io.IOException: 502
at io.socket.engineio.client.transports.PollingXHR$Request$1.run(PollingXHR.java:218) ~[?:?]
… 1 more


(Marco) #4

Same problem here. No connection via myopenhab.


(Davide ) #5

me too, in the last 12 hours
i had to delete temp and cache folder and restart the system
now works


(Marco) #6

Great… And I am on a holiday trip :disappointed_relieved:


(Davide ) #7

unfortunately the problem is repeated.
I’ve already done this procedure in the past few days. It works for one or two days and then stops working


(Wouter Born) #8

I had the same issue yesterday and after restarting the Cloud Connector bundle the Cloud registered my instance as online again.

The issue is that the cloud connection is properly reestablished after these disconnects… but the Cloud just keeps your instance as marked offline.

See also:


(Simon) #9

Same here, restarting the cloud service solved it for me too.


(Michael Ingraham) #10

Restarting the bundle has worked for me. But today restarting still doesn’t bring it online. Are there any issues with myopenhab.org?


(Patric) #11

Hi, i can’t connect to the cloud either since yesterday. Connection to myopenhab.org works fine and it says i am connected, but home.myopenhab.org gives only a timeout (504). Restarting does not help at all. Am I the only one with this problems?


(Patric) #12

Hi, i found my problem. It was sitting in front of the monitor…
Im using OH 2.5 and didn’t updated it for a long time. Yesterday i updated it and it seems that the setting “Mode” was fixed. I had it always on “notification” only, since it made no difference anyway.

Now it’s working the way it’s supposed to. With notification only there is no connection to OH -> 504 Timeout.


(Matt) #13

I solved this problem by not using the OH Cloud anymore :slight_smile: Constantly up and down, extremely slow, and some functions just completely non-functional. It’s free, so I’m not complaining or demanding it be fixed. It just is what it is and that’s the reality of it.

I use reverse proxy now everything works perfectly all the time.